SX160IS bad pixels on DNGs

  • 6 Replies
  • 990 Views
*

Offline dvip

  • ****
  • 451
SX160IS bad pixels on DNGs
« on: 01 / October / 2015, 21:45:20 »
Advertisements
I'm using DNG 1.1 on the SX160IS and noticed that bad pixels will show on the dng file but not on the jpg.

Here is what I have done:
- I created badpixel.bin
- use Manual bad pixel removal [Average.]
- DNG version 1.1

Am I missing something to get rid of the bad pixels on DNGs?


*

Offline dvip

  • ****
  • 451
Re: SX160IS bad pixels on DNGs
« Reply #1 on: 01 / October / 2015, 23:59:05 »
This is what the pixel looks like on the upper left corner. Please take a look at 100%.
This image is a crop from the raw DNG file. The JPG doesn't show the dead pixel at all.
Although, It looks more like a white hot pixel.

It looks like DNGs from the SX160IS have a vignette and a lot of chroma noise in low light, even at iso 100. But RawTherapee helps big time.
« Last Edit: 03 / October / 2015, 19:54:44 by dvip »

*

Offline reyalp

  • ******
  • 11394
Re: SX160IS bad pixels on DNGs
« Reply #2 on: 02 / October / 2015, 15:42:30 »
This is what the pixel looks like on the upper left corner. Please take a look at 100%.
This image is a crop from the raw DNG file. The JPG doesn't show the dead pixel at all.
Although, It looks more like a white hot pixel.

It looks like DNGs from the SX160IS have a vignette and a lot of chroma noise in low light, even at iso 100. But RawTherapee helps big time.
It would be helpful if you can upload a sample DNG somewhere (too large for the forum, use dropbox, box.com, google drive etc).

DNG 1.3 + badpixel.bin will not fix hot pixels. For "manual badpixel removal" you need to create a file with a list of the hot pixels. The old show_bad tool mentioned on the wiki doesn't work on most modern cameras, but you can use chdkptp: https://www.assembla.com/spaces/chdkptp/wiki/DNG_Processing#generating_badpixel_lists

If you are using raw therapee, the "dead / hot pixel" setting  on the raw tab does a pretty reasonable job without a list.

I agree, this camera has quite a lot of noise at base ISO, and a lot of lens problems: Vignetting, distortion, chromatic aberration. The raw therapee chromatic aberration correction does a much better job than the Canon jpeg.
Don't forget what the H stands for.

*

Offline dvip

  • ****
  • 451
Re: SX160IS bad pixels on DNGs
« Reply #3 on: 02 / October / 2015, 19:43:08 »
reyalp,
Here is a link to a DNG file.
It is dark enough to see the hot pixel on the upper left corner:

https://drive.google.com/file/d/0B3gf3da5LdLiR0J2bE51cHV3U0E/view?usp=sharing

Yes, I've been using RawTherapee to deal with dead/hot pixels, vignetting, distortion, noise, and chromatic aberration, and it does a nice job.   Just wish the DNG were dead/hot pixel free.


*

Offline reyalp

  • ******
  • 11394
Re: SX160IS bad pixels on DNGs
« Reply #4 on: 03 / October / 2015, 15:58:50 »
Just wish the DNG were dead/hot pixel free.
If raw therapee fixes it them, then what difference does it make? Either way, the hot pixels are being interpolated over.

If it doesn't fix them completely, then you can take a dark frame and generate a hot pixel list.

From your sample DNG, the number of hot pixels seems normal to me.
Don't forget what the H stands for.

*

Offline dvip

  • ****
  • 451
Re: SX160IS bad pixels on DNGs
« Reply #5 on: 03 / October / 2015, 19:54:03 »
Ok, thanks for checking it out.

*

Offline dvip

  • ****
  • 451
Re: SX160IS bad pixels on DNGs
« Reply #6 on: 05 / October / 2015, 19:28:21 »
Got it done in chdkptp-r658-win32 with:
dnglistpixels -min=4095 -out=badpixel.txt -fmt=chdk
But, yes, RawTherapee does it as well.
Next, deal with chromatic aberration.
And need to find a PowerShot SX160IS-RAW.lcp lens correction profile.
...having fun fixing it all :)

 

Related Topics