"Disable LCD Off" setting bug

  • 5 Replies
  • 1337 Views
*

Offline TMHKR

  • **
  • 77
  • Canon PowerShot SX170 IS (1.01a firmware)
"Disable LCD Off" setting bug
« on: 18 / October / 2015, 16:09:15 »
Advertisements
Hello. I would like to report a small, but sometimes very annoying bug.

If you set the "Disable LCD Off" setting to "Alt", the screen won't turn off while the red "ALT" text is displayed on screen. And that's OK.

However, if you enter CHDK menus, it seems that you're no longer considered to be in ALT mode, and screen will turn itself off after a minute or so.

I hate it when the screen turns off while I'm setting parameters in CHDK menus. I hope you can fix it - if "Disable LCD Off" is set to "Always" or "Alt", the screen should stay on when CHDK menus are displayed.

Camera: SX170
Firmware: 1.01a
CHDK: latest autobuild 1.3

*

Offline reyalp

  • ******
  • 11496
Re: "Disable LCD Off" setting bug
« Reply #1 on: 18 / October / 2015, 18:09:51 »
However, if you enter CHDK menus, it seems that you're no longer considered to be in ALT mode, and screen will turn itself off after a minute or so.

I hate it when the screen turns off while I'm setting parameters in CHDK menus. I hope you can fix it - if "Disable LCD Off" is set to "Always" or "Alt", the screen should stay on when CHDK menus are displayed.
Thanks for the report. Is there a particular menu this happened with?

I wasn't able to reproduce this on d10 with the main CHDK menu sitting open in 1.4. I haven't checked 1.3 yet, but offhand I don't remember any changes in this area.
Don't forget what the H stands for.

*

Offline TMHKR

  • **
  • 77
  • Canon PowerShot SX170 IS (1.01a firmware)
Re: "Disable LCD Off" setting bug
« Reply #2 on: 19 / October / 2015, 08:44:53 »

Thanks for the report. Is there a particular menu this happened with?

I wasn't able to reproduce this on d10 with the main CHDK menu sitting open in 1.4. I haven't checked 1.3 yet, but offhand I don't remember any changes in this area.

Nope, it happens in all CHDK menus.

And what's worse - when the screen turns off, you can't turn it on simply by pressing any button. First you need to exit the ALT mode, and THEN you can press any button to turn the screen back on.

With that said, it would seem that ALT mode actually IS enabled while the CHDK menus are displayed. But nevertheless - if the CHDK menus are open, and "Disable LCD Off" is set to "Alt", the screen turns off after time period you've set in Canon menus has passed.

You say you can't reproduce this bug, perhaps you've disabled the automatic screen off setting in the Canon menus?
« Last Edit: 19 / October / 2015, 08:46:54 by TMHKR »

*

Offline srsa_4c

  • ******
  • 3689
Re: "Disable LCD Off" setting bug
« Reply #3 on: 19 / October / 2015, 13:44:09 »
Some questions.
- If you set "Disable LCD Off" to 'always', does the camera go to sleep (in non-ALT mode, in ALT mode, in CHDK menu)?
- What happens if you start a module (such as calendar, file browser, etc.) and leave it running?

And what's worse - when the screen turns off, you can't turn it on simply by pressing any button. First you need to exit the ALT mode, and THEN you can press any button to turn the screen back on.
Since ALT mode blocks the keyboard from the firmware, this is expected. However, the orientation sensor isn't blocked, so you should be able to wake up the cam by tilting it.


*

Offline TMHKR

  • **
  • 77
  • Canon PowerShot SX170 IS (1.01a firmware)
Re: "Disable LCD Off" setting bug
« Reply #4 on: 19 / October / 2015, 14:32:46 »
Some questions.
- If you set "Disable LCD Off" to 'always', does the camera go to sleep (in non-ALT mode, in ALT mode, in CHDK menu)?
- What happens if you start a module (such as calendar, file browser, etc.) and leave it running?

However, the orientation sensor isn't blocked, so you should be able to wake up the cam by tilting it.

Test results, measured by stopwatch:

Canon menu screen off period = 1 minute

Disable LCD Off = Always
  Non-ALT mode = stays awake
  ALT mode = stays awake
  CHDK main menu = stays awake
  Module (file browser) = stays awake

Disable LCD Off = Alt
  Non-ALT mode = turns off
  ALT mode = stays awake
  CHDK main menu = stays awake
  Browsing through various CHDK menus = stays awake
  Module (file browser) = stays awake
  Module (calendar) = stays awake

Wake by tilting the camera = works

I don't understand, it didn't work yesterday... If it happens again, I will report here what was I doing when it happened.

*

Offline reyalp

  • ******
  • 11496
Re: "Disable LCD Off" setting bug
« Reply #5 on: 19 / October / 2015, 15:58:30 »
Thanks.

I had "Auto power down" set to "ON" and "Display off" set to "1 min" in the power saving menu. I verified that it went off when not in alt or menu. Note on D10 at least, this only appears to happened in rec mode. It would sit indefinitely with the display on in playback.

I was running the camera on an external power supply. I'm not aware that this changes the camera behavior, but it's not impossible.

It also wouldn't be too surprising if having PTP connected or using PTP mode switching changed the behavior in some way. My tests were done without PTP.
Don't forget what the H stands for.

 

Related Topics