supplierdeeply

"error: missing modules"

  • 5 Replies
  • 2648 Views
"error: missing modules"
« on: 15 / November / 2015, 13:21:06 »
Advertisements
Hi,

I'm trying to install CHDK on my PowerShot SX40HS using a bootable SD card. I'm using STICK.
Everything seems to go fine (according to STICK), but when i'm inserting the SD card into the camera, i have "error: missing modules" poping up, and CHDK doesn't load.

How can I know what is the missing module(s), or when do find it/them ?
I'm stuck here :(
 
I had the issue downloading the sx40hs-100i-1.3.0-4272-full realease, as well as letting STICK choose automatically.

Many thanks !

*

Offline reyalp

  • ******
  • 11335
Re: "error: missing modules"
« Reply #1 on: 15 / November / 2015, 14:43:08 »
This error happens if you don't have all the file sin the correct location on your SD card. Modules (.flt files) should be in CHDK/MODULES/

This can happen if you put the modules on the wrong partition of a multi-partition card, but SX40 supports booting from FAT32 and does not support multi-partition. Stick should get this right, but maybe looking at the card with a card reader will give some clue as to what is wrong.

Quote
Everything seems to go fine (according to STICK), but when i'm inserting the SD card into the camera, i have "error: missing modules" poping up, and CHDK doesn't load.
If you see this error, CHDK is actually loaded and running, but many functions won't be available because it can't load the module files.
Don't forget what the H stands for.

Re: "error: missing modules"
« Reply #2 on: 18 / November / 2015, 15:56:36 »
Hi,

Thanks for your answer.

Quote
This error happens if you don't have all the file sin the correct location on your SD card. Modules (.flt files) should be in CHDK/MODULES/

They are files in that folder

Quote
This can happen if you put the modules on the wrong partition of a multi-partition card, but SX40 supports booting from FAT32 and does not support multi-partition. Stick should get this right, but maybe looking at the card with a card reader will give some clue as to what is wrong.

So I tried to force a FAT32 unique partition using  LICKS. Then when i boot my camera, I have the message "sd card is locked", and see nothing about CHDK appearing. (If SD card is unlocked, the camera boot normally, under the canon firmware).
I didn't find the possibility to force FAT16/32 using stickx. Maybe it's me ?

Quote
If you see this error, CHDK is actually loaded and running, but many functions won't be available because it can't load the module files.

Doesn't look like so, because i can navigate under Canon's menu ..?

Thanks again for your help !

*

Offline reyalp

  • ******
  • 11335
Re: "error: missing modules"
« Reply #3 on: 18 / November / 2015, 17:07:20 »
So I tried to force a FAT32 unique partition using  LICKS. Then when i boot my camera, I have the message "sd card is locked", and see nothing about CHDK appearing. (If SD card is unlocked, the camera boot normally, under the canon firmware).
It sounds like the partition was not made bootable. Note this is the canon BOOTDISK string which is written and different offsets of the boot sector for FAT16 and FAT32, not any normal bootable flag you would find in fdsik etc.

You can try loading with the firm update method and making the card bootable within CHDK.
http://chdk.wikia.com/wiki/%22firmware_update_method%22

Quote
I didn't find the possibility to force FAT16/32 using stickx. Maybe it's me ?
I don't know, I don't personally use either any of these utilities. If you are using linux, you can format the card with a single FAT32 partition and set the BOOTDISK flag using dd.

Quote
Quote
If you see this error, CHDK is actually loaded and running, but many functions won't be available because it can't load the module files.

Doesn't look like so, because i can navigate under Canon's menu ..?
If you see anything on the display from CHDK, then CHDK is running. CHDK does not block access to the canon UI, you need to enter "alt" mode to access the CHDK menu, see http://chdk.wikia.com/wiki/CHDK_User_Manual. That said, if the modules aren't available, CHDK won't be very functional.
Don't forget what the H stands for.


*

Offline zeno

  • *****
  • 882
Re: "error: missing modules"
« Reply #4 on: 19 / November / 2015, 04:39:15 »
While STICK tries to do the right thing, it can get confused, particularly if there are already partitions on the card.

I suggest you reformat the card, using the camera's Canon menu. This will make sure that there's a single partition on the card. It's much more reliable than using Windows and a card reader to do it. Then run STICK again.
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

Re: "error: missing modules"
« Reply #5 on: 22 / November / 2015, 16:18:17 »
Hi,

Thanks guys, it finally worked ! I used the firmware update method. I format the sd card using the camera, but i dont think it was the important point.  Then i copied/pasted all the package folder i downloaded to the sd card, and bam ! It works.
For newbie like me, note that for the firmware method, the sd card must not be locked while in the camera.

Thanks again for your help :) now i have to play with my camera :p

 

Related Topics