fixedint.lua: Astrophotography oriented script for long exposure + timelapse - page 4 - Completed and Working Scripts - CHDK Forum

fixedint.lua: Astrophotography oriented script for long exposure + timelapse

  • 35 Replies
Thanks Reyalp,
  I will try the glue script as you suggest.  This seems like a neat way to do it.  I like the options in your script.

  This is diverging off-topic, but one of the reasons I want to use the CHDKptp is so that I can set the focus, take a picture, then set the focus at a slightly different point, and take another picture... and see where the focus is sharpest.   But I am getting confused by all the different units. 

   Is there a way to interrogate the camera to determine what the focus point is set to?  Then I can focus at infinity or set it to scene mode, and see what value it reports.  I'd use that as a starting value and bracket around it.

   I've found that 'luar set_focus(-1)' does not result in consistently focused images.  But I am not sure how the camera knows to translate '-1' to "infinity".   It seems to me to be more robust to set_focus(xxxx), but first I need to determine what value of xxxx corresponds to true focus at infinity.  (I'm also making another assumption here, that the lens is generally capable of going beyond infinity.  It must be able to for optical focus of a distant subject to be able to work.   So I am not sure what "set the focus to infinity" means, unless the camera is somehow taught at what point the lens should be set.)

  Ok, thanks again for the speedy reply!

p.s.  Thanks.  First attempt at the NA nebula.   It's about 30 or so good shoots.  I hope to collect another 30 shots when it clears up on Wednesday.   Might be my last attempt before it's too cold and Deneb is blocked by the house.  I was working on my deck!   The pink on the right is amplifier glow, so I need to take more dark shots as well.  I am using deep sky stacker and I have a polar-aligned tracker.


Offline reyalp

  • ******
  • 14098
I split the rest of the discussion about focus to since it's mostly not specific to this script
Don't forget what the H stands for.

Hi, relatively new user of CHDK and scripts.

I loaded CHDK 1.4.1 on my Canon G10 fine. I then tried to use the fixedint.lua script, but it reports an error as follows:

*** STARTED ***
uBASIC:1 Unk stmt
***Terminated ***

Other scripts work ok. I have reset CHDK settings to default with no success. Any ideas?


That error almost always means the script filename is messed up somehow.  If the filename extension is not  .lua    then CHDK tries to run it as a uBASIC script instead of as a Lua script.
Ported :   A1200    SD940   G10    Powershot N    G16

Bingo. Something with how my MAC saved the file. Now have a card reader on my windows machine and fixed it.  Thanks!!!


Related Topics

SimplePortal 2.3.6 © 2008-2014, SimplePortal