EOS M10 dump

  • 17 Replies
  • 8254 Views
*

Offline axman

  • ***
  • 138
  • Publish
    EOS M10 dump
    « on: 15 / February / 2016, 13:38:47 »
    Advertisements
    Standard dump instructions worked fine.  Url below is untested but should work, pls advise if trouble.
    https://www.dropbox.com/s/7c1imq0yo9q275o/PRIMARY.BIN?dl=0
    Casual 'strings -a' shows lots of readable ascii, a lot of stuff for TCP/IP stack because of wifi capability, I guess.
    dumper log:
    Code: [Select]
    Started
    FC000000 dry
    done
    « Last Edit: 18 / January / 2017, 14:44:05 by acseven »

    *

    Offline reyalp

    • ******
    • 10700
  • Publish
    Re: EOS M10 dump
    « Reply #1 on: 15 / February / 2016, 14:23:20 »
    Thanks, this confirms (as expected) that EOS M10 is built on the P&S codebase like EOS M3, not on the DSLR codebase like earlier EOS cams.

    DryOS R57, firmware version 100a.
    Don't forget what the H stands for.

    *

    Offline fe50

    • ******
    • 3069
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: EOS M10 dump
    « Reply #2 on: 21 / February / 2016, 07:09:41 »
    Since the EOS M10 is built on the P&S codebase...
    Added the
    • EOS M10 1.00A
    full 32MB dump by axman from this forum post to the CHDK P&S FW dumps repository (Section "DSLR FW Dumps").

  • Publish
    Re: EOS M10 dump
    « Reply #3 on: 19 / January / 2017, 10:48:03 »
    Can you guys tell me what I'm doing wrong?
    My M10 is just not loading anything.

    I used a 8GB SD card, made a 4GB partition, prepared it according to the instructions, put it in, started the cam in Play mode. Nothing happens. The cam just let's me operate it normally. No freeze, no messages, no sign that anything happened.


    *

    Offline srsa_4c

    • ******
    • 3453
  • Publish
    Re: EOS M10 dump
    « Reply #4 on: 19 / January / 2017, 19:53:36 »
    I used a 8GB SD card, made a 4GB partition
    You don't need smaller partition. Scripts work on bigger cards/partitions too (FAT or FAT32).
    Quote
    , prepared it according to the instructions
    What OS are you using and which instructions did you follow? The dumper script is here.
    Quote
    , put it in, started the cam in Play mode. Nothing happens. The cam just let's me operate it normally. No freeze, no messages, no sign that anything happened.
    You need to press the SET button to start the script. You'll get orange text (potentially covered by Canon OSD) on the top of the LCD when the script runs.

  • Publish
    Re: EOS M10 dump
    « Reply #5 on: 19 / January / 2017, 21:34:12 »
    OK it worked. I didn't know about pressing the "SET" button.

    Please find my FW Dump of my M10 with the FW 1.1.0
    https://www.dropbox.com/s/wj992fgjbtbbc3c/PRIMARY.BIN?dl=0

    Code: [Select]
    Started
    FC000000 dry
    done
    « Last Edit: 19 / January / 2017, 21:36:14 by br_andi »

    *

    Offline fe50

    • ******
    • 3069
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: EOS M10 dump
    « Reply #6 on: 08 / February / 2017, 12:13:16 »
    Thanks for the dump - firmware version 1.10D
    Added the
    • EOS M10 1.10D
    full 32MB dump by br_andi from this forum post to the CHDK P&S FW dumps repository.

  • Publish
    Re: EOS M10 dump
    « Reply #7 on: 13 / April / 2017, 14:03:13 »
    trying to do a firmware dump for M10 firmware 1.1.0f - tried to prepare a SD card using the basic dumper but the dump instructions do not say what to put in the file 'script.req' - can someone lead me to this file content?


    thanks
    Zweistein


    *

    Offline reyalp

    • ******
    • 10700
  • Publish
    Re: EOS M10 dump
    « Reply #8 on: 13 / April / 2017, 14:20:51 »
    http://chdk.wikia.com/wiki/Canon_Basic/Card_Setup

    The file "script.req" must exist on the card's root directory, and must only contain the string "for DC_scriptdisk" (works without any trailing newline character)
    Don't forget what the H stands for.

  • Publish
    Re: EOS M10 dump
    « Reply #9 on: 13 / April / 2017, 14:26:09 »
    ok done - copied 'extend.m' file to root containing the new Basic dumper a well as the 'script.req' file as you described - then running camersa in play mode seems to start the script (card is prepared as 'SCRIPT') but the log file says only:


    Code: [Select]
    Started
    not found!


    greetings
    Zweistein


     

    Related Topics