eos M10 port - page 30 - DryOS Development - CHDK Forum
supplierdeeply

eos M10 port

  • 300 Replies
  • 191298 Views
Re: eos M10 port
« Reply #290 on: 11 / December / 2020, 16:05:25 »
Advertisements
Hello, I have just joined the forum because I found this firmware to "unlock" the possibility of my m10 (mainly timelapse and clean HDMI out).

Unfortunately my m10 is on 1.1.1 firmware and I am not able neither to use the bootable SD (fat32 + EOS SD) or the firmware update method (no possibility from the "playback" startup and camera stuck on black screen if I go directly on the update). Has anyone been able to make it run on 1.1.1?

Otherwise, being a programmer myself, can I help in any way to port the current beta to 1.1.1?

Best regards

*

Offline srsa_4c

  • ******
  • 4426
Re: eos M10 port
« Reply #291 on: 11 / December / 2020, 16:32:29 »
Unfortunately my m10 is on 1.1.1 firmware and I am not able neither to use the bootable SD (fat32 + EOS SD) or the firmware update method (no possibility from the "playback" startup and camera stuck on black screen if I go directly on the update). Has anyone been able to make it run on 1.1.1?

Otherwise, being a programmer myself, can I help in any way to port the current beta to 1.1.1?
Normally I'd say downgrade to the previous official firmware, but that is no longer available on the Canon support site(s).

Can you make a dump of your firmware please?

Re: eos M10 port
« Reply #292 on: 11 / December / 2020, 20:36:24 »
Anyone tried this in Android with camera connect and control from RUPIAPPS? It shows the m10 as compatible. Thanks

Re: eos M10 port
« Reply #293 on: 12 / December / 2020, 06:18:10 »
Can you make a dump of your firmware please?

Here you are: link


*

Offline srsa_4c

  • ******
  • 4426
Re: eos M10 port
« Reply #294 on: 12 / December / 2020, 13:58:35 »
Here you are: link
Thanks, I'll post a test build in a few days.

*

Offline srsa_4c

  • ******
  • 4426
Re: eos M10 port
« Reply #295 on: 13 / December / 2020, 12:11:56 »
Test build for firmware version 111a. Source is in CHDK trunk, autobuild is disabled until feedback comes.

@riccardo
Can you please try this build and report whether it works? If possible, shoot some photos, record some videos, try the firmware update boot method too. If the camera crashes while CHDK is loaded, I'd like to know.

*

Offline c_joerg

  • *****
  • 1147
Re: eos M10 port
« Reply #296 on: 13 / December / 2020, 13:16:44 »
Test build for firmware version 111a. Source is in CHDK trunk, autobuild is disabled until feedback comes.
Just for understanding....
Is there any reason why you don't bring your m10 to the latest firmware?
M100 100a, M3 101a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline srsa_4c

  • ******
  • 4426
Re: eos M10 port
« Reply #297 on: 13 / December / 2020, 13:54:06 »
Is there any reason why you don't bring your m10 to the latest firmware?
I could do it, but why. All my research was done on 110d, 111a doesn't bring features I'd be interested in, firmware update carries a risk greater than zero.


Re: eos M10 port
« Reply #298 on: 14 / December / 2020, 08:48:22 »
Test build for firmware version 111a. Source is in CHDK trunk, autobuild is disabled until feedback comes.

@riccardo
Can you please try this build and report whether it works? If possible, shoot some photos, record some videos, try the firmware update boot method too. If the camera crashes while CHDK is loaded, I'd like to know.

Hello, thank you for the quick build! I will definetly try it this evening or one of the following and update you asap.


EDIT: I just did a quick try using the "update method", everything seems fine: took some pictures and videos without any problems. Checking the battery % and voltage I have even noticed a couple of my "Patona" batteries to be faulty (after a complete charge they're about 45% but drops to 0% in 5-6 mins).
Disabling the Canon native OSD was fine, I have just encountered some problems with Google Duo which doesn't respect the camera image aspect ratio, while VLC/OBS/MS Teams seem to keep it or at least leaving the black upper and lower bands to keep the ratio. But this is definetly a Google Duo issue. I will try the release during the next days, but from I have noticed now, it seems already stable. Thank you for your work!
« Last Edit: 14 / December / 2020, 10:08:37 by riccardo »

*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: eos M10 port
« Reply #299 on: 19 / December / 2020, 05:04:47 »
Added the following dumps to the CHDK DSLR FW dumps repository
...

 

Related Topics