Display (bitmap overlay) - page 33 - General Discussion and Assistance - CHDK Forum

Display (bitmap overlay)

  • 342 Replies
  • 67393 Views
*

Offline srsa_4c

  • ******
  • 4414
Re: Display (bitmap overlay)
« Reply #320 on: 03 / June / 2021, 15:30:16 »
Advertisements
Seeing the same on the G7X2 and G5X - not sure what is going on here.
The rightmost 3rd of the CHDK bitmap image seems to get shifted left to the centre.
@srsa_4c - any thoughts?
I'm still saying that the "scaling bits" we're using are actually something else.

I dumped the ximr struct while recording and found it to be different from idle mode by a bit (literally). The 4th halfword in ximr_context (unk2[0] in case of g5x) is normally 0x500 but becomes 0x100 during recording. I tried modifying it to be always 0x500 and that seemingly worked (I see nothing wrong, but who knows).

*

Offline philmoz

  • *****
  • 3320
    • Photos
Re: Display (bitmap overlay)
« Reply #321 on: 03 / June / 2021, 18:27:46 »
I dumped the ximr struct while recording and found it to be different from idle mode by a bit (literally). The 4th halfword in ximr_context (unk2[0] in case of g5x) is normally 0x500 but becomes 0x100 during recording. I tried modifying it to be always 0x500 and that seemingly worked (I see nothing wrong, but who knows).


Thanks - that works for the G5X and G7X2; but it makes me a little uneasy.


If we had 2MB of free memory for all cameras we could use a full res buffer (960x540x4).
This will also slow down drawing and erasing though.

CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

*

Offline reyalp

  • ******
  • 13231
Re: Display (bitmap overlay)
« Reply #322 on: 03 / June / 2021, 19:54:26 »
FWIW, I noticed on g7x that using analog video out (or force_analog_av) completely breaks both the Canon and CHDK UI. Example screenshot from video capture, with CHDK menu open. I haven't looked further and don't think this is an urgent issue, just noting it as a data point.

In normal video out, the Canon UI dimensions change compared to the LCD, to move the UI elements away from the edges of the screen. The overall viewport buffer dimensions are unchanged, at 720x480
Don't forget what the H stands for.

*

Offline philmoz

  • *****
  • 3320
    • Photos
Re: Display (bitmap overlay)
« Reply #323 on: 03 / June / 2021, 22:14:27 »
FWIW, I noticed on g7x that using analog video out (or force_analog_av) completely breaks both the Canon and CHDK UI. Example screenshot from video capture, with CHDK menu open.


srsa_4c noted that earlier with HDMI output at less than full HD res.
Unfortunately I don't have any way to replicate either case.

CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)


*

Offline CanonUser9000

  • *
  • 27
  • A570 - S95 - S100 - SX220 - SX700 - EOSM
Re: Display (bitmap overlay)
« Reply #324 on: 04 / June / 2021, 04:35:40 »
Quote
Can you check the zebra color settings for over and under exposure (CHDK Settings -> Color Settings).
Make sure they are valid colours and not transparent.

Tested several color combinations w/o any influence.

Quote
Also, the thresholds may need to be adjusted. Some (mostly earlier digic 6) cams use values in the 16-235 ish rather than 0-255, so to see anything in zebra the thresholds need to be large.

 ::) Thats it! Noticable zebra is displayed if thresholds for  underexp>=19  and  overexp>=21

*

Offline reyalp

  • ******
  • 13231
Re: Display (bitmap overlay)
« Reply #325 on: 05 / June / 2021, 15:32:51 »
I added debug_logging_ptr, debug_logging_flag and mzrm_sendmsg_ret_adr to finsig_thumb2. I intentionally did this in the trunk sig finder and merged the changes to the ximr tree. May regret this later, but I think if we keep the actual stubs updates in a separate commit, it should work out ok.

edit:
and FW_YUV_LAYER_BUF as a DEF_CONST

::) Thats it! Noticable zebra is displayed if thresholds for  underexp>=19  and  overexp>=21
It seems like we will probably want a camera.h define / camera_info field to define which variant is used (if it's truly camera specific rather than settings or output device, as it seems to be so far). That would at least allow reasonable defaults for the zebra and histogram limits.

« Last Edit: 05 / June / 2021, 20:12:12 by reyalp »
Don't forget what the H stands for.

*

Offline reyalp

  • ******
  • 13231
Re: Display (bitmap overlay)
« Reply #326 on: 06 / June / 2021, 17:45:03 »
I added support for sx710hs and sx730hs.

With the sig finder additions, the main things that need to be manually verified are the register and message IDs in debug_logging_my, and any viewport dimension logic in  update_ui
Don't forget what the H stands for.

*

Offline philmoz

  • *****
  • 3320
    • Photos
Re: Display (bitmap overlay)
« Reply #327 on: 06 / June / 2021, 17:58:56 »
I added support for sx710hs and sx730hs.

With the sig finder additions, the main things that need to be manually verified are the register and message IDs in debug_logging_my, and any viewport dimension logic in  update_ui


Thanks for that. Nice work on the sigfinder additions  :)


I've added these to the Google Drive link if anyone wants to test them.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)


Re: Display (bitmap overlay)
« Reply #328 on: 10 / June / 2021, 11:36:24 »
@philmoz

Just spotted and confirmed a strangeness with the G5X EVF.

As I only use M mode I had not spotted it before, plus this is the only non-M3 camera I have with a built in EVF.

In all modes, other than C, the EVF looks fine.

If CHDK is not on the card, or no card in the Cam, C mode is OK in the EVF.

With CHDK on the card, and enabled, ie locked, and in C mode, the LCD is OK, but the EVF is completely corrupted, ie 100% full of rubbish pink green dots in three horizontal bands.

BTW I'm using the latest build from your repository and the corruption was there before, ie I tested a previous build. Thus likely there all the time, but not spotted as I don't use C mode.

Cheers

Garry

*

Offline c_joerg

  • *****
  • 1083
Re: Display (bitmap overlay)
« Reply #329 on: 10 / June / 2021, 12:38:42 »
Which Mode (AV, P, M...) is saved on C? 
M100 100a, M3 101a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

 

Related Topics