SX400IS porting thread

  • 60 Replies
  • 46686 Views
Re: SX400IS porting thread
« Reply #30 on: 24 / February / 2017, 05:47:57 »
Advertisements
Oh, that is sad. I only discovered this thread yesterday, so I did not get a chance to grab the older versions of the release.

Would it be possible for you to re-upload it? Or is it best to wait for [nafraf] ?

*

Offline srsa_4c

  • ******
  • 3728
Re: SX400IS porting thread
« Reply #31 on: 25 / February / 2017, 09:46:04 »
Test release is attached, for firmware version 100b. It will "expire" in 2 weeks (that means nag screens will be shown at startup and in ALT mode, but functionality won't be affected).
Reports are still welcome:
- Is it stable? User astol reported a crash using an earlier test version.
- Movie quality and bitrate overrides seem to be implemented, but have not been tested.
- Dark frame subtraction: it should work normally.
- Remote shooting using chdkptp.

Note that without convincing feedback, this port will never become official.

Re: SX400IS porting thread
« Reply #32 on: 28 / February / 2017, 03:27:21 »
pop-up screen become obsessive. In earlier test versions this problem wasn't noticed.


*

Offline msl

  • *****
  • 1239
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: SX400IS porting thread
« Reply #33 on: 28 / February / 2017, 06:17:39 »
This is a normal CHDK feature. You can turn off this help screen via CHDK menu.

CHDK Menu => Menu Settings

=> http://chdk.wikia.com/wiki/CHDK_User_Manual#Show_.3CALT.3E_Help_Screen

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!


Re: SX400IS porting thread
« Reply #34 on: 01 / March / 2017, 08:13:48 »
Thank you [srsa_4c]. I have downloaded it and loaded on the camera. On a cursory look, it works fine.

I will try to test it a bit more in-depth the following days. Is there any particular template I should follow? Specifically, I am not sure how to check the last 2 items on your list - remote shooting, and dark frame extraction. Any link for guidance is welcome.

*

Offline srsa_4c

  • ******
  • 3728
Re: SX400IS porting thread
« Reply #35 on: 01 / March / 2017, 20:52:17 »
I will try to test it a bit more in-depth the following days. Is there any particular template I should follow? Specifically, I am not sure how to check the last 2 items on your list - remote shooting, and dark frame extraction.
You can quickly look up things that have already been tested by reading the text version of this thread. I think no-one has reported the amount of free RAM yet, for example.

Looks like I was wrong about movie overrides - they are not enabled in the menu.

Dark frame subtraction: the Canon firmware automatically takes a dark frame when exposure time exceeds ~1 second - this process effectively doubles exposure time with the camera displaying "busy" during the dark frame acquisition.
You should be able to disable or force dark frames by using the following CHDK menu entry: Enhanced photo operations -> Dark frame subtraction. Check whether all 3 settings there work ('auto' allows the firmware to work as intended by Canon).

Remote shooting over PTP: the easiest method is to use the 'user' tab in the chdkptp GUI, namely the "remote capture" buttons - obviously, after switching the camera to 'rec' mode with the 'rec' button.
Expected result: you should get either a DNG or a JPG in the chosen folder of your PC, and no JPG should be saved on camera. You can get more control over the remote shooting process by using the rs command in chdkptp (help is available by executing 'help rs').
It's possible that you'll encounter one or more of the known problems mentioned here - let us know if you do.

Re: SX400IS porting thread
« Reply #36 on: 12 / March / 2017, 11:25:36 »
Hi Guys,
Firstly, I have to say a huge thanks for producing this version. I had pretty much given up on this camera as the quality of the JPEG images was just awful - maybe I have a bad example, don't know. But with CHDK I can at last get my hands on the RAW file and it has given this beast a new lease of life.

The last download has now expired, so is it possible to get a new one - or one that does not expire?

Thanks,
Ralph


Re: SX400IS porting thread
« Reply #37 on: 12 / March / 2017, 12:26:17 »
The last download has now expired, so is it possible to get a new one - or one that does not expire?
FYI ... the expired version will still work.  The warning message is just to prompt you to check back for an updated version and not keep using an early, potentially buggy release.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: SX400IS porting thread
« Reply #38 on: 12 / March / 2017, 13:05:48 »
Duh, so it does. Great, I'll try and feed back some observations.

Thanks

Re: SX400IS porting thread
« Reply #39 on: 16 / March / 2017, 12:32:56 »
Get one more problem.
For some time raw files saving like this


With jpg files all ok. Any changing raw saving parameters (including defaults) gives same result.
Furthermore using earlier chdk-firmware gives same result (which is very strange).

Maybe this is not firmware, but already hardware problem - I don't know :(

 

Related Topics