Focusing - Forum related topics (including issues) - CHDK Forum supplierdeeply

Focusing

  • 7 Replies
  • 514 Views
Focusing
« on: 24 / June / 2021, 18:37:26 »
Advertisements
When I focus by half-pressing the shutter button without CHDK, everything works fine.
With CHDK, the whole screen slowly goes yellow, and I don't know if focus is done
Is there a fix?

*

Offline reyalp

  • ******
  • 13295
Re: Focusing
« Reply #1 on: 24 / June / 2021, 20:05:04 »
What camera?
What version of CHDK?
Can you post a picture of the screen?
Do you have CHDK zebra enabled?
Don't forget what the H stands for.

Re: Focusing
« Reply #2 on: 24 / June / 2021, 20:30:42 »
Canon S5Is
Version 1.1.0.0
Cannot post picture
Yes, Zebra is enabled

*

Offline reyalp

  • ******
  • 13295
Re: Focusing
« Reply #3 on: 24 / June / 2021, 22:26:28 »
Canon S5Is
Version 1.1.0.0
Cannot post picture
Yes, Zebra is enabled
Without a picture, it's hard to know what you are experiencing. Do you mean the screen goes completely solid yellow, or are some other things visible?

In general, CHDK should not cause the whole screen to be covered in a solid color when you half press. If the entire scene is over or under exposed, the zebra could cover it. Bugs in the zebra code could also potentially cause something like this. So I'd suggest trying with zebra disabled.

For version, I meant CHDK version. You see this in the CHDK splash screen or in the CHDK menu under "Miscellaneous Stuff" -> "Show Build Info"

If you use a recent version of CHDK 1.6 (the "unstable" development branch) you can take a screenshot within CHDK:
Go to "Miscellaneous Stuff" -> "Tools" -> "Screen Record"
Select "Schedule Dump"
You will be returned to the <alt> screen. Exit alt, and half press. This needs to be done before the time in "Dump Start Delay" passes. You can increase it if needed.

The dump will be saved in DCIM/100CANON/ named something like CRW_0000.JPG. Post the file here. You can zip it if it's too large for the forum. The file is not actually a jpeg, so normal image programs won't open it correctly.
Don't forget what the H stands for.


Re: Focusing
« Reply #4 on: 25 / June / 2021, 10:20:16 »
The screen goes yellow in lines moving down, I tried without zebra and it helped somewhat. CHDK version is 09.9-1286
I do not have the Screen record option.

*

Offline reyalp

  • ******
  • 13295
Re: Focusing
« Reply #5 on: 25 / June / 2021, 13:08:04 »
The screen goes yellow in lines moving down,
That sounds like it could potentially be zebra
Quote
I tried without zebra and it helped somewhat.
What does "helped somewhat" mean? Is the problem still there, but different in some way? If so, how?

"Edge overlay" is another feature that can draw a lot on the screen.

Quote
CHDK version is 09.9-1286
Assuming you mean 0.9, build 1286, this version is almost 10 years old. Some bugs have been fixed since ;)

Since a lot has changed and that build is no longer easily available, you might want save the version you have now before trying a new one. The simplest would be just to use a different card, but you could also save the files to a PC.

Note if your card is multi-partition (likely if the card is larger than 4gb and you're using the bootable SD card method to load), you need to get the diskboot.bin from the small partition.
Don't forget what the H stands for.

*

Offline reyalp

  • ******
  • 13295
Re: Focusing
« Reply #6 on: 25 / June / 2021, 13:31:59 »
I see from your other  posts (https://chdk.setepontos.com/index.php?topic=14365.0, https://chdk.setepontos.com/index.php?topic=14363.msg146233#msg146233) that you installed recently on several different cards and maybe had some trouble with multi-partition cards.

I'm not clear how you ended up with such an ancient version, but I'd definitely suggest using 1.5 or 1.6.
Don't forget what the H stands for.

Re: Focusing
« Reply #7 on: 25 / June / 2021, 16:02:03 »
I bought my camera in 2008. Used CHDK from that point on. Got busy with kids, work, so camera was put to rest.
Recently retired, all my kids are out of house, and I took it up again. Downloaded V 1.5 and disabled edge overlay, and now
everything seems to be working fine. Thanks very much

Barry


 

Related Topics