G16 Porting Thread - Test Versions Available

  • 215 Replies
  • 55422 Views
Re: G16 Porting Thread - Test Versions Available
« Reply #130 on: 14 / January / 2018, 14:11:31 »
Advertisements
Well, I’m sorry to have raised
the points of:
Some settings available only after a reboot and
wake up only with a power off/on.
I could not reproduce the behaviors. I tried a lot.
So, please ignore.
Great to see 1.00h in autobuild


Gesendet von iPhone mit Tapatalk

Re: G16 Porting Thread - Test Versions Available
« Reply #131 on: 14 / January / 2018, 20:38:37 »
Well, I’m sorry to have raised the points of: Some settings available only after a reboot and wake up only with a power off/on.  I could not reproduce the behaviors. I tried a lot. So, please ignore.
No problem. CHDK is a hack and sometimes things don't really happen exactly as you think they should. Especially as you play with new and different things.

If you do trip over something broken like this, please report back?

Quote
Great to see 1.00h in autobuild
Two down - two to go. Hopefully one of the many people who have downloaded the test builds will check in.  If only because they get tired of the annoying notice we've added to test builds  :haha
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #132 on: 23 / February / 2018, 22:04:23 »
That guy with a 101A checking in

Test results for: 1.5.0-4960
Flickering still a problem, though reduced by enough that I can tolerate using it outside for once.
Zebra, Histogram, Edge Overlay works in photo mode (But not in Video Mode)
DNG works no problem
Exposure Override does not work (set to 1/4 F8 ISO 80, image comes out at 1/120 F4 ISO 800 for example)
Can't test usb remote at the moment unfortunately

If there's anything else you want me to test i'll hopefully get back to you in a manner somewhat resembling being punctual :o

Re: G16 Porting Thread - Test Versions Available
« Reply #133 on: 23 / February / 2018, 22:11:22 »
Flickering still a problem, though reduced by enough that I can tolerate using it outside for once.
That's pretty much how it goes for Digic6 ports at the moment.

Quote
Zebra, Histogram, Edge Overlay works in photo mode (But not in Video Mode). DNG works no problem
Good.

Quote
Exposure Override does not work (set to 1/4 F8 ISO 80, image comes out at 1/120 F4 ISO 800 for example)
Hmmmm .. not so good.   Does the resulting image appear to look like 1/4 F8 ISO80 rather than 1/120 F4 ISO 800 ?  If you are looking at the EXIF info, it might not match what the actual image exposure is?

Otherwise, I need to do some code exploring and will need help testing.

Quote
If there's anything else you want me to test i'll hopefully get back to you in a manner somewhat resembling being punctual :o
Just knowing it boots is good.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: G16 Porting Thread - Test Versions Available
« Reply #134 on: 23 / February / 2018, 22:58:35 »
Does the resulting image appear to look like 1/4 F8 ISO80 rather than 1/120 F4 ISO 800 ?

Nope. i expected an overblown image and got a perfectly autoexposed one.

Upon further investigation i found the following:
 - On half press the exposure shown on screen is the one i set to.
 - In M mode i have the ISO set via canon's UI to 3200 and override via CHDK to 640, this results in an EXIF displaying ISO 200 (and the image exposure matches when i take the image with ISO 200 in canon's UI to check)
 - - Testing with a handful of combinations of canon's UI ISO and CHDK ISO seems to suggest that the actual ISO gets locked at 200 regardless (in P mode it does the same but at 80, in Tv and Av auto iso kicks in)
 - Shutter Speed and Aperture override doesn't appear to do anything other than change what the UI says on half press
 - In video mode everything is auto

Hopefully this helps you out some

Re: G16 Porting Thread - Test Versions Available
« Reply #135 on: 23 / February / 2018, 23:10:26 »
Nope. i expected an overblown image and got a perfectly autoexposed one.
Very interesting.  Thanks for reporting that.
Quote
Upon further investigation i found the following:
 - On half press the exposure shown on screen is the one i set to.
 - In M mode i have the ISO set via canon's UI to 3200 and override via CHDK to 640, this results in an EXIF displaying ISO 200 (and the image exposure matches when i take the image with ISO 200 in canon's UI to check)
 - - Testing with a handful of combinations of canon's UI ISO and CHDK ISO seems to suggest that the actual ISO gets locked at 200 regardless (in P mode it does the same but at 80, in Tv and Av auto iso kicks in)
 - Shutter Speed and Aperture override doesn't appear to do anything other than change what the UI says on half press
Okay - I'll retest my G16 to assure myself this works on that port.  Then I'll try to puzzle out why overrides don't work - the hooks are inserted in the same place so I must have missed something.
Quote
In video mode everything is auto
The G16 ports (and most DIGIC6 ports) do not do anything in video modes.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 11591
Re: G16 Porting Thread - Test Versions Available
« Reply #136 on: 23 / February / 2018, 23:54:57 »
Nope. i expected an overblown image and got a perfectly autoexposed one.
Do you have anything in the flash hotshoe by any chance? On some previous cameras, this interfered with overrides. It's also possible for the microswitch to get stuck.
Don't forget what the H stands for.

Re: G16 Porting Thread - Test Versions Available
« Reply #137 on: 24 / February / 2018, 05:44:23 »
Do you have anything in the flash hotshoe by any chance?
I only have a 3D printed cover in there. What could tha-
Oh.
Ooooooooooooohhhhhhhhhhhhhhhh.
Well that works now. Thank you very much!


Re: G16 Porting Thread - Test Versions Available
« Reply #138 on: 24 / February / 2018, 10:18:28 »
Do you have anything in the flash hotshoe by any chance?
I only have a 3D printed cover in there. What could tha-
Oh.
Ooooooooooooohhhhhhhhhhhhhhhh.
Well that works now. Thank you very much!
@reyalp   Thanks - I like to think I would have eventually remembered about that but who know how long it would have taken.

@xureality : if you still want to use your 3D printed cover, there is an option to disable the switch in the hot shoe that will let you do that.  Look in the Enhanced Photo Operations menu for Hotshoe override [ Empty ].
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #139 on: 24 / February / 2018, 19:07:49 »
Hotshoe override [ Empty ].

At least it's another feature put to the test  :D (which also works)
And I can confirm that USB remote works, also. (per http://chdk.wikia.com/wiki/Testing)

 

Related Topics