G16 Porting Thread - Test Versions Available - page 7 - DryOS Development - CHDK Forum
supplierdeeply

G16 Porting Thread - Test Versions Available

  • 227 Replies
  • 72713 Views
Re: G16 Porting Thread - Test Versions Available
« Reply #60 on: 26 / July / 2017, 10:10:28 »
Advertisements
Mind if another 101A user join the fray?  :D
Welcome. 

Quote
I've so far load CHDK into card with STICK. Camera shoot stills and video fine, DNG works.
LethalDosage reported crashing when scripts try to "shoot". Can you try the simple script included with CHDK ( shoot.lua ) and confirm this? I did not receive a response from my question to him about whether he could still shoot normally without crashing while not in <ALT> mode with CHDK was loaded in the background.  I think your statement says that you can?

Quote
OSD/Menu flickers badly with exposure changes (both bright -> dark and dark -> bright. tested by covering the lens; doesn't flicker when lens is covered).
That's "normal" unfortunately - and it's worse on the most recent D6 cameras.  If you put the camera into "playback" mode rather than "shooting" mode it tends to be less annoying.  There may be a solution on the horizon based on some recent work by srsa_4c.  I have a slightly improved version already and if he makes more breakthroughs I'll incorporate them as well.

Quote
Zebra stripes doesn't actually draws over over/underexposed areas, but rather areas that are going to be (and i have to crank the treshold to 20 to actually see anything).
I'll look at it on the 1.01c - I had not noticed that.

Quote
ALT menu takes 4-5 seconds to load (not sure if typical).
Do you mean 4-5 seconds after you press the <ALT> key?  (I usually configure the Shortcut button as the <ALT> key.)
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #61 on: 26 / July / 2017, 10:50:23 »
Quote
LethalDosage reported crashing when scripts try to "shoot". Can you try the simple script included with CHDK ( shoot.lua ) and confirm this? I did not receive a response from my question to him about whether he could still shoot normally without crashing while not in <ALT> mode with CHDK was loaded in the background.  I think your statement says that you can?
unfortunately not, in <ALT> mode it will not work (sorry, total noob at this, just figured that there's a difference in normal shooting and running scripts) It crashes in the manner he described

Quote
Do you mean 4-5 seconds after you press the <ALT> key?  (I usually configure the Shortcut button as the <ALT> key.)
yes, and i just figured out that that menu is supposed to be a help menu and that you can press the relevant buttons as soon as you press <ALT> *facepalms*

G16 Porting Thread - Test Versions Available
« Reply #62 on: 26 / July / 2017, 12:11:05 »
unfortunately not, in <ALT> mode it will not work (sorry, total noob at this, just figured that there's a difference in normal shooting and running scripts) It crashes in the manner he described
I may have confused you here.  If you press the camera's shutter button while in CHDK <alt> mode, the current script starts.  When you are not in <alt> mode, pressing the shutter button takes a photograph.  If you have loaded CHDK, it's hooked into the camera's firmware when you shoot normally.  I was trying to determine if that causes crashes or not. 

So it crashes when a script tries to shoot and not  when you shoot normally?

Quote
Quote
Do you mean 4-5 seconds after you press the <ALT> key?  (I usually configure the Shortcut button as the <ALT> key.)
yes, and i just figured out that that menu is supposed to be a help menu and that you can press the relevant buttons as soon as you press <ALT> *facepalms*
You can turn that annoying thing off in the CHDK Menu Settings menu.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #63 on: 26 / July / 2017, 12:26:45 »
Quote
So it crashes when a script tries to shoot and not  when you shoot normally?
That is correct.

Quote
You can turn that annoying thing off in the CHDK Menu Settings menu.
I actually want it to come on sooner because i have no idea what i'm doing, so i set the menu delay to 0 and it works how i want it to now, thanks!


G16 Porting Thread - Test Versions Available
« Reply #64 on: 26 / July / 2017, 13:03:53 »
I actually want it to come on sooner because i have no idea what i'm doing, so i set the menu delay to 0 and it works how i want it to now, thanks!
When all else fails, there is always RTFM :

CHDK 1.4.0 User Manual


I'll look into the script crashes on shooting tonight.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #65 on: 26 / July / 2017, 16:09:45 »
Hi waterwingz,
I found this page today and very happy that a solution for the G16 is on the way.
Especially I am interested in TTL flash mode with camera mode M. My G16 has 1.00h firmware.

I experienced exactly the same as Harald Becherer some posts before:
"...power LED is green, no other reaction is to be seen (Black screen, no movement of the lens,...)
and the camera is locked, so that I have to take out the battery to switch it off...."

My SD-card was out of the box, FAT32 formatted, made bootable with EOScard, CHDK including all subdirectories on the card, card locked.

If I can contribte to the further progress, please let me know.

Many thanks for your work!

Re: G16 Porting Thread - Test Versions Available
« Reply #66 on: 26 / July / 2017, 19:23:55 »
I experienced exactly the same as Harald Becherer some posts before: "...power LED is green, no other reaction is to be seen (Black screen, no movement of the lens,...) and the camera is locked, so that I have to take out the battery to switch it off...."  My SD-card was out of the box, FAT32 formatted, made bootable with EOScard, CHDK including all subdirectories on the card, card locked.
Your card appears to be configured correctly. 

I sent Harald a test version of the code but have not heard back from him yet.

link > g16-100h-1.5.0-4873-full

At startup, this version should blink the green LED on the power button on & off once, and then blink the orange LED on the optical viewfinder bezel five times. 

Try it and let me know what pattern you see?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Online reyalp

  • ******
  • 12649
Re: G16 Porting Thread - Test Versions Available
« Reply #67 on: 27 / July / 2017, 01:02:59 »
Ok, crashed it again and powered up again and saved crash log.  Seems power-down would clear any info, but maybe not.  ROMLOG.LOG attached.

Waterwingz had to leave IRC when we were talking about this, so I figured I'd post here:

This romlog is fairly odd

Code: [Select]
Exception!! Vector 0x0C
Occured Time  2017:06:30 14:41:50
Task ID: 16121892
Task name: CtrlSrv
Invalid data access in CtrlSrv, which we don't normally hook. Fairly normal so far.

Code: [Select]
0x0063EBC4
0xEDE205FC
This is LR and PC respectively.  Neither of these look anything like Canon code addresses.  0x0063EBC4 could maybe plausibly be a CHDK address, but we don't hook CtrlSrv, and most CHDK LR values should be thumb (as should most Canon firmware LRs too). 0x0063EC64 also appears in the stack trace a number of times.

One thing I'd suggest checking is that stack size for PhySw has been adjusted from the normal firmware value.
Don't forget what the H stands for.


Re: G16 Porting Thread - Test Versions Available
« Reply #68 on: 27 / July / 2017, 13:27:12 »
I tried version g16-100h-1.5.0-4873-full but same reaction as before: power LED is green, no other reaction...no blinking. :'(

Re: G16 Porting Thread - Test Versions Available
« Reply #69 on: 27 / July / 2017, 14:38:22 »
I tried version g16-100h-1.5.0-4873-full but same reaction as before: power LED is green, no other reaction...no blinking. :'(
Thanks - that tells me quite a bit. I'll post a second test version later today.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics