G16 Porting Thread - Test Versions Available - page 9 - DryOS Development - CHDK Forum supplierdeeply

G16 Porting Thread - Test Versions Available

  • 229 Replies
  • 94243 Views
Re: G16 Porting Thread - Test Versions Available
« Reply #80 on: 30 / July / 2017, 15:07:52 »
Advertisements
Test with g16-100h_test2.zip
Results: steady green LED on the OVF - no blinking of the orange LED on the OVF, no light on the power LED, no other reaction until remove of the Batterie.

Hi Waterwings hi Keema
Back on testing.
I get the same result as Keema.
Test2: Steady green LED, screen black, battery pull out for switch off.
With the 4891 I get also the orange blinking.

Thanks, Harald

G16 Porting Thread - Test Versions Available
« Reply #81 on: 30 / July / 2017, 15:31:09 »
With the 4891 I get also the orange blinking.
That is good news as it means you have everything configured correctly.

Unfortunately, I am traveling until next Sunday so we lose a week here.  However, I have a very good idea what is happening now so I might even have a working version then.

I'll also need some time to explore why overrides are not working.  The code is very similar to other DIGIC6 cameras but there are a few differences so I must have missed something.
« Last Edit: 30 / July / 2017, 15:33:48 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 13502
Re: G16 Porting Thread - Test Versions Available
« Reply #82 on: 30 / July / 2017, 16:24:11 »
I'll also need some time to explore why overrides are not working.  The code is very similar to other DIGIC6 cameras but there are a few differences so I must have missed something.
IIRC there are some reported issues with overrides on M3 and M10 as well (https://chdk.setepontos.com/index.php?topic=12542.msg133768#msg133768).
Don't forget what the H stands for.

Re: G16 Porting Thread - Test Versions Available
« Reply #83 on: 06 / August / 2017, 22:14:13 »
Another test version for the 1.00h.  TIA for your patience with this - I'm running out of things that could be wrong.

On startup, this version should show the following LED activity :
  • The orange LED on the OVF blinks twice
  • A one second pause
  • The orange and green LEDs on the OVF blink twice together
  • The green LED on the power button then blinks eight times (dimly)
  • The LCD display activates and the green LED blinks three more times

Let me know what you see?  (I'm guessing it might get stuck at step 3?)

edit : attachment removed
« Last Edit: 07 / August / 2017, 17:16:58 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: G16 Porting Thread - Test Versions Available
« Reply #84 on: 07 / August / 2017, 11:57:43 »
Hi waterwingz,

report for g16-100h-test3.zip:
steps 1-4 as you wrote; after the dimly blinking of the green LED on the power button it got stuck.

Re: G16 Porting Thread - Test Versions Available
« Reply #85 on: 07 / August / 2017, 13:47:08 »
steps 1-4 as you wrote; after the dimly blinking of the green LED on the power button it got stuck.
Found the problem.  Or at least I think so.

Finding it was difficult in my first test versions because I was only using the green LED on the OVF for debugging.  Updated test version attached - let's see if this works now?

edit : attachment removed
« Last Edit: 07 / August / 2017, 17:17:17 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #86 on: 07 / August / 2017, 14:34:20 »
steps 1-4 as you wrote; after the dimly blinking of the green LED on the power button it got stuck.
Found the problem.  Or at least I think so.

Finding it was difficult in my first test versions because I was only using the green LED on the OVF for debugging.  Updated test version attached - let's see if this works now?
WOW!
First Light for CHDK
I'm trying a couple things out...
Happy


Gesendet von iPhone mit Tapatalk

Re: G16 Porting Thread - Test Versions Available
« Reply #87 on: 07 / August / 2017, 15:16:34 »
It is really working for the first time!
Congratulation and many thanks!
Screen is flickering, but I like it  :D


Re: G16 Porting Thread - Test Versions Available
« Reply #88 on: 07 / August / 2017, 17:04:18 »
WOW! First Light for CHDK. I'm trying a couple things out...
It is really working for the first time! Congratulation and many thanks!
Screen is flickering, but I like it  :D
Great news. Time for some more detailed testing.  I've updated the download links in the first post of this thread with new installation files for all supported firmware versions.

Screen flickering is normal unfortunately.  Try to do as much of your setup & configuration work in Play/Review mode.
« Last Edit: 07 / August / 2017, 17:18:17 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #89 on: 07 / August / 2017, 17:15:33 »
IIRC there are some reported issues with overrides on M3 and M10 as well (https://chdk.setepontos.com/index.php?topic=12542.msg133768#msg133768).
I changed capt_seq.c by adding a call to shooting_expo_param_override in case 1 of the big switch statement in capt_seq_task( ).  This is the case labelled "Normal Shoot" in the other D6 ports.

With that change, overrides entered via the Enhanced Photo Operations menu now take effect during normal shooting (Auto, P, Tv, M modes tested). 

However, scripted shoot( ) statements do not use the override values from either the Enhanced Photo Operations menu or set_tv96_direct( ), set_av96( ), and set_sv96( ).   Placing a call to shooting_expo_param_override at the common exit point from capt_seq_task( ) did not have any effect either.  So scripts like hdr.lua take three images at the same exposure.

Onwards ...
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics