supplierdeeply

G16 Porting Thread - Test Versions Available

  • 215 Replies
  • 54474 Views
Re: G16 Porting Thread - Test Versions Available
« Reply #170 on: 10 / March / 2018, 22:19:09 »
Advertisements
Tried it again and it's stable, no blinking.
The blinking is unfortunately normal - especially when the camera is in shooting mode rather than playback mode.  It's a long story.

Now that you seem to have the install process worked out, here's a build with everything enabled (other than the nagging expired message).  Let's see how that goes?

Other than the blinking in shooting mode, it seems to be OK.  I appreciate your patience throughout this process.  Please let me know what I should do to test this.

Re: G16 Porting Thread - Test Versions Available
« Reply #171 on: 10 / March / 2018, 23:34:32 »
Please let me know what I should do to test this.
AFAIK, we have never made a definitive list for testing every thing that a porter sets in the sub/<fw> directories.  In general,  the first firmware version of a new port gets some high level functionality tests - with a bias towards things that are hard to find or have caused problems.  Just getting CHDK to load and display menus correctly is a big step all by itself.

Subsequent additions of different firmware versions for any released port get a bit of a free pass. If they appear to work then, based on the original port being good,  we mostly assume they are okay until anyone reports otherwise .

So the big things I'd suggest checking are :
  • RAW/DNG images - take some shot with DNG enabled and assure yourself that the DNG images actually look like uncorrected versions of the related JPG
  • USB remote - enable this and just use a regular USB cable plugged into a spared charger or computer port to trigger it and assure it's working
  • exposure overrides in the Enhanced Photo Operations menu - set both Tv, Sv, & Av and make sure the resulting image change appropriately when you change the values
  • set a long exposure time (30 seconds) and then see if dark frame subtraction control works ( if not, it will take 60 seconds to complete a 30 second exposure)
  • try out the edge overlay, historgram, and zebra functions and make sure they seem to work (i.e. usable images on the camera's LCD)
  • try running some scripts - there are four simple ones included with the CHDK installation file and hundreds more online at places like this
  • play with anything else that tweaks your interest

There is learning curve here so feel free to post questions.  If all else fails - RTFM.  And tell us how you did - if the 1.01b build passes the above list of tests without crashing then we will release it for distribution in the autobuild.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #172 on: 11 / March / 2018, 08:42:43 »
Please let me know what I should do to test this.
AFAIK, we have never made a definitive list for testing every thing that a porter sets in the sub/<fw> directories.  In general,  the first firmware version of a new port gets some high level functionality tests - with a bias towards things that are hard to find or have caused problems.  Just getting CHDK to load and display menus correctly is a big step all by itself.

Subsequent additions of different firmware versions for any released port get a bit of a free pass. If they appear to work then, based on the original port being good,  we mostly assume they are okay until anyone reports otherwise .

So the big things I'd suggest checking are :
  • RAW/DNG images - take some shot with DNG enabled and assure yourself that the DNG images actually look like uncorrected versions of the related JPG
  • USB remote - enable this and just use a regular USB cable plugged into a spared charger or computer port to trigger it and assure it's working
  • exposure overrides in the Enhanced Photo Operations menu - set both Tv, Sv, & Av and make sure the resulting image change appropriately when you change the values
  • set a long exposure time (30 seconds) and then see if dark frame subtraction control works ( if not, it will take 60 seconds to complete a 30 second exposure)
  • try out the edge overlay, historgram, and zebra functions and make sure they seem to work (i.e. usable images on the camera's LCD)
  • try running some scripts - there are four simple ones included with the CHDK installation file and hundreds more online at places like this
  • play with anything else that tweaks your interest
There is learning curve here so feel free to post questions.  If all else fails - RTFM.  And tell us how you did - if the 1.01b build passes the above list of tests without crashing then we will release it for distribution in the autobuild.


Thanks, I will test these out and get back to you.

Re: G16 Porting Thread - Test Versions Available
« Reply #173 on: 13 / March / 2018, 07:59:05 »
Hi, I'm trying your great work on my g16 101c :)
First try was version 4891, works with bootable sd card method.

Now I'm trying the 5000 version, from CHDK-SVN Autobuild.
Firmware Update Method works well, photo are saved.
Using bootable sd card method, after shooting photo, camera display "memory card error"
No photos are saved


Re: G16 Porting Thread - Test Versions Available
« Reply #174 on: 13 / March / 2018, 08:28:22 »
Firmware Update Method works well, photo are saved.
That's interestin! I never tested or released anything for the "Firmware Update" method.  On Digic6 cameras, it apparently has a lot of issues so it's not made available on those camera.

@reyalp :  will you take a look ?

Quote
Using bootable sd card method, after shooting photo, camera display "memory card error" No photos are saved
Well, build 5000 works on both my G16's.  Did you try low level formatting the card and start from scratch using STICK or CHIMP?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #175 on: 13 / March / 2018, 15:24:16 »
Quote
Well, build 5000 works on both my G16's.  Did you try low level formatting the card and start from scratch using STICK or CHIMP?

low level formatted by G16  &&  STICK, but same thing (memory card error) :(
version 4891 (from here) work well, write CPUINFO.TXT, BENCH.LOG, and photo into SD CARD.

can you please post your version, between 4891 and 5000 (not expired)?
 

*

Offline srsa_4c

  • ******
  • 3725
Re: G16 Porting Thread - Test Versions Available
« Reply #176 on: 13 / March / 2018, 19:09:20 »
low level formatted by G16  &&  STICK, but same thing (memory card error)
If possible, try again using a different SD card.


*

Offline reyalp

  • ******
  • 11583
Re: G16 Porting Thread - Test Versions Available
« Reply #177 on: 14 / March / 2018, 00:58:46 »
@reyalp :  will you take a look ?
I disabled FI2 in the autobuild.

The two things that are known to fail on most digic 6 cameras are using hybrid auto mode, and the orientation sensor freaking out in playback mode. If these do not occur on G16, I guess we can re-enable FI2 loading.

Regarding the card error on boot, this sounds like the sort of card-dependent initialization issues we've seen on other cameras.
Digic 6 UHS initialization (also resulted in intermittent SD card errors on g7x with one card)
https://chdk.setepontos.com/index.php?topic=13089.msg132583#msg132583
Pre-digic 6 cameras:
https://chdk.setepontos.com/index.php?topic=12795.0
Don't forget what the H stands for.


Re: G16 Porting Thread - Test Versions Available
« Reply #178 on: 14 / March / 2018, 21:53:17 »
Quote from: reyalp link=topic=13054.msg136409#msg136409
I disabled FI2 in the autobuild. The two things that are known to fail on most digic 6 cameras are using hybrid auto mode, and the orientation sensor freaking out in playback mode. If these do not occur on G16, I guess we can re-enable FI2 loading.
Thanks.  When I get a minute,  I'll check this out.

Quote
Regarding the card error on boot, this sounds like the sort of card-dependent initialization issues we've seen on other cameras.
It's somewhat curious that gpancot had an earlier version of the G16 build working but finds that the 5000 build does not work.  To test this out, I ran a complete new install using STICK on an SD card that I had low level formatted in camera first. Everything worked correctly - no errors.  So it's not a fundamental issue with the G16 CHDK build anyway.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G16 Porting Thread - Test Versions Available
« Reply #179 on: 15 / March / 2018, 04:55:26 »
"memory card error" was with 32GB Samsung EVO UHS-I Class 10 (U1)
no error with 16GB Sandisk Class 4 (non UHS)
(v5000 and v5001)

@reyalp: confirm problem with FI2 and hybrid auto mode

 

Related Topics