ixus175_elph180_100c porting attempt - page 16 - DryOS Development - CHDK Forum
supplierdeeply

ixus175_elph180_100c porting attempt

  • 201 Replies
  • 65413 Views
*

Offline axman

  • ***
  • 145
Re: ixus175_elph180_100c porting attempt
« Reply #150 on: 01 / July / 2017, 11:45:39 »
Advertisements
tested build3 and build4.  Build3 is almost perfect.
  *shows different behavior to previous builds.

build3
use CHDK menu, RAW -> save raw
  destination A/DCIM, capture image with normal Shutter press;
1x DNG is saved to <separate> \DCIM directory.                    
DNG image has no faults like build1 or build2.                 
  And
  JPG is saved to normal DCIM dir.
----------
hooktest (Continuous mode On, then Continuous mode off)
  ALL PASS
  DNG save=Y was on by mistake during hooktests,
    but no DNG were saved during execution.  hooktest JPGs all good.
-------------
chdkptp shoot w/RAW *Off*
con 1> shoot                      // 1x JPG is saved to sd card
*con 4> shoot -dng=1      // 1x DNG + 1x JPG are saved to sd card ...
*                                           // no faults in DNG or JPG images

chdkptp shoot w/RAW *On*
con 1> shoot            // 1x JPG is saved to sd card
con 4> shoot -dng=1     // 1x DNG + 1x JPG are saved to sd card
*                                         // no faults in DNG or JPG images


build4
use CHDK menu, RAW -> save raw Y, DNG
  destination A/DCIM, capture image with normal Shutter press;
1x DNG is saved to <separate> \DCIM directory.
DNG image has no faults like build1 or build2.
  And
  JPG is saved to normal DCIM dir.

* hooktest (Continuous mode On, then Continuous mode off)  ALL FAIL
test pass #1  ALL FAIL
Continuous mode On + (RAW-DNG save=Y On by mistake during hooktest pass #1),
but no DNG were saved during test execution. 
1x JPG for each hooktest 'shoot' cmd are saved anyway to sd card; images are good.

test pass #2  ALL FAIL
Continuous mode On, DNG=N
1x JPG for each 'shoot' cmd is saved to sd card; images good.

test pass #3
Continuous mode Off, ALL FAIL
1x JPG for each 'shoot' cmd is saved to sd card; images good.
--------------
chdkptp shoot w/RAW *Off*
*con 1> shoot            // 2x JPG is saved to sd card
*con 4> shoot -dng=1     // 2x JPG are saved to sd card
                                            // 0x DNG are saved
chdkptp shoot w/RAW *On*
*con 1> shoot            // 2x JPG are saved to sd card
*con 4> shoot -dng=1     // 2x JPG saved to sd card
                                            // 0x DNG are saved

hooktest log for build4 attached.

If there is specific test not run that I *should* run, please say.

*

Offline blackhole

  • *****
  • 763
  • A590IS 101b
    • Planetary astrophotography
Re: ixus175_elph180_100c porting attempt
« Reply #151 on: 01 / July / 2017, 16:08:52 »
Quote
tested build3 and build4.  Build3 is almost perfect.
  *shows different behavior to previous builds.
Thank you for testing.
Can you try the "Firmware update" method to load the CHDK, the SD card must be unlocked.
If it does not work, lock the card and try the tests you have been doing so far.
You can also try Histogram and Zebra mode.
In the Zebra menu, set "OverExposure Threshold" to 10
Test build attached.

*

Offline axman

  • ***
  • 145
Re: ixus175_elph180_100c porting attempt
« Reply #152 on: 03 / July / 2017, 13:36:00 »
thank you for the test build.  It works well.  Not sure if * is unexpected or not.

build5:

quick shoot, 1x image, good.
half-press then full-press, 1x image, good.
---------------------------------
test 'ShortExp' = 10s, DarkFrameSubtraction = Off
  5x in succession; 1x image for each shutter press, good.
  shutter open 10s, then 'Busy' shown briefly, return is normal, good.

test 'ShortExp' = 10s, DarkFrameSubtraction = On
  5x in succession; 1x image for each shutter press, good.
  shutter open 10s, afterwards 'Busy' shown 10s, return is normal, good.
-----------------------
use CHDK menu, RAW -> save raw Y, DNG
  destination withJPEG, capture image with normal Shutter press;
  1x DNG is saved to \DCIM directory.
  DNG image has no faults like build1 or build2.
  And JPG is also saved to \DCIM dir.
-----------------------
hooktest (Cont. Off, then On)  ALL PASS
----------------------
chdkptp shoot w/RAW *Off*
con 1> shoot            // 1x JPG is saved to sd card
*con 4> shoot -dng=1     // 1x JPG are saved to sd card and
*                        // 1x DNG are also saved to host-PC

chdkptp remoteshoot w/RAW *Off*
*con 1> rs '/home/ajm/Pictures' -dng -shots=1    // 1x DNG saved to host-PC
con 4> rs '/home/ajm/Pictures' -jpg -shots=1
ERROR: unsupported format
------------------------
chdkptp shoot & rs w/RAW *On*
con 1> shoot                                    // 1x DNG saved to sd card
con 2> rs '/home/ajm/Pictures' -dng -shots=1    // 1x DNG saved to host-PC
--------------------------
Zebra - OverExposure Threshold = 10
Half-press to activate.  In the osd, it shows over-exposed areas of image as an overlay of black shapes;  black shapes are dynamic, changing with what is seen to be over-exp part of image.

Histogram - in the osd, it shows a graph;
  graph is dynamic, and changes when subject is changed.
------------------
Testing firmware update method will be done separate.

*

Offline axman

  • ***
  • 145
Re: ixus175_elph180_100c porting attempt
« Reply #153 on: 03 / July / 2017, 14:11:37 »
test of "firmware update method" http://chdk.wikia.com/Prepare_your_SD_card#Firmware_Update_Method.2A

format sd card using camera.
copy CHDK root files and CHDK directory structure to formatted card.

File 'PS.FI2' is present in root of sd card, along with vers.req, DISKBOOT.BIN and the 2 txt files.  CHDK/ contains the full pkg.  sd card is unlocked.

power cam on using PLAY button.  Attempt Canon Firm Update...  Update File Error!!!

try again with card locked;  same error.

Going back now to using bootable sd card method.


*

Offline blackhole

  • *****
  • 763
  • A590IS 101b
    • Planetary astrophotography
Re: ixus175_elph180_100c porting attempt
« Reply #154 on: 03 / July / 2017, 18:56:59 »
Once again thanks for testing and patience.
Port now looks pretty good.
It would be good to check what happens if an ISO value outside the Canon range is used in combination with the flash (ISO lower than 100 or higher than 1600).
To determine the active area of the sensor I need one DNG image. The image of the white wall would be good.

I do not know what's going on with the non-functional PS.FI2 file.

*

Offline axman

  • ***
  • 145
Re: ixus175_elph180_100c porting attempt
« Reply #155 on: 04 / July / 2017, 14:15:34 »
Thank you for all the work on this port.  Sorry for my ignorance on what is ISO, what it does, etc, I had to study it more.  Try to test it correctly.

ISO override with flash test

chdk menu ISO enabled             // phone pic of chdk menu, if questions on menu settings
  set to 1800
chdk menu custom Auto ISO         // phone pic 2  ^^
  min 60, max 1800, fallback 600
shooting mode = P
flash = On
AUTO ISO override value shows in osd gui as red characters, agrees w/menu.

chdkptp shoot -svm=1800           // IMG_0200.JPG
https://drive.google.com/open?id=0B1mUSgMF9DmfNGRPYlp0cTViRzA

chdkptp shoot -sv=1800            // IMG_0201.JPG
https://drive.google.com/open?id=0B1mUSgMF9DmfbnFNOUhSY0p1d1k

seems like autofocus lamp blinks (orange) ?  Image is captured, Busy shows a short time.  For each shoot cmd, 1x jpg is saved to sd card.

to my eye, -svm version looks more 'yellow' than -sv.

Nothing obvious in exifprobe's report between two images ^.  EXIF IFD data does not suggest ISO override took effect, but I don't understand the photographic parameters very well..
---------------------------------------------
chdk menu ISO enabled             
  set to 60
chdk menu custom Auto ISO         
  min 60, max 1800, fallback 600
shooting mode = P
flash = On
AUTO ISO override value shows in osd gui as red characters, agrees w/menu.

chdkptp shoot -svm=60           // IMG_0202.JPG
https://drive.google.com/open?id=0B1mUSgMF9DmfUlFiSVRoLWpDSkE

chdkptp shoot -sv=60            // IMG_0203.JPG
https://drive.google.com/open?id=0B1mUSgMF9DmfM1o3RXRQZ1hHVGc

to my eye, there is slight diff between images but hard to describe.

I made exifprobe txt file report from each of ^ 4 images.
  Nothing obvious in 'diff 200 201' between svm= and sv=. 
  Nothing obvious in diff between iso 1800 vs iso 60.
    however, some "unknown" exif data params are different..

EXIF IFD data does not clearly show that ISO override took effect, but I don't know for sure how to tell.. 

In previous tests with ShortExp and LongExp, the change in exposure time was clearly seen in exif data..  For this ISO test, I do not see any of the IFD parameters changing all that much.. 

Did these test results give answer to what you are interested in?  Please suggest any detail or parameter to try if I tested wrong.
--------------------------------------------------
DNG of white surface,

I used white piece of paper as subject, with cam ~25-30cm away;  flash On.
Tried to move cam close to paper so that paper filled the LCD view finder.
DNG looks 'fish-eye' and has blue color tint around perimeter.. 
https://drive.google.com/open?id=0B1mUSgMF9DmfU3cxWmV3T05zRFE

Maybe this is not good enough?  I don't have a white wall.

*

Offline srsa_4c

  • ******
  • 4221
Re: ixus175_elph180_100c porting attempt
« Reply #156 on: 04 / July / 2017, 15:55:38 »
I do not know what's going on with the non-functional PS.FI2 file.
Are you using the correct key (fc6363...) and correct platform ID?
(The FI2 header seems to be the same as the one used by the Ixus160)

*

Offline blackhole

  • *****
  • 763
  • A590IS 101b
    • Planetary astrophotography
Re: ixus175_elph180_100c porting attempt
« Reply #157 on: 04 / July / 2017, 19:17:11 »
Quote
Did these test results give answer to what you are interested in?  Please suggest any detail or parameter to try if I tested wrong.
There was a misunderstanding, my fault, I apologize.
I was thinking to shooting mode "AUTO",not to "Custom AUTO ISO".
Switch the camera to shooting mode: "AUTO".
In CHDK menu set "Override ISO" to 50.
Turn on the flash in Canon's settings and try to take a image.

Thanks for DNG.

I do not know what's going on with the non-functional PS.FI2 file.
Are you using the correct key (fc6363...) and correct platform ID?
(The FI2 header seems to be the same as the one used by the Ixus160)
Yes, I used the correct key and platform ID.
"KEYSYS" is properly recognized as "d4i" as I expected.


*

Offline axman

  • ***
  • 145
Re: ixus175_elph180_100c porting attempt
« Reply #158 on: 05 / July / 2017, 11:21:38 »
Quote
Did these test results give answer to what you are interested in?  Please suggest any detail or parameter to try if I tested wrong.
There was a misunderstanding, my fault, I apologize.
I was thinking to shooting mode "AUTO",not to "Custom AUTO ISO".
Switch the camera to shooting mode: "AUTO".
In CHDK menu set "Override ISO" to 50.
Turn on the flash in Canon's settings and try to take a image.

Misunderstanding is not your fault.  I tried 'auto-iso' when repeat attempts taking image (to see a change in ISO value) had no visible effect on results.  Sorry for wasting time.

Change shooting mode to AUTO.  Set ISO override 60.  Flash on.
Image is captured.  Subject is dark but visible. 
Exif data - it does not say ISO 60, but maybe it does not matter.

*

Offline srsa_4c

  • ******
  • 4221
Re: ixus175_elph180_100c porting attempt
« Reply #159 on: 05 / July / 2017, 11:59:22 »
Yes, I used the correct key and platform ID.
"KEYSYS" is properly recognized as "d4i" as I expected.
I'm also getting update file error on my M10, when trying the .fi2. I was also wrong about this:
(The FI2 header seems to be the same as the one used by the Ixus160)
Seems like there's some research to do and the fi2 tool needs an update.
Weird thing is that the fi2 decoder still appears to correctly handle even the latest known fw upgrade files (M5)...

 

Related Topics