supplierdeeply

ixus175_elph180_100c porting attempt

  • 197 Replies
  • 51519 Views
Re: ixus175_elph180_100c porting attempt
« Reply #190 on: 01 / September / 2018, 19:05:24 »
Advertisements
I added A/D support for all the lipo battery cameras I have in trunk  r5062, including elph180.
Yea - I probably knew that if I'd thought about it a bit more.  This means we can remove the two superfluous  #defines and speed up the build a bit   ::)
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 11591
Re: ixus175_elph180_100c porting attempt
« Reply #191 on: 01 / September / 2018, 19:41:29 »
This means we can remove the two superfluous  #defines and speed up the build a bit   ::)
To be clear, I only added it for cameras I could personally test, not all the lipo battery cameras.

The A/D channel and values are different on digic 6 at least, so I'd be hesitant to enable it everywhere unless we had sigfinder detection of the battery type and A/D channel.
Don't forget what the H stands for.

Re: ixus175_elph180_100c porting attempt
« Reply #192 on: 02 / September / 2018, 13:43:03 »
To be clear, I only added it for cameras I could personally test, not all the lipo battery cameras.
My collection of cameras does not overlap yours AFAIK.  Is there a list of which ones you did to save me some grep time, as
Code: [Select]
#define CAM_REMOTE_AtoD_CHANNEL   5   
is only used twice.

Also, are all Canon battery packs (i.e. not AA cameras) lipo? Or is there a mix of NiMH, NiCd and Li-ion ?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 11591
Re: ixus175_elph180_100c porting attempt
« Reply #193 on: 02 / September / 2018, 17:26:01 »
Also, are all Canon battery packs (i.e. not AA cameras) lipo? Or is there a mix of NiMH, NiCd and Li-ion ?
I was actually just using it as a shorthand for Canon-proprietary non-AA. It's possible they made some with different chemistry but the vast majority (if not all) have a thermistor terminal.

Quote
My collection of cameras does not overlap yours AFAIK.  Is there a list of which ones you did
In the current trunk CAM_REMOTE_AtoD_CHANNEL is set for
D10
g7x *
ixus120_sd940
ixus140_elph130
ixus175_elph180
sx200is
sx710is *

* = channel 3, 12 bit ADC


edit:
If you are adding remote inputs, the AV detect and HDMI would be welcome too of course.
« Last Edit: 02 / September / 2018, 17:28:14 by reyalp »
Don't forget what the H stands for.


Re: ixus175_elph180_100c porting attempt
« Reply #194 on: 02 / September / 2018, 23:00:43 »
Seems that I have not done a SVN uodate in a while.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: ixus175_elph180_100c porting attempt
« Reply #195 on: 01 / October / 2018, 16:56:41 »
Based on sigfinder output, firmware 100a and 100b should be able to use the same build as 100c (except for the compatibility check).

Here's a test build set to load on those firmwares for anyone who has those has them. Please report if it works. It almost certainly will.

Hi, I have an ixus 175 with the 100b firmware. I tried the attached zip supplied, but noticed there wasn't a PS.F12 included.
I tried to use the PS.F12 from the latest 100c Autobuild, but the firmware update failed.
I then tried to use the 100c Autobuild itself, but as expected this failed to work and I had to take out the camera's battery.
Anyone got a test version of 100b I could try?
Thanks

*Update* I looked into further options and found the EOScard.exe tool and got the attached zip version to work. Anything I should test specifically to help get the 100b into the autobuild?
« Last Edit: 01 / October / 2018, 17:12:28 by charge »

*

Offline reyalp

  • ******
  • 11591
Re: ixus175_elph180_100c porting attempt
« Reply #196 on: 02 / October / 2018, 00:28:22 »
*Update* I looked into further options and found the EOScard.exe tool and got the attached zip version to work. Anything I should test specifically to help get the 100b into the autobuild?
Thanks for reporting. I've enabled 100b in the autobuild. Since it's a copy it really should be fine and not need additional testing.

You will probably want update to the autobuild version when it shows up (should be in the next 30 minutes or so), there have been some bug fixes since that test build.
Don't forget what the H stands for.

Re: ixus175_elph180_100c porting attempt
« Reply #197 on: 04 / October / 2018, 16:00:07 »
*Update* I looked into further options and found the EOScard.exe tool and got the attached zip version to work. Anything I should test specifically to help get the 100b into the autobuild?
Thanks for reporting. I've enabled 100b in the autobuild. Since it's a copy it really should be fine and not need additional testing.

You will probably want update to the autobuild version when it shows up (should be in the next 30 minutes or so), there have been some bug fixes since that test build.
I have tried the Autobuild version and I haven't found any issues, thanks for enabling it. The only nitpick is that the spashscreen says 100c rather than 100b, probably due to it being a copy  ;)


 

Related Topics