supplierdeeply

Poll

Please ignore this poll. I just wanted to post my question on SX50 crashes. Thankyou

Advice on fixing CHDK problems.
0 (0%)
Advice on issuing a workaround.
0 (0%)

Total Members Voted: 0

SX50 crashes: Subject Distance Override / Distance Bracketing / ND Filter Option

  • 1 Replies
  • 555 Views
Advertisements
Hi I would like to report three conditions that reproducibly lead to crashing of CHDK on my Canon SX50, Firmware 1C.

1. Setting Distance Override to any value (100 .. infinite) and setting the camera to manual focussing results in a crash after the shutter button is pressed. This is observed for CHDK versions 1.3.1, 1.4.1 and 1.5

2. Setting Distance Bracketing to any value and setting the camera to manual focussing results in a crash after the shutter is pressed and held. This is observed for CHDK versions 1.3.1, 1.4.1 and 1.5

3. Setting the the ND Filter Option to "In" now works since Firmware version 1.4.1. In 1.3.1 nothing happened despite the message that the ND Filter was in. However, when the shutter is half pressed, focussing only works correctly during the 1st attempt. If no photo is taken and the shutter is half-pressed again, the focussing light does not come on. If again no photo is taken and the shutter is half-pressed for a third time, the camera crashes, reproducibly.

Are there any updated CHDK distributions or alternative branches, etc. available that solve these issues ?

Thank you and best regards,
Klaas
« Last Edit: 08 / July / 2017, 00:26:44 by KlaMa »

Are there any updated CHDK distributions or alternative branches, etc. available that solve these issues ?
Short answer - no.  The latest CHDK code is always the "unstable" branch (CHDK version 1.5.x) and I'm quite sure there are no "fixes" related to your issues there.  Sorry.

SD override issues are a common problem with CHDK unfortunately. You can read most of the gory details here : Setting focus from scripts or menus.  It's quite possible the fixes found there did not make it into that port.

reyalp : should this be moved to the sx50 porting thread ?

edit :  I guess the MF issues are "old news" : Re: SX50 HS porting thread
« Last Edit: 08 / July / 2017, 01:31:06 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics