sx710 porting thread - page 3 - DryOS Development - CHDK Forum

sx710 porting thread

  • 30 Replies
  • 13653 Views
*

Offline mcgd

  • *
  • 23
Re: sx710 porting thread
« Reply #20 on: 15 / December / 2018, 08:17:24 »
Advertisements
Thanks for getting this port going!I have got hold of a 710HS and so far it's looking really good!I have a couple of questions:
First, I had previously been using a SX260HS, and during bracketing it was able to get much faster shutter speeds than the 1/3200 maximum achievable by normal means - at least 2 stops worth.  When I do this with the 710HS, bracketing doesn't go below 1/3200.  (I'm relying on what the image actually looks like here, not the metadata, as that was always 1/3200 on the 260 even with faster shutter speeds.)
So I'm wondering if this is just a physical limitation of this model, or whether having faster shutter speeds might be something not yet implemented in the port, or if there is an option I need to enable somewhere to make it happen?
Also, I thought I'd see if I could manually make it use a faster shutter speed, but when I go to the Tv override, and set it to "Short Exposure", I can't manually select a shutter speed shorter than 1/100.  It represents the speed as a decimal number and using the arrows changes it by 0.01, so if it's on 0.01 and I try and make it shorter, it just goes to 0.0000 (even though it has four digits after the decimal point).  Is this how it's meant to be? Is there some other way to adjust the manual exposure to be smaller than 0.01?
Many thanks-Matthew

*

Online reyalp

  • ******
  • 12646
Re: sx710 porting thread
« Reply #21 on: 15 / December / 2018, 16:23:56 »
Thanks for getting this port going!I have got hold of a 710HS and so far it's looking really good!I have a couple of questions:
First, I had previously been using a SX260HS, and during bracketing it was able to get much faster shutter speeds than the 1/3200 maximum achievable by normal means - at least 2 stops worth.  When I do this with the 710HS, bracketing doesn't go below 1/3200.  (I'm relying on what the image actually looks like here, not the metadata, as that was always 1/3200 on the 260 even with faster shutter speeds.)
So I'm wondering if this is just a physical limitation of this model, or whether having faster shutter speeds might be something not yet implemented in the port, or if there is an option I need to enable somewhere to make it happen?
This is likely a result of exp_drv_task not being implemented. I didn't implement this because long exposures are available without it (background here https://chdk.setepontos.com/index.php?topic=3461.msg135787#msg135787) but on many cameras it impacts very short exposures too.
What firmware version is your sx710?

I'd also be interested to know what kind of situation you find yourself needing faster than 1/3200.
Quote
Also, I thought I'd see if I could manually make it use a faster shutter speed, but when I go to the Tv override, and set it to "Short Exposure", I can't manually select a shutter speed shorter than 1/100.  It represents the speed as a decimal number and using the arrows changes it by 0.01
Like most CHDK numeric inputs, you can change which digit is controlled with the zoom lever. This is a bit tricky on SX710, it likes to jump more than one, but if you tap a few times you should be able to get the one you want.

However, if bracketing doesn't go beyond 1/3200, this almost certainly won't either, it uses exactly the same method under the hood.
Don't forget what the H stands for.

*

Offline mcgd

  • *
  • 23
Re: sx710 porting thread
« Reply #22 on: 16 / December / 2018, 21:54:42 »
What firmware version is your sx710?
I've got 1.00a
Quote
I'd also be interested to know what kind of situation you find yourself needing faster than 1/3200.
It's really useful for bracketing for HDR.  I usually start with the brightest exposure, then bracket through to the darkest one.  With bright scenes (e.g. with sun reflections), the darkest exposure required to capture the bright parts of the image needs to be much shorter than 1/3200. at wider apertures.  I can solve this by reducing the aperture before bracketing, then changing it back for other shots.  Trouble is that sometimes (e.g. with waves and reflections on the sand) I don't have long to take the shot, and I lose it while I'm changing the aperture.  With the 260HS, because it went to much shorter exposures, I could just leave the aperture, and fire away knowing the camera would be able to handle the brightest bits.  It wWould be great to have this working if possible.
Quote
Like most CHDK numeric inputs, you can change which digit is controlled with the zoom lever. This is a bit tricky on SX710, it likes to jump more than one, but if you tap a few times you should be able to get the one you want.
Thanks, I didn't know about that!  I was trying that mainly just to see if it was an issue with bracketing, but you've cleared that up now.

*

Online reyalp

  • ******
  • 12646
Re: sx710 porting thread
« Reply #23 on: 16 / December / 2018, 22:08:02 »
It's really useful for bracketing for HDR.  I usually start with the brightest exposure, then bracket through to the darkest one.  With bright scenes (e.g. with sun reflections), the darkest exposure required to capture the bright parts of the image needs to be much shorter than 1/3200.
That makes sense. Here's a test build for 100a with exp_drv implemented.

edit:
Oops, wrong build, will re-upload in a minute
Updated build attached, if you downloaded the -1 zip, use this instead.
« Last Edit: 16 / December / 2018, 22:13:31 by reyalp »
Don't forget what the H stands for.


*

Offline mcgd

  • *
  • 23
Re: sx710 porting thread
« Reply #24 on: 16 / December / 2018, 23:45:04 »
That makes sense. Here's a test build for 100a with exp_drv implemented.
Brilliant, that works nicely, many thanks!  Looks like it's getting over 2 stops shorter than 1/3200, very like the 260HS.  That will be a great help!

*

Online reyalp

  • ******
  • 12646
Re: sx710 porting thread
« Reply #25 on: 16 / December / 2018, 23:58:08 »
Brilliant, that works nicely, many thanks!  Looks like it's getting over 2 stops shorter than 1/3200, very like the 260HS.  That will be a great help!
Thanks for confirming. This change will be in autobuild 5141 and later.
Don't forget what the H stands for.

*

Offline Caefix

  • ***
  • 235
  • Sorry, busy deleting test shots...
Re: sx710 porting thread
« Reply #26 on: 28 / July / 2020, 14:36:46 »
 ???  :-X Tue Jul 28 18:43:12 2020,MF Test 3.2 Log
sx710hs,101a,CHDK_DE,1.5.0-5544
Mode:P,Continuous_AF:0,Servo_AF:0,Metering:1
tests : set_focus:1, set_aflock:1, set_mf:1, bypass:0

Without changing any setting (&& Exposure>=1sec) it throws one of those lines and ends up with black or garbled screen.
It could survive with a green screen, too...

ASSERT!! LiveImageTask.c Line 261
Task name: _imageSensor4

ASSERT!! RawToYuvPath.c Line 782
Task name: DevelopRawTo4

ASSERT!! LiveImageSub.c Line 2651
Task name: LiveImageTas4

Is there any use for GK.LOL files(128kb) ?
All lifetime is a loan from eternity.

*

Online reyalp

  • ******
  • 12646
Re: sx710 porting thread
« Reply #27 on: 28 / July / 2020, 16:00:59 »
???  :-X Tue Jul 28 18:43:12 2020,MF Test 3.2 Log
sx710hs,101a,CHDK_DE,1.5.0-5544
Mode:P,Continuous_AF:0,Servo_AF:0,Metering:1
tests : set_focus:1, set_aflock:1, set_mf:1, bypass:0
I was not able to reproduce this on my sx710 101 using the mftest.lua 3.1 script that's in the current source tree. I did not find the 3.2 version in a quick search and skim of the original MF rework thread https://chdk.setepontos.com/index.php?topic=11078.0


Quote
Is there any use for GK.LOL files(128kb) ?
No. GK.LOG is a romlog from the GPU, which is saved along with the romlog from the main core whenever there's a crash. We don't currently know how to parse it.
Don't forget what the H stands for.


*

Offline Caefix

  • ***
  • 235
  • Sorry, busy deleting test shots...
Re: sx710 porting thread
« Reply #28 on: 29 / July / 2020, 14:37:39 »
Hmm, resolution/filesize, language, grid, Safety-Mf(probably) excluded...
Maybe the summertime-switch? I´ve ISO fixed to 80.
Here IT happens between ..passed and ..done, not always crashing.
 Pointing in dark corner defaults to foggy..green area.
Sometimes last jpg is partially a (recursive?) pattern.
Btw. bypass=1 leads to FocusLensController.c/CaptSeqTask in
 2) Testing set_focus() only // start, , , ,1,0,0,0

// My Mftest.lua only logs a bit more...
Some testshots zipped for HiRes:
All lifetime is a loan from eternity.

*

Online reyalp

  • ******
  • 12646
Re: sx710 porting thread
« Reply #29 on: 29 / July / 2020, 15:42:02 »
Hmm, resolution/filesize, language, grid, Safety-Mf(probably) excluded...
Maybe the summertime-switch? I´ve ISO fixed to 80.
Here IT happens between ..passed and ..done, not always crashing.
 Pointing in dark corner defaults to foggy..green area.
Sometimes last jpg is partially a (recursive?) pattern.
Do you have DNG enabled?
Do you have "i-contrast" enabled?
Quote
Btw. bypass=1 leads to FocusLensController.c/CaptSeqTask in
 2) Testing set_focus() only // start, , , ,1,0,0,0
This is expected. Bypass tries to use focus override modes where it's known not to work. SX710 crashes if focus override is used with AF enabled.

Quote
// My Mftest.lua only logs a bit more...
So, "3.2" was just your version with more logging?

Do you encounter these crashes in normal use, or only when using this script?

Don't forget what the H stands for.

 

Related Topics