supplierdeeply

SX400IS external power gives memory card error with CHDK

  • 10 Replies
  • 433 Views
SX400IS external power gives memory card error with CHDK
« on: 02 / February / 2018, 16:53:31 »
Advertisements
The memory card is supposed to be in write protect to load CHDK and It does with the battery power. I can take pictures. Then I connected external power (dummy battery + DC converter ACK-DC90). Camera turns on fine. With memory card write protected, the CHDK menu comes on fine, a script is loaded fine. Shooting a picture causes the click but then brings on screen message "memory card error". So I remove the write protect. Camera powers up fine, takes pictures fine without card error message. However CHDK will not load. I have double checked it. Same.

Explanation? Solution? Thanks.

*

Offline reyalp

  • ******
  • 11335
Re: SX400IS external power gives memory card error with CHDK
« Reply #1 on: 02 / February / 2018, 17:48:09 »
Looks like this https://chdk.setepontos.com/index.php?topic=12795.0

If no one beats me to it, I'll look into whether the workaround mentioned there can be applied to sx400. In the meantime, it's possible a different SD card will not suffer from the same problem.
Don't forget what the H stands for.

Re: SX400IS external power gives memory card error with CHDK
« Reply #2 on: 02 / February / 2018, 18:34:20 »
Thank you. I looked at the above link, but it is all Greek to me. If it were bad/incompatible card it should have problem when on battery power too. I have used this card in this camera with CHDK for several months and never had memory error until today only on external power.

*

Offline reyalp

  • ******
  • 11335
Re: SX400IS external power gives memory card error with CHDK
« Reply #3 on: 02 / February / 2018, 22:28:07 »
If it were bad/incompatible card it should have problem when on battery power too.
You would think so, but this behavior of failing on external power with CHDK was seen in one of the cases linked from that thread. There seem to be some fairly sensitive interactions between how CHDK loads and how the card hardware is initialized. Quite why external power would matter is unclear, but there could be voltage or timing differences.
Don't forget what the H stands for.


Re: SX400IS external power gives memory card error with CHDK
« Reply #4 on: 02 / February / 2018, 22:50:40 »
If it were bad/incompatible card it should have problem when on battery power too.
You would think so, but this behavior of failing on external power with CHDK was seen in one of the cases linked from that thread. There seem to be some fairly sensitive interactions between how CHDK loads and how the card hardware is initialized. Quite why external power would matter is unclear, but there could be voltage or timing differences.
Batteries typically have a much better ability to deal with surge current requirements.

@ju1234 : Is your ACK-DC90 a genuine Canon product? Or a 3rd party "equivalent" model?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 11335
Re: SX400IS external power gives memory card error with CHDK
« Reply #5 on: 03 / February / 2018, 00:32:49 »
Here's a test build with the same workaround as used on sx530. Please report if it fixes the problem or not.

Since your card is already bootable, you can just copy the contents of the zip to the root of the card.
Don't forget what the H stands for.

*

Offline Ant

  • ****
  • 362
Re: SX400IS external power gives memory card error with CHDK
« Reply #6 on: 03 / February / 2018, 06:56:09 »
but there could be voltage or timing differences.

Perhaps there is a difference in startup sequences. EOS M3 reacts(EF-M 22mm lense doing it's focus drive initialisation) to closing the battery cover and play or power buttons. But there is no reaction when AC power is switched on.

Re: SX400IS external power gives memory card error with CHDK
« Reply #7 on: 03 / February / 2018, 20:28:05 »
Thank you Reyalp. Copying these files will replace the existing files. Should I let it. If it does not work will I have to revet back to the original files? If that is the case, should I  copy and save the existing files some where before I copy the ones you have attached.


*

Offline reyalp

  • ******
  • 11335
Re: SX400IS external power gives memory card error with CHDK
« Reply #8 on: 04 / February / 2018, 01:17:16 »
Thank you Reyalp. Copying these files will replace the existing files. Should I let it.
Yes, you need to replace all the files.
Quote
If it does not work will I have to revet back to the original files? If that is the case, should I  copy and save the existing files some where before I copy the ones you have attached.
You could just re-install CHDK however you installed it in the first place, or you could save a copy on your PC.
Don't forget what the H stands for.

Re: SX400IS external power gives memory card error with CHDK
« Reply #9 on: 04 / February / 2018, 08:58:19 »
It worked. Thank you.

For my SX500IS I do not have external power yet. I will most likely have the same problem with that one too. Is there a certain file in the above set that I can take to copy to that camera or will I need a whole new set?

Thanks.

 

Related Topics