SX610 HS porting thread - page 7 - DryOS Development - CHDK Forum  

SX610 HS porting thread

  • 65 Replies
  • 28294 Views
*

Offline reyalp

  • ******
  • 12436
Re: SX610 HS porting thread
« Reply #60 on: 01 / January / 2020, 16:07:08 »
Advertisements
Yes, no bugs found here this year.  ::)
Thanks, change checked in.

I wonder if this port is ready for the autobuild, or are there other things that need to be tested / fixed?
Don't forget what the H stands for.

*

Offline blackhole

  • *****
  • 738
  • A590IS 101b
    • Planetary astrophotography
Re: SX610 HS porting thread
« Reply #61 on: 01 / January / 2020, 18:46:36 »
I wonder if this port is ready for the autobuild, or are there other things that need to be tested / fixed?
Judging by the number of downloads, plenty of people use this port with no reported issues. I think it's safe to add a port to an auto build server.

*

Offline reyalp

  • ******
  • 12436
Re: SX610 HS porting thread
« Reply #62 on: 03 / January / 2020, 19:49:57 »
This cam seems to have the same style filewrite task as elph180, so here's a test build with that enabled.

To test, please enable continuous shooting in the canon firmware and run the following chdkptp command from the command prompt / shell
Code: [Select]
chdkptp -e"exec require'camtests'.runbatch{shoot=true}"

edit 2020/01/05
Replaced build with test-2 to fix a mistake I found in the elph180 version of the code. This mistake seems to have been harmless on elph180.

edit2
and again with test-3 to actually hook up filewrite task :-[
« Last Edit: 05 / January / 2020, 18:30:33 by reyalp »
Don't forget what the H stands for.

*

Offline reyalp

  • ******
  • 12436
Re: SX610 HS porting thread
« Reply #63 on: 09 / January / 2020, 21:09:39 »
Judging by the number of downloads, plenty of people use this port with no reported issues. I think it's safe to add a port to an auto build server.
Added to the autobuild in r5400. I included the filewrite code, but #ifdef'd it out pending a test report.
Don't forget what the H stands for.


*

Offline Caefix

  • ***
  • 144
  • Sorry, busy deleting test shots...
Re: SX610 HS porting thread
« Reply #64 on: 21 / February / 2020, 12:28:19 »
exec require'camtests'.runbatch{shoot=true} : Passed 15, failed 0, seems all okay.  :D
All lifetime is a loan from eternity.

*

Offline reyalp

  • ******
  • 12436
Re: SX610 HS porting thread
« Reply #65 on: 22 / February / 2020, 23:47:08 »
exec require'camtests'.runbatch{shoot=true} : Passed 15, failed 0, seems all okay.  :D
Thanks for the report. I enabled filewrite in autobuild 5428

FYI, if you are running chdkptp tests on new ports, you might as well test everything, using
Code: [Select]
chdkptp -e"exec require'camtests'.runbatch{bench=true,filexfer=true,shoot=true,xfersizebugs=true}"
Don't forget what the H stands for.

 

Related Topics