SX610 HS porting thread - page 6 - DryOS Development - CHDK Forum

SX610 HS porting thread

  • 65 Replies
  • 30919 Views
Re: SX610 HS porting thread
« Reply #50 on: 04 / February / 2019, 19:41:23 »
Advertisements
You can use the old build to make a bootable SD card.The SD card must be formatted as FAT32.
Miscellaneous stuff 》》SD card 》》Make card bootable
To expand slightly on that, use the old build and follow the menu path @blackhole listed.  That configures your card to be bootable - but note that it must first be formatted FAT32.

Once you have done that, simply unzip the new build that I posted onto your SD card with full folder expansion.  Then set the SD card lock switch to the "locked" position, insert it into your camera, and power up. You should see the CHDK logo as the camera starts up, indicating a successful installation.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline Caefix

  • ****
  • 309
  • Sorry, busy deleting test shots...
Re: SX610 HS porting thread
« Reply #51 on: 25 / July / 2019, 12:39:30 »
Hi together!
Got a SX610 yesterday, the mousemeter to get it run with CHDK was done as fast as unpacking it :)

It´s another port with a voodoo in zoom keys.
Each manual press gives a click to the lens, moving it one step (from 100). Watch zoom bar.
You can trap it with test\ubtest.bas


PS: Equivalent behavior in playmode, makes Textbox() unusable.
BUT: set_zoom works fine, no distortion.

Edit: alt. testbuild removed.

... nice, nevertheless: (bookscannertype md-tool)
« Last Edit: 31 / December / 2019, 13:40:27 by Caefix »
All lifetime is a loan from eternity.

*

Offline reyalp

  • ******
  • 12796
Re: SX610 HS porting thread
« Reply #52 on: 30 / December / 2019, 14:46:49 »
From the sx730 thread:
//  :-* Sx 610 & 620 : maybe same problem solvable?
I don't understand your earlier post in this thread about zoom keys, so I don't know if it's the same problem.

The problem on sx730 was:
In shooting mode, enter alt, click zoom in or out, lens moves

Expected behavior:
In alt mode, the canon firmware should not respond to keys

If this is the problem you see on sx610, we can fix it. If there was some other problem, you need to describe it more specifically.
Don't forget what the H stands for.

*

Offline Caefix

  • ****
  • 309
  • Sorry, busy deleting test shots...
Re: SX610 HS porting thread
« Reply #53 on: 30 / December / 2019, 14:50:57 »
 :D That´s it.
All menues & textbox etc. are affected, too.
All lifetime is a loan from eternity.


*

Offline reyalp

  • ******
  • 12796
Re: SX610 HS porting thread
« Reply #54 on: 30 / December / 2019, 15:15:51 »
:D That´s it.
All menues & textbox etc. are affected, too.
OK.  We need to know what bits in physw_status change when you use the zoom key.

I suspect this camera has two stage zoom, where if you press a little, the zoom moves more slowly, and if you press all the way, it moves faster. We need to test both.

Using chdkptp, you can test like this.
connect to the camera. Leave it in play mode, so the canon firmware won't respond to any keys, and make sure it's NOT in alt mode so CHDK won't mask any bits.

First, without any keys pressed:
Code: [Select]
rmem -i32 0x00019804 3
Then repeat the command with the zoom key held in each direction. If it has two stages, check each stage. Some values probably in the 3rd number should respond to the changes.

If you don't use chdkptp, you can check with the memory browser. The zoom keys are probably in the 3rd word, so you should start at 0x0001980C

edit:
0x00019804 is the address of physw_status from stubs_entry.S for this camera. If you want to test other cameras, you can get the address from there.
« Last Edit: 01 / January / 2020, 16:09:01 by reyalp »
Don't forget what the H stands for.

*

Offline Caefix

  • ****
  • 309
  • Sorry, busy deleting test shots...
Re: SX610 HS porting thread
« Reply #55 on: 31 / December / 2019, 11:08:18 »
Code: [Select]
0x0001980C = 0xf7f4
right/2    = 0xE7f4
right out  = 0xf7f4
left/2     = 0x87f4
left out   = 0xf7f4

0x00019818 = 0xf400
right/2    = 0xE400
right out  = 0xf400
left/2     = 0xB400
left out   = 0xf400 
Edit: isobase.Lua: "set CAM_MARKET_ISO_BASE=200"
(same on Sx710, S110...)
« Last Edit: 31 / December / 2019, 12:41:57 by Caefix »
All lifetime is a loan from eternity.

*

Offline reyalp

  • ******
  • 12796
Re: SX610 HS porting thread
« Reply #56 on: 31 / December / 2019, 13:18:30 »
Code: [Select]
0x0001980C = 0xf7f4
right/2    = 0xE7f4
right out  = 0xf7f4
left/2     = 0x87f4
left out   = 0xf7f4

0x00019818 = 0xf400
...
0x19818 is outside physw_status   :blink:

Also, I should have mentioned, the test should be done NOT in alt mode, otherwise the known bits won't change.

Anyway, if the above was in alt mode, the bits in 1980C that changed should be slow speed, and weren't in the current settings. Test build attached.

Quote
Edit: isobase.Lua: "set CAM_MARKET_ISO_BASE=200"
(same on Sx710, S110...)
200 is the default for cameras with dryos >r49, so this is fine. The script only says what it should be, not whether it's already set correctly.
Don't forget what the H stands for.

*

Offline Caefix

  • ****
  • 309
  • Sorry, busy deleting test shots...
Re: SX610 HS porting thread
« Reply #57 on: 31 / December / 2019, 13:32:17 »
 :haha :D :xmas :-* :lol  A happy new cam 2019!?
All lifetime is a loan from eternity.


*

Offline reyalp

  • ******
  • 12796
Re: SX610 HS porting thread
« Reply #58 on: 31 / December / 2019, 15:23:22 »
:haha :D :xmas :-* :lol  A happy new cam 2019!?
Does this mean the test build works correctly?
Don't forget what the H stands for.

*

Offline Caefix

  • ****
  • 309
  • Sorry, busy deleting test shots...
Re: SX610 HS porting thread
« Reply #59 on: 01 / January / 2020, 10:53:11 »
:haha :D :xmas :-* :lol  A happy new cam 2019!?
Does this mean the test build works correctly?
Yes, no bugs found here this year.  ::)
All lifetime is a loan from eternity.

 

Related Topics