A better(?) way to control display off - page 9 - General Discussion and Assistance - CHDK Forum  

A better(?) way to control display off

  • 81 Replies
  • 22966 Views
Re: A better(?) way to control display off
« Reply #80 on: 25 / March / 2018, 10:10:56 »
Advertisements
I tried this on a few cameras. elph130, sx160, d10 all work correctly. a540 completes the script and ends up with the display on, but completely blank. Exiting alt and pressing menu brings it back. This issue is discussed earlier in the thread.
Yea - I added code some time ago to ultimate.lua to handle that case.

Quote
We could make the mode switching functions turn the display on before switching, but we'd need to track the original state to know to turn it back off after the switch completed. It's also possible that the mode switch isn't fully complete when the function returns, which might cause problems if we tried to immediately change the LCD state.
Probably not worth it for the unknown but limited number of camera's this appears to affect (S95,A560,G10 so far) and the fairly specialized use case.  Once it's understood, it's easy to script around it. And I have not explored whether things like Canon shooting mode or other setting affect it. Maybe just add a note in the wiki definition of the function?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 12793
Re: A better(?) way to control display off
« Reply #81 on: 25 / March / 2018, 18:52:07 »
Probably not worth it for the unknown but limited number of camera's this appears to affect (S95,A560,G10 so far) and the fairly specialized use case.  Once it's understood, it's easy to script around it. And I have not explored whether things like Canon shooting mode or other setting affect it. Maybe just add a note in the wiki definition of the function?
Makes sense to me, I added a note on the wiki.
Don't forget what the H stands for.

 

Related Topics