supplierdeeply

Need help: SX530HS, loaded CHDK 1.5.0, main screen keeps flickering

  • 6 Replies
  • 468 Views
Advertisements
Please, I need help. SX530HS: I was not able to install CHDK using the STICK. So, I did it using the Bootable SD card method. There is only 1.5.0 available for this camera which I was able to install. Few issues:

When I press the playback button to go to <Alt> mode, instead of showing the red <alt> logo on the bottom of the screen, it shows the user menu. Pressing the display button again removes the user menu from screen. If I instead press the Menu button, screen changes to main menu and when pressed one more time, the red color <Alt> with the currently set script shows on the bottom. Is this all normal. I thought pressing the display button is supposed to bring the <alt>.

Some time (No specific circumstances I have been able to pin point) the center part of the screen is flickering making it difficult to read the menu items and there is tick tick sound as if the auto focus is  continuously trying to focus. How do I fix that problem.

Thanks.

*

Offline reyalp

  • ******
  • 11541
Re: Need help: SX530HS, loaded CHDK 1.5.0, main screen keeps flickering
« Reply #1 on: 22 / February / 2018, 22:11:06 »
When I press the playback button to go to <Alt> mode, instead of showing the red <alt> logo on the bottom of the screen, it shows the user menu. Pressing the display button again removes the user menu from screen. If I instead press the Menu button, screen changes to main menu and when pressed one more time, the red color <Alt> with the currently set script shows on the bottom. Is this all normal. I thought pressing the display button is supposed to bring the <alt>.
The default alt key on this camera is the PLAY button. There is an option to open the user menu on alt ("On Dire" in CHDK menu settings), but it's not on by default. You can use "Reset options to default" in the CHDK menu to restore defaults.

Quote
Some time (No specific circumstances I have been able to pin point) the center part of the screen is flickering making it difficult to read the menu items and there is tick tick sound as if the auto focus is  continuously trying to focus. How do I fix that problem.
This sounds like you have Continuous AF enabled in the Canon firmware. For modes that allow manual controls (M, P etc), Continuous AF can be turned off in the Canon menu. In AUTO and some scene modes, it may be on all the time. When this does or doesn't disrupt the CHDK UI may depend on the scene.

If you want continuous AF enabled, I'd suggest adjusting your CHDK settings in playback or in a mode with continuous AF turned off.
Don't forget what the H stands for.

Re: Need help: SX530HS, loaded CHDK 1.5.0, main screen keeps flickering
« Reply #2 on: 22 / February / 2018, 23:38:08 »
Thanks Reyalp. I got the first part fixed. I understand that I can set it to show the user menu as start up when going to <Alt> or not.

I am still having problems with the second part of my question. I am having difficulty understanding your explanations of the autofocus. I did not find any way to enable/disable autofocus.

Here is what I have noticed about this problem: When camera is turned on, it starts in the playback mode. In that mode, pressing the play button turns <Alt> on and CHDK menu can be turned on. Then there is no flickering. If I put the camera in shooting mode by pressing halfway on the shutter, then the autofocus is continuously seeking , I can see the center box change in size continuously. Now if I press the play button to turn <Alt> on, then there is flickering and I can see the box changing. Now if I need to make any changes in CHDK settings, I cannot do that because of the severe flickering. I must turn the camera off/on or change it back to the play mode before I can make changes. This is not normal (because this is not so in my SX400IS). I used the SX400 for shooting last year's eclipse. Being able to change CHDK settings while camera was in shooting mode was very useful. Is my understanding of problem correct or is there some other solution? Thanks again.


*

Offline reyalp

  • ******
  • 11541
Re: Need help: SX530HS, loaded CHDK 1.5.0, main screen keeps flickering
« Reply #3 on: 22 / February / 2018, 23:52:27 »
If I put the camera in shooting mode by pressing halfway on the shutter, then the autofocus is continuously seeking , I can see the center box change in size continuously.
Now if I press the play button to turn <Alt> on, then there is flickering and I can see the box changing. Now if I need to make any changes in CHDK settings, I cannot do that because of the severe flickering. I must turn the camera off/on or change it back to the play mode before I can make changes. This is not normal (because this is not so in my SX400IS). I used the SX400 for shooting last year's eclipse.
As I said, the continuous focusing depends on Canon firmware settings, which you can change using canon controls and menus.
This may be due to the shooting mode (M, P, AUTO, etc) or "Continuous AF" setting in the Canon menu. Some shooting modes (usually AUTO) don't let you turn Continuous AF off. Face detect AF may also have the same effect on some cameras.

You could also probably adjust the CHDK menu while the Canon menu is open

edit:
Screenshot added
« Last Edit: 23 / February / 2018, 00:11:21 by reyalp »
Don't forget what the H stands for.


Re: Need help: SX530HS, loaded CHDK 1.5.0, main screen keeps flickering
« Reply #4 on: 23 / February / 2018, 08:38:16 »
Thank you very much for taking the time. I understand. On my camera's canon menu for some reason the option of "continuous AF off/on" is not there in any of the modes. Instead there is option of "AF-point zoom off/on". I turned that off but did not male any difference.

Which items should I adjust in the "CHDK menu while Canon menu is open"?
« Last Edit: 23 / February / 2018, 08:58:26 by ju1234 »

*

Offline blackhole

  • *****
  • 613
  • A590IS 101b
    • Planetary astrophotography
Re: Need help: SX530HS, loaded CHDK 1.5.0, main screen keeps flickering
« Reply #5 on: 23 / February / 2018, 09:41:00 »
See User guide, pages 68, 69 and 70.
One of these settings is your problem. Be sure the camera is not in AUTO mode.
http://gdlp01.c-wss.com/gds/6/0300017626/01/PowerShot_SX530_HS_Camera_User_Guide_EN.pdf

*

Offline reyalp

  • ******
  • 11541
Re: Need help: SX530HS, loaded CHDK 1.5.0, main screen keeps flickering
« Reply #6 on: 23 / February / 2018, 14:11:40 »
Which items should I adjust in the "CHDK menu while Canon menu is open"?
I only meant that if you open the canon menu and then open the CHDK menu, the CHDK menu probably won't flicker. So if you don't want to switch to play, you could open the Canon menu and then open the CHDK menu to change CHDK settings without the flickering. However, the colors in the CHDK menu will probably be wrong and may be hard to read.

Don't forget what the H stands for.

 

Related Topics