Powershot SX620 HS CHDK - page 3 - General Help and Assistance on using CHDK stable releases - CHDK Forum

Powershot SX620 HS CHDK

  • 25 Replies
  • 8093 Views
*

Online blackhole

  • *****
  • 681
  • A590IS 101b
    • Planetary astrophotography
Re: Powershot SX620 HS CHDK
« Reply #20 on: 03 / August / 2019, 09:20:26 »
Advertisements
Hello blackhole, I have SX620 HS and I wanted to test your build, but it expired :(
Could you make another one, please?
Here is the test release for the SX620HS,a firmware version 100b.
Can you please go through these tests and post a report here?
https://chdk.fandom.com/wiki/Testing

Re: Powershot SX620 HS CHDK
« Reply #21 on: 05 / August / 2019, 19:04:59 »
Thank you for the build :)
I'm still testing it (I test functions in portions, partially) - I encountered some problems, so first I tried to resolve them by myself and then created this small report.

Overrides - looks fine (shutter speed and iso override), but I have to test much more there of course.

DNG - it's ok, but in the first tries, images were seriously broken. I had to switch everything what I could in camera os to manual control. After that results were pretty good.
DNG 1.3 - too many bad pixels in very first tries (hundreds of thousands) - don't know why exactly. I switched to DNG 1.1 and had ~8K bad pixels - not bad. Then back to DNG 1.3 and... ~8K bad pixels - not exactly sure what happened here but it's fine now, low level of bad pixels.

I'm not able to open any RAW in non-DNG format (.CRW, .CR2). Tried in RawTherapee 5.6, RAWHide and Adobe Lightroom - no effects. I can't say if they are corrupted or problem lays on the software side (unsupported maybe?).

File counter (single and continuous shots) - ok, numbers match
RAW File in Dir with JPEG - ok
Free memory - over 800kb, so it's fine
zebra test - correct overexposure detection, no offset

Scripts tests:
isobase.lua - shows "BASE=200, set CAM_MARKET_ISO_BASE 200"
mftest.lua - It crashes in the first test, in the "set_focus() only", so I disabled it. Passes the rest: https://drive.google.com/open?id=1Pqidn-CK5zrw_wh1Pfi8QyyGhCxDkhCD
llibtst.lua test - passed
setmode.lua - passed

That's what I tested to this day, there will be more in the next days :)

*

Online blackhole

  • *****
  • 681
  • A590IS 101b
    • Planetary astrophotography
Re: Powershot SX620 HS CHDK
« Reply #22 on: 06 / August / 2019, 05:09:16 »
I'm not able to open any RAW in non-DNG format (.CRW, .CR2). Tried in RawTherapee 5.6, RAWHide and Adobe Lightroom - no effects. I can't say if they are corrupted or problem lays on the software side (unsupported maybe?).
Thanks for the report.
This is normal, CHDK raw is not a real format, like on cameras that support it by default. It's just a bitmap from the sensor so applications don't recognize it. The DNG format is the recommended method of use.

Can you share one DNG, I need it to determine the active area of the sensor?

*

Offline reyalp

  • ******
  • 11998
Re: Powershot SX620 HS CHDK
« Reply #23 on: 06 / August / 2019, 12:10:45 »
DNG - it's ok, but in the first tries, images were seriously broken. I had to switch everything what I could in camera os to manual control. After that results were pretty good.
It would be good to know if it's broken in a specific shooting mode. For example, is it bad in Auto but OK in P.
Also, when it's "seriously broken" is there any recognizable image at all, or is it just random patterns?
Don't forget what the H stands for.


Re: Powershot SX620 HS CHDK
« Reply #24 on: 06 / August / 2019, 13:13:39 »
DNG: https://drive.google.com/open?id=1HDaYYw9qRzHOAzpaigrnv3WLMKS5jcba

and "broken" DNG: https://drive.google.com/open?id=1C9KJ0ph7f2mABiWiGikaCMOVB6KyJAEM
Quote
Also, when it's "seriously broken" is there any recognizable image at all, or is it just random patterns?
I would say both but don't bother it anymore - I restored default Canon settings and it works fine in P and Auto. I had "broken" DNGs in the first tries probably becasue of lack of knowledge - this exact, weird result happens in "fast series of photos" shooting mode.

*

Offline reyalp

  • ******
  • 11998
Re: Powershot SX620 HS CHDK
« Reply #25 on: 06 / August / 2019, 16:17:45 »
I would say both but don't bother it anymore
I see what you mean about both, that's quite odd.

We want to make it work as well as possible, so it's good to know about any issues you find. Even if we can't fix them, we can save people trouble by disabling raw in modes that don't work, or at least flagging things quickly when other users run into them.
Quote
- I restored default Canon settings and it works fine in P and Auto.  I had "broken" DNGs in the first tries probably becasue of lack of knowledge - this exact, weird result happens in "fast series of photos" shooting mode.
By "fast series of photos" do you mean continuous mode, or something different like HDR or other scenes mode that shoots several images and combines them?

You should test bursts of several photos in continuous mode. If you get some bad images in a burst, the port might not be set up correctly to handle multiple raw buffers, and this can be fixed.

The port should disable raw in modes in scene modes where it doesn't work or make sense.

Thanks for testing and reporting :)
Don't forget what the H stands for.

 

Related Topics