supplierdeeply

SX210IS long exposure not working

  • 8 Replies
  • 282 Views
SX210IS long exposure not working
« on: 20 / July / 2018, 17:47:47 »
Advertisements
I'm a long time user of CHDK and it runs flawlessly on several other cameras I have. I just picked up a Canon SX210IS today and loaded CHDK up on it, everything went smooth until I tried to take a test long exposure shot.

Camera settings:

AF-Point Zoom OFF
Servo AF OFF
Continuous AF OFF
AF-assist Beam OFF
MF-Point Zoom OFF

The camera is in M mode, but I've also tried it in P, and TV.

CHDK settings:

Enhanced Photo Operations-> Disable Overrides NO
Enhanced Photo Operations-> Override TV type LongExp
  • Checked

Enhanced Photo Operations-> Long Exp. Value 0:01:00
Enhanced Photo Operations-> Dark Frame Subtraction OFF
Enhanced Photo Operations-> Disable Overrides on Startup [] Unchecked

Dark Frame subtraction is noticeably working, but the camera will not take an exposure longer than what the Canon menu is set to. I've turned on CHDK OSD to show my TV settings and it indeed says  TV:0:01:00 in the upper left corner.

I'm not sure what else I should try? I've read through some different posts about what could prevent the overrides from working but I think I've disabled all of those (AutoFocus, etc.).  Any help would be greatly appreciated!

Re: SX210IS long exposure not working
« Reply #1 on: 21 / July / 2018, 00:48:02 »
OK so I've been scouring the forums and playing with settings and came across something interesting. If I use the built in camera timer delay it works. I've used the 2 and 10 second delay and either one will delay and then take my 1:00 minute exposure.

*

Offline reyalp

  • ******
  • 11448
Re: SX210IS long exposure not working
« Reply #2 on: 21 / July / 2018, 01:05:39 »
This is pretty odd, I don't see anything obviously wrong with port.

When you shoot manually, are you waiting for the camera to focus with the shutter at half press, then pressing fully? Or just pressing the button right away? Quick press sometimes has problems, but this port already has the usual workaround.

Have you tried shorter overrides, like if the camera would use 1/100, setting the override to 1/500?
Don't forget what the H stands for.

Re: SX210IS long exposure not working
« Reply #3 on: 21 / July / 2018, 11:04:16 »
Quote
When you shoot manually, are you waiting for the camera to focus with the shutter at half press, then pressing fully? Or just pressing the button right away? Quick press sometimes has problems, but this port already has the usual workaround.

This is it. The camera mode is in TV. I reset all camera and CHDK settings.

CHDK:
Override Tv Type ->
LongExp
Long Exp. Value
0:01:00
Disable Overrides on Startup
Off

Quick pressing takes a normal shot ignoring the overrides. Long pressing and letting focus takes the minute exposure. I haven't tried it with other shorter values yet but I can if you want me to.

Lol, I never claimed to be a photographer that knows what they're doing! I use CHDK mostly for astrophotography so I have it in either continuous or with a basic loop script. 

Thank you for the help!


*

Offline reyalp

  • ******
  • 11448
Re: SX210IS long exposure not working
« Reply #4 on: 21 / July / 2018, 16:21:10 »
Quick pressing takes a normal shot ignoring the overrides. Long pressing and letting focus takes the minute exposure. I haven't tried it with other shorter values yet but I can if you want me to.
Thanks. It sounds like it's related to the quick press rather than exposure length, so it's probably not necessary.

I've attached a test build with a variation of the quick press workaround. Please let me know if it solves the problem.

Quote
Lol, I never claimed to be a photographer that knows what they're doing! I use CHDK mostly for astrophotography so I have it in either continuous or with a basic loop script. 

Thank you for the help!
FWIW, if you use a script, using the shoot function should do the correct wait, or if you are using key presses wait for get_shooting like
Code: [Select]
press "shoot_half"
while get_shooting <> 1
 sleep 10
wend
click "shoot_full"

FWIW, a script I wrote for astrophotography is available at https://chdk.wikia.com/wiki/Lua/Scripts:_Fixed_Exposure_Intervalometer
Don't forget what the H stands for.

Re: SX210IS long exposure not working
« Reply #5 on: 23 / July / 2018, 09:32:52 »
I've attached a test build with a variation of the quick press workaround. Please let me know if it solves the problem.

Sorry just got around to trying this. Put this in place, changed only the same settings as above, and quick pressed several times and that seemed to do the trick. The TV overrides are working in this build with the quick press.


FWIW, a script I wrote for astrophotography is available at https://chdk.wikia.com/wiki/Lua/Scripts:_Fixed_Exposure_Intervalometer

I've always either used a script or the built in timer when taking shots to avoid any vibrations. In my haste to test out my new camera I was just impatiently smacking that button and wondering why it wasn't working. I'll try out this script. Thanks again! I feel I owe this community a lot.

*

Offline reyalp

  • ******
  • 11448
Re: SX210IS long exposure not working
« Reply #6 on: 23 / July / 2018, 13:06:54 »
Sorry just got around to trying this. Put this in place, changed only the same settings as above, and quick pressed several times and that seemed to do the trick. The TV overrides are working in this build with the quick press.
Thanks. Can you confirm that the TV override still works for normal (not quick press) shooting?

Also, if you can check whether ISO overrides work, that would be helpful. To test, you can set ISO to 100 in the Canon UI, camera in P mode. Override ISO to 400 in CHDK UI, no other CHDK overrides. The resulting shot should be overexposed.
Don't forget what the H stands for.

Re: SX210IS long exposure not working
« Reply #7 on: 24 / July / 2018, 20:49:54 »
Yes the TV overrides work for quick or normal press.

Also, if you can check whether ISO overrides work, that would be helpful. To test, you can set ISO to 100 in the Canon UI, camera in P mode. Override ISO to 400 in CHDK UI, no other CHDK overrides. The resulting shot should be overexposed.

I couldn't see a difference between 100 vs 400 but setting the canon to 80 and the ISO override to 1600 made it obvious. Ok 100 vs 400 is obvious too with the flash.

Thanks again! If there's anything else I can help with I still owe!


*

Offline reyalp

  • ******
  • 11448
Re: SX210IS long exposure not working
« Reply #8 on: 25 / July / 2018, 01:44:14 »
I couldn't see a difference between 100 vs 400 but setting the canon to 80 and the ISO override to 1600 made it obvious.
As long as the subject is something the camera can expose enough to have a recognizable picture, 100 to 400 should be very obvious.

There is a quirk in CHDK ISO overrides that can confuse testing: After you shoot or half press with the CHDK override active, the camera auto exposure will act like auto ISO is enabled until you set change the ISO in the Canon UI or restart. This shouldn't be an issue if you test the no override case first, but might if you had tried more than once.

I've attached a simple test script that will avoid this. You should be able to just aim the camera somewhere there's enough light to take a picture and run it. I'd suggest leaving the flash off to minimize other sources of confusion.

Thanks again for testing.
Don't forget what the H stands for.

 

Related Topics