supplierdeeply

Displaying images downloaded from Internet and showing them on the camera LCD...

  • 5 Replies
  • 215 Views
Advertisements
I'm currently fiddling with trying to get my A570 to display images from the Internet (let's say I downloaded a copy of up goer 5 from the xkcd website and put it in DCIM/105CANON). As of right now it isn't working but I know it can (when I used a newer Sony camera, it worked with the images set to 1080p, and the A570 displayed them as well). If there's a better way than 1080p then tell me.

Update: 1080p isn't working, nor is native camera res (the 7.1MP size images).
« Last Edit: 15 / August / 2018, 03:56:57 by the2048 »
A570IS 101a, if that's what matters the most.

*

Offline msl

  • *****
  • 1237
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
You have to adjust the image files a bit.

The dimensions of the image must be divisible by 8 and the file name must have the following pattern, IMG_xxxx.JPG (xxxx is a number from 0001 to 9999).

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!

Done that (if the native image size of the camera is divisible by 8 ), and it still says "Unsupported Image" or something along the lines of that. It worked once, but not now... What else could I try?


edit: turns out 8 with a closing parentheses does glasses smiley but I added a space to mitigate that
« Last Edit: 15 / August / 2018, 23:08:28 by the2048 »
A570IS 101a, if that's what matters the most.

*

Offline reyalp

  • ******
  • 11496
Done that (if the native image size of the camera is divisible by 8 ), and it still says "Unsupported Image" or something along the lines of that. It worked once, but not now... What else could I try?
Use the exif from a real camera image. You can probably do it with exiftool, or maybe open real camera image in gimp, paste the image you want, save with the preserve exif option.

Don't forget what the H stands for.


I'll try that (just typing in the EXIF data in the Windows Properties file dialog compared to a photo shot with an A570 didn't work).
Update: Now the image isn't showing at all.
Update 2: I can make my own voice memos that play on the camera (quick editing in Audacity to make it WAV, mono, it works with 44.1KHz sampling rate) but the Internet downloaded photos don't display. I'll try some more, but if it works, the steps will be added.
« Last Edit: 17 / August / 2018, 00:42:49 by the2048 »
A570IS 101a, if that's what matters the most.

*

Offline reyalp

  • ******
  • 11496
but the Internet downloaded photos don't display. I'll try some more, but if it works, the steps will be added.
I'd suggest comparing the exif and other image properties of working and non-working images using tools like exiftool and/or exiv2. There are a lot of details and canon-specific tags windows properties doesn't show you.
Don't forget what the H stands for.

 

Related Topics