Problem remoteshoot with ixus240hs - page 2 - General Discussion and Assistance - CHDK Forum

Problem remoteshoot with ixus240hs

  • 16 Replies
  • 468 Views
*

Offline dan86

  • *
  • 13
Re: Problem remoteshoot with ixus240hs
« Reply #10 on: 11 / March / 2020, 16:55:15 »
Advertisements
In the L setting there is no error during the remoteshoot command, but the 240 crashes with the play command.
So in summary in record mode I can do as many remoteshoot as I want but with error messages in setting M. the 240hs crashes as soon as I do the command play after remoteshoot

*

Offline reyalp

  • ******
  • 12537
Re: Problem remoteshoot with ixus240hs
« Reply #11 on: 12 / March / 2020, 01:39:45 »
In the L setting there is no error during the remoteshoot command, but the 240 crashes with the play command.
This sounds like a known problem that happens on a lot of cameras. The camera crashes when you switch to play if the image file is missing. Try including -jpgdummy in the the remoteshoot command. This creates an empty file with the same name as the image. You can delete the empty files after you switch to play.

The problem in M2 size is still a bug, which I haven't seen on other cameras.
Don't forget what the H stands for.

*

Offline dan86

  • *
  • 13
Re: Problem remoteshoot with ixus240hs
« Reply #12 on: 12 / March / 2020, 03:33:39 »
Hello

Here after ordering my trials

in M position

daniel@daniel-pc:~/tempo/chdk/chdkptp-r921$ ./chdkptp.sh
___> connect
connected: Canon IXUS 240 HS, max packet size 512
con> rec
con 1> remoteshoot -quick -jpgdummy
WARNING: capture_get_data error General Error
ERROR: General Error
con 4> play
con 5> rec
con 6> remoteshoot -quick -jpgdummy
WARNING: capture_get_data error General Error
ERROR: General Error
con 9> play
con 10> rec
con 11> remoteshoot -quick -jpgdummy
WARNING: capture_get_data error General Error
ERROR: General Error
con 14> play

In L Position

con> connect
connected: Canon IXUS 240 HS, max packet size 512
con> rec
con 1> remoteshoot -quick -jpgdummy
con 4> play
con 5> rec
con 6> remoteshoot -quick -jpgdummy
con 9> play
con 10> rec
con 11> remoteshoot -quick -jpgdummy
con 14> play

In both cases there is no 240hs crash with the play command.
In position M there are always error messages but without blogging
thanks a lot for your help

*

Offline reyalp

  • ******
  • 12537
Re: Problem remoteshoot with ixus240hs
« Reply #13 on: 12 / March / 2020, 13:32:06 »
In position M there are always error messages but without blogging
In M, do you get a usable image file?
Don't forget what the H stands for.


*

Offline dan86

  • *
  • 13
Re: Problem remoteshoot with ixus240hs
« Reply #14 on: 12 / March / 2020, 16:16:58 »
Yes it is perfectly usable. There is just the presence of error messages. There is no longer any blockage with the jpgdummy option in the remoteshoot.
As I do a photobooth the definition M is more than enough.

*

Offline reyalp

  • ******
  • 12537
Re: Problem remoteshoot with ixus240hs
« Reply #15 on: 12 / March / 2020, 19:47:37 »
Yes it is perfectly usable. There is just the presence of error messages. There is no longer any blockage with the jpgdummy option in the remoteshoot.
Thanks. Can you do a test like this
size M
one shot with rs -jpg -jpgdummy
another shot, without changing the scene or anything using shoot -dl
Upload both files. Use google drive or dropbox if they are too big for the forum.
Don't forget what the H stands for.

*

Offline dan86

  • *
  • 13
Re: Problem remoteshoot with ixus240hs
« Reply #16 on: 13 / March / 2020, 02:35:36 »

Hello
here are the 2 photos.
I had a timeout at the first shoot -dl

           
con 1> connect         
connected: Canon IXUS 240 HS, max packet size 512
con> rec   
con 2> rs -jpg -jpgdummy
WARNING: capture_get_data error General Error
ERROR: General Error
con 5> shoot -dl       
ERROR: :39: wait A/DCIM/100___03/IMG_0002.JPG timeout
rlib wait_timeout:16

con 7> shoot -dl
A/DCIM/100___03/IMG_0003.JPG->IMG_0003.JPG
con 10> play

 

Related Topics