CHDK and SX100is

  • 9 Replies
  • 290 Views
CHDK and SX100is
« on: 09 / October / 2018, 15:53:50 »
Advertisements
Hi all,
        I recently (actually today) bought an SX100. A search of the forum turned up some issues with CHDK for this camera. Is there a particular release I should use?
Thanks,
..... john

*

Offline reyalp

  • ******
  • 11514
Re: CHDK and SX100is
« Reply #1 on: 09 / October / 2018, 16:34:43 »
Hi all,
        I recently (actually today) bought an SX100. A search of the forum turned up some issues with CHDK for this camera. Is there a particular release I should use?
Thanks,
..... john
You should use the latest trunk (development) autobuild, and if there are unresolved problems, you should report them.

Don't forget what the H stands for.

Re: CHDK and SX100is
« Reply #2 on: 10 / October / 2018, 12:12:26 »
Hi reyalp,
         Would this be the latest version for GM1.00C?
sx100is-100c-1.4.1-5097-full.zip
Thanks,
..... john
       

*

Offline reyalp

  • ******
  • 11514
Re: CHDK and SX100is
« Reply #3 on: 10 / October / 2018, 13:28:03 »
Hi reyalp,
         Would this be the latest version for GM1.00C?
sx100is-100c-1.4.1-5097-full.zip
Thanks,
..... john
That's the latest 1.4 release build. You can use that if you want.

I suggested the trunk (1.5 development version) http://mighty-hoernsche.de/trunk/ but it doesn't really matter. There shouldn't be any camera specific differences between 1.4 and 1.5 for this port, the only reason I suggested it is that if there's something to fix, I'd probably work on it in 1.5 first.
Don't forget what the H stands for.


Re: CHDK and SX100is
« Reply #4 on: 10 / October / 2018, 19:43:23 »
Hi reyalp,
         I didn't know what the "latest trunk (development) autobuild" was or where to find it, so I just fumbled around until I found a build download page. But now that I know where to find the 1.5 build, I'll use it.
Thanks again,
..... john

Re: CHDK and SX100is
« Reply #5 on: 13 / October / 2018, 14:30:18 »
Hi,
     I installed version 1.5 successfully. I've noticed that the camera now starts in the replay mode. This is not a big problem; because a light touch on the shutter button will extend the lens and get me into shooting mode. Have I missed a setting, or is this just how this camera starts with CHDK?
Thanks,
..... john

*

Offline srsa_4c

  • ******
  • 3695
Re: CHDK and SX100is
« Reply #6 on: 13 / October / 2018, 14:45:15 »
I've noticed that the camera now starts in the replay mode. This is not a big problem; because a light touch on the shutter button will extend the lens and get me into shooting mode. Have I missed a setting, or is this just how this camera starts with CHDK?
Yes, the behaviour is normal for most cameras. If you hold down the ON/OFF button for a bit longer, the camera will start in shooting mode.

Re: CHDK and SX100is
« Reply #7 on: 13 / October / 2018, 15:48:37 »
Hi srsa_4c,
      That works like charm.
Thanks,
... john
P.S. I never had this problem with my A590


*

Offline reyalp

  • ******
  • 11514
Re: CHDK and SX100is
« Reply #8 on: 13 / October / 2018, 20:51:53 »
P.S. I never had this problem with my A590
A590 has a play/rec switch separate from power button. Most later PowerShots have separate buttons that can both power on the camera, like the SX100. On these cameras, CHDK doesn't know which button you started the camera with unless you hold it down a bit longer, so it defaults to starting in playback mode to avoid extending the lens unexpectedly.
Don't forget what the H stands for.

Re: CHDK and SX100is
« Reply #9 on: 15 / October / 2018, 11:36:37 »
Thanks for the explanation reyalp.
.... john

 

Related Topics