SX430 - This will be my first porting Attempt - page 12 - DryOS Development - CHDK Forum
supplierdeeply

SX430 - This will be my first porting Attempt

  • 166 Replies
  • 177296 Views
Re: SX430 - This will be my first porting Attempt
« Reply #110 on: 20 / November / 2018, 20:37:25 »
Advertisements
If DNG looks bad or corrupted probably you have the wrong sensor dimensions in platform_camera.h  The dimensions are different than the maximum image size. 

Re: SX430 - This will be my first porting Attempt
« Reply #111 on: 21 / November / 2018, 01:06:11 »
It looks like the wrong CFA pattern
I played a bit with the DNG (extracted the raw data using chdkptp and used DNG4PS2), and I think the CFA is okay. I'd change CAM_COLORMATRIX1. I used the matrix values from ixus175 and the resulting image is much better (but still doesn't match the JPG colors).

If the raw hook is sorted, I'd recommend checking for shooting modes where a valid raw can't be obtained or where enabling DNG causes DNG or JPG corruption.

yes i changed the CFA to the two supplied by Blackhole and yes the problem persists its still green

i copied the COLORMATRIX1 from IXUS 175 and all the colours seem to be present i am not sure about how much they should match with the JPG but i used DCRAW with the -a switch and blue and red are present and it is pretty close to the jpg other than the smoothing optimization etc

Re: SX430 - This will be my first porting Attempt
« Reply #112 on: 21 / November / 2018, 01:08:01 »
here is the platform_camera.h

Re: SX430 - This will be my first porting Attempt
« Reply #113 on: 21 / November / 2018, 01:23:13 »
The same DNG4PS2 profile works for this DNG too, so I guess you could change CAM_COLORMATRIX1 in the sx420 source.

Please remove the sx420 dng gdrive link as I'm not sure if that was intended to be shared publicly.

I think you have at least two ports that are not in svn - if they don't do harm (they are tested at least partially and work more or less) it would be a good idea to submit them for inclusion, with appropriate notes.
I will replace CAM_COLORMATRIX1 for the SX420 with that of ixus175 and post the final test build. Judging by the reports for the sx420, the port works well, apart from problems with dng that should be solved with this.
Tomorrow I'll make a patch for both cameras, sx420 and sx430, for adding to the svn.
For sx620 I'm waiting for some of the testers familiar with chdkptp, I think it's the best because in the keymap missing many keys.

i can test the IXUS285 though if you want ( :) )


*

Offline blackhole

  • *****
  • 677
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #114 on: 21 / November / 2018, 02:44:34 »
If DNG looks bad or corrupted probably you have the wrong sensor dimensions in platform_camera.h  The dimensions are different than the maximum image size.
To me, it looks okay, considering stubs_entry.s and specifications of the camera. The active area is currently the entire sensor.

*

Offline blackhole

  • *****
  • 677
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #115 on: 21 / November / 2018, 02:58:18 »
i can test the IXUS285 though if you want ( :) )
I have that in mind!

Can you briefly describe what you have been testing so far (main overrides TV AV ISO , Zebra , PTP extension , scripts..).
I need it for notes.txt

Re: SX430 - Following Things Tested
« Reply #116 on: 21 / November / 2018, 06:37:50 »
i can test the IXUS285 though if you want ( :) )
I have that in mind!

Can you briefly describe what you have been testing so far (main overrides TV AV ISO , Zebra , PTP extension , scripts..).
I need it for notes.txt

i have tested all the overrides using PTP extension as it is easier and the effects are immediately visible. if the scripts need seperate testing .... pls name a few which should be tested and i will gladly test those too

from the begining
booted using the Bootable Card made using Cardtricks144 and EOSCard (i have used 4GB cards)
the CHDK menu works ok, A few settings i tried worked ok (eg startup screen )
CHDK OSD - OK
RAW DNG - OK

PTP - OK
the following things tested
Live View - OK
Overlay - OK (1:1 etc all ok)

Buttons
UP, Down, Left, Right - OK
Set, Menu - OK
Zoom +, Zoom - OK
Shoot Half, Shoot, Video - OK
Rec, Play - Ok

Shooting Modes
seems ok
however Fisheye and Miniature seem reversed from CHDK PTP if i set FishEye i get Miniature and Vice Versa


setting
Miniature gives FishEye
FishEye gives Miniature
Face_Self_Timer gives Poster
Poster_Effect gives SuperVivid
SuperVivid gives Face_Self_Timer

FireWork - OK
LIVE - OK
Long Shutter - OK
LowLight - OK
MonoChrome - OK
Portriait - OK
ToyCamera - OK
AUTO - OK
P - OK

On the USER tab
JPG Remote Shoot - ERROR : unsupported format
DNG Remote Shoot - OK

Files
OK

Setting AV and TV and SV using

for eg
"set_tv96(" & mTVval & ") sleep(100) set_user_tv96(" & mTVval & ") press 'shoot_half'"

and putting a value works - it changes the properties of the picture ... i do not have much experience to know if the values are as desired
though they look ok and approximately consistent with older cameras

setting Focus lock using set_aflock(1) works ok
setting Manual Focus using set_focus works ok (when focus lock is enabled )

I do not know how Exposure Lock works but putting camera in Video mode and sending set_aelock(1) locks the exposure for the Preview

that is all i tested.... if something in particular needs testing ... pls let me know

*

Offline blackhole

  • *****
  • 677
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #117 on: 21 / November / 2018, 06:41:41 »
Thank you, that's all I need.


Re: SX430 - This will be my first porting Attempt
« Reply #118 on: 21 / November / 2018, 06:53:38 »
Thank you, that's all I need.

since you mentioned it

Zebra - shows the overlay ... though i have never used zebra previously so i do not know if it behaves properly ( i will try a more thorough test later )
it seems the Zebra does not turn off EDIT - after turning it off in the CHDK menu /EDIT even turning the camera off and then on ... the zebra persists

Histogram appears
Edge Overlay - seems ok

have not tested any script - have rarely used script - any suggestion which i should use (which would test it thoroughly )
(on a side note - can a script be made to test features and make a log  :) )

*

Offline blackhole

  • *****
  • 677
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #119 on: 21 / November / 2018, 07:23:50 »
Hmm, zebra should be disabled with unchecked "Draw Zebra []"
Go to:
Miscellaneous stuff -> File browser -> CHDK and delete the CCHDK4.CFG file (select the file, press LEFT and select Delete from the menu)

 

Related Topics