SX430 - This will be my first porting Attempt - page 19 - DryOS Development - CHDK Forum

SX430 - This will be my first porting Attempt

  • 202 Replies
  • 230932 Views
Re: SX430 - This will be my first porting Attempt
« Reply #180 on: 24 / August / 2021, 06:54:20 »
Advertisements
I had turn off the servo for the initial tests and had turned it and then then continous Af on thinking one or the other would have some effect
 .. but not to worry .. .i will go thru the proper procedure and will presently post a new log file ... give me a few hrs  :)

also i will post log files as attachment ... then.

Support of the powershot 430 is?
« Reply #181 on: 30 / July / 2023, 18:48:29 »
I have bought a powershot sx 430 and it seems to not be officially supported. I did a brief search and found a old thread of someone trying to get a build working, but it doesn't seem to be active anymore since the last message was two years ago. https://chdk.setepontos.com/index.php?topic=13569.180

Just making a topic to see if anyone is willing to continue making a build. I might be able to help in a day when I get back home as I'm still on vacation. One note is that I am very new to the modding scene of cameras

I have attached a picture of the camera from ebay until I get back home tomorrow from my vacation. I actually still haven't seen the camera in person since I've bought the camera right before I left for vacation

Edit: accidentally posted this topic instead of attaching a picture of the camera on ebay
« Last Edit: 30 / July / 2023, 19:05:39 by DashingRiggs »

*

Offline reyalp

  • ******
  • 14098
Re: SX430 - This will be my first porting Attempt
« Reply #182 on: 31 / July / 2023, 00:29:22 »
Hi @DashingRiggs, I merged your post into the porting thread.

I've attached a build of the current source for sx430 firmware 100b. I'm not sure exactly what the status of this port is, but from the last few posts in this thread it seems like it should be mostly complete.
Don't forget what the H stands for.

*

Offline blackhole

  • *****
  • 942
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #183 on: 31 / July / 2023, 02:38:01 »
Hi @DashingRiggs, I merged your post into the porting thread.

I've attached a build of the current source for sx430 firmware 100b. I'm not sure exactly what the status of this port is, but from the last few posts in this thread it seems like it should be mostly complete.
The port is mostly finished, ptp remote and video features are not implemented because there was no interest in testing from any user.
The reason why the port was not added to the autobuild server is that we are waiting for a report for correct power on behavior, the test build is in this post: https://chdk.setepontos.com/index.php?topic=13569.msg143258#msg143258 , but neither after three years and 41 downloads still no answer.


*

Offline reyalp

  • ******
  • 14098
Re: SX430 - This will be my first porting Attempt
« Reply #184 on: 31 / July / 2023, 11:23:10 »
The reason why the port was not added to the autobuild server is that we are waiting for a report for correct power on behavior, the test build is in this post: https://chdk.setepontos.com/index.php?topic=13569.msg143258#msg143258 , but neither after three years and 41 downloads still no answer.
May be missing something, but it looks to me like that was confirmed by nstatic https://chdk.setepontos.com/index.php?topic=13569.msg146881#msg146881

Related changes were committed by philmoz in trunk r6010 https://chdk.setepontos.com/index.php?topic=650.msg146882#msg146882

Looks like there was some unresolved discussion of SD override after that
Don't forget what the H stands for.

*

Offline blackhole

  • *****
  • 942
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #185 on: 31 / July / 2023, 13:49:51 »
May be missing something, but it looks to me like that was confirmed by nstatic https://chdk.setepontos.com/index.php?topic=13569.msg146881#msg146881

Related changes were committed by philmoz in trunk r6010 https://chdk.setepontos.com/index.php?topic=650.msg146882#msg146882
Oops !
Quote
Looks like there was some unresolved discussion of SD override after that
It seems like camera allows SD override only when AFL is set.
https://chdk.setepontos.com/index.php?topic=13569.msg146901#msg146901

Re: SX430 - This will be my first porting Attempt
« Reply #186 on: 31 / July / 2023, 17:54:31 »
Hi @DashingRiggs, I merged your post into the porting thread.

I've attached a build of the current source for sx430 firmware 100b. I'm not sure exactly what the status of this port is, but from the last few posts in this thread it seems like it should be mostly complete.
The port is mostly finished, ptp remote and video features are not implemented because there was no interest in testing from any user.
The reason why the port was not added to the autobuild server is that we are waiting for a report for correct power on behavior, the test build is in this post: https://chdk.setepontos.com/index.php?topic=13569.msg143258#msg143258 , but neither after three years and 41 downloads still no answer.


I am at my house and the camera seems to be ready for modding. I'll do a bit of research on how to get this setup and I'll report to see what wrong happens!

Re: SX430 - This will be my first porting Attempt
« Reply #187 on: 20 / August / 2023, 17:46:04 »
Hi @DashingRiggs, I merged your post into the porting thread.

I've attached a build of the current source for sx430 firmware 100b. I'm not sure exactly what the status of this port is, but from the last few posts in this thread it seems like it should be mostly complete.
The port is mostly finished, ptp remote and video features are not implemented because there was no interest in testing from any user.
The reason why the port was not added to the autobuild server is that we are waiting for a report for correct power on behavior, the test build is in this post: https://chdk.setepontos.com/index.php?topic=13569.msg143258#msg143258 , but neither after three years and 41 downloads still no answer.


I am at my house and the camera seems to be ready for modding. I'll do a bit of research on how to get this setup and I'll report to see what wrong happens!


I have finally found time to mod the camera and I'm doing my research now. Now I'm just having a little bit of trouble finding how to load chdk onto the camera. My current root directory looks like this but I don't know any specific directions to load the exploit yet. I'll look at the history of this thread for now.
« Last Edit: 20 / August / 2023, 17:49:45 by DashingRiggs »


Re: SX430 - This will be my first porting Attempt
« Reply #188 on: 20 / August / 2023, 19:01:27 »
Hi @DashingRiggs, I merged your post into the porting thread.

I've attached a build of the current source for sx430 firmware 100b. I'm not sure exactly what the status of this port is, but from the last few posts in this thread it seems like it should be mostly complete.
The port is mostly finished, ptp remote and video features are not implemented because there was no interest in testing from any user.
The reason why the port was not added to the autobuild server is that we are waiting for a report for correct power on behavior, the test build is in this post: https://chdk.setepontos.com/index.php?topic=13569.msg143258#msg143258 , but neither after three years and 41 downloads still no answer.


I am at my house and the camera seems to be ready for modding. I'll do a bit of research on how to get this setup and I'll report to see what wrong happens!


I have finally found time to mod the camera and I'm doing my research now. Now I'm just having a little bit of trouble finding how to load chdk onto the camera. My current root directory looks like this but I don't know any specific directions to load the exploit yet. I'll look at the history of this thread for now.

I have now gotten this to work! I think I can start testing what hasn't been already. To add, I fixed it by re doing everything.

Re: SX430 - This will be my first porting Attempt
« Reply #189 on: 03 / October / 2023, 23:18:23 »
Do we have a test build with ps.fi2 for the latest 1.7 build, I want to test it but can't load it using the firmware update method

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal