SX430 - This will be my first porting Attempt - page 21 - DryOS Development - CHDK Forum

SX430 - This will be my first porting Attempt

  • 202 Replies
  • 228654 Views
*

Offline reyalp

  • ******
  • 14086
Re: SX430 - This will be my first porting Attempt
« Reply #200 on: 20 / October / 2023, 22:16:41 »
Advertisements
I've gotten it. Before, I didn't know it reset if the camera's AF to on if it is restarted/crashed and that you had to re-disable the options..
Thanks. That appears to confirm SD override works in MF and AFL. And yeah, if it crashes, settings you changed before the crash are generally forgotten, I've added a note to the testing page, this probably explains why the report from 2021 had the same issue  :haha

Quote
Also I can confirm that the PTP software works pretty almost perfectly. I think if the camera disconnects while the software is open, it freezes the PTP software and I can't even shut it down with task manager,ProcessKO, or alt+f4
Can you provide more details? What OS, libusb driver, chdkptp version? What's causing the camera to disconnect (power off, crash, something else?)

On my windows 10 system, running the current svn chdkptp or r964, if I unplug or turn off the camera while the GUI is running, there's an IO error in the console and it disconnects gracefully.

edit:
I've enabled sx430 100b in the trunk autobuilds, it should appear shortly in build 6258. There's no significant difference from the most recent build posted in this thread.
« Last Edit: 20 / October / 2023, 22:20:44 by reyalp »
Don't forget what the H stands for.

Re: SX430 - This will be my first porting Attempt
« Reply #201 on: 22 / October / 2023, 12:04:42 »

Can you provide more details? What OS, libusb driver, chdkptp version? What's causing the camera to disconnect (power off, crash, something else?)


I am using the newest version of libusb and chdkptp using the forum guide that you linked. The screenshot given is my OS build on windows 10 64 bit. I'm pretty sure what's causing my camera to disconnect is my low quality cable. I can't exactly remember, but I think there's a chance chdkptp will just freeze and never respond and I can't even close it with task manager or as it just doesn't do anything.

*

Offline reyalp

  • ******
  • 14086
Re: SX430 - This will be my first porting Attempt
« Reply #202 on: 29 / October / 2023, 21:54:08 »
I am using the newest version of libusb and chdkptp using the forum guide that you linked. The screenshot given is my OS build on windows 10 64 bit. I'm pretty sure what's causing my camera to disconnect is my low quality cable. I can't exactly remember, but I think there's a chance chdkptp will just freeze and never respond and I can't even close it with task manager or as it just doesn't do anything.
Hmm, haven't seen that, but I guess it wouldn't be too much of surprise if flaky hardware caused weird behavior.

If your remember (or if it happens again), what does the camera do in that situation? Does it shut down or freeze, or just work like the cable was unplugged?
Don't forget what the H stands for.

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal