SX430 - This will be my first porting Attempt - page 7 - DryOS Development - CHDK Forum

SX430 - This will be my first porting Attempt

  • 166 Replies
  • 176731 Views
Re: SX430 - This will be my first porting Attempt
« Reply #60 on: 10 / November / 2018, 11:28:48 »
Advertisements
On a side note(although it may just be the begining of the port for SX430):

I observed Magic being performed ... and i was as fascinated with the results.... being the Sorcerer's Assistant ( not apprentice yet ) as i was previously being a distant observer.

 :)

so i am going to go thru the changes you made... just to understand a little bit ... about the spells you used  :) so that i may some day call myself an apprentice
Thanks for the magic

Re: SX430 - This will be my first porting Attempt
« Reply #61 on: 10 / November / 2018, 12:28:05 »
there seems to be a problem with RAW

the image gets corrupted ... even the jpg along with raw gets corrupted
i have uploaded the images to the google drive here
(if there is a better alternative to google drive or if this board has a preference pls let me know)

the individual image taken without the RAW on is ok
ive uploaded the jpg the CRW the Tiff converted with DCRAW and the JPG created from that tiff for easy review

there seems to be a small problem with the CHDK menu.... the camer screen refresh manages to overwrite the menu althouth the menu eventually redraws there is a flicker every time the original canon screen refreshes

Re: SX430 - This will be my first porting Attempt
« Reply #62 on: 10 / November / 2018, 12:36:59 »
connection on ptp gives

ERROR: :80: module 'capmode' not found:
    no field package.preload['capmode']
    no file 'A/CHDK/SCRIPTS/capmode.lua'
    no file 'A/CHDK/LUALIB/capmode.lua'
user code: 1
i think that is because it is not the full compile ?

Re: SX430 - This will be my first porting Attempt
« Reply #63 on: 10 / November / 2018, 12:50:14 »
copied the lualib and scripts folder from the older build and it connects

live preview is ok
UI overlay is ok

the modes combo does not get filled when switching to Rec mode

Video button works ok

shoot however does not shoot there is a tick tick sound by the camera ... but the shutter doesnt release
is this due to the mode combo not available ?


Re: SX430 - This will be my first porting Attempt
« Reply #64 on: 10 / November / 2018, 12:57:05 »
JPG remote shoot says

ERROR: unsupported format

DNG Remote Shoot
attempts to shoot and behaves like half press same as shoot ... but does not shoot (same as shoot)

*

Offline blackhole

  • *****
  • 663
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #65 on: 10 / November / 2018, 15:04:18 »
there seems to be a problem with RAW

the image gets corrupted ... even the jpg along with raw gets corrupted
i have uploaded the images to the google drive here
(if there is a better alternative to google drive or if this board has a preference pls let me know)

the individual image taken without the RAW on is ok
ive uploaded the jpg the CRW the Tiff converted with DCRAW and the JPG created from that tiff for easy review
Are there any differences if you using the P shooting mode ?
Quote
there seems to be a small problem with the CHDK menu.... the camer screen refresh manages to overwrite the menu althouth the menu eventually redraws there is a flicker every time the original canon screen refreshes
Use the P shooting mode and set the AF frame to (Center) in the Canon menu. This will reduce flicker.

*

Offline blackhole

  • *****
  • 663
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #66 on: 10 / November / 2018, 15:10:34 »
copied the lualib and scripts folder from the older build and it connects

live preview is ok
UI overlay is ok

the modes combo does not get filled when switching to Rec mode

Video button works ok

shoot however does not shoot there is a tick tick sound by the camera ... but the shutter doesnt release
is this due to the mode combo not available ?
I'm not sure. @reyalp  will certainly know more about it.

*

Offline srsa_4c

  • ******
  • 3907
Re: SX430 - This will be my first porting Attempt
« Reply #67 on: 10 / November / 2018, 15:13:44 »
One source of failures is the propset which is newer than the latest known propset. This one could be called propset 11. A newly generated stubs_entry.S identifies a few propcases that can be used as a starting point.
propset 11 (sx430)
Code: [Select]
// Known propcases
// //      PROPCASE_AFSTEP 13
// #define PROPCASE_FOCUS_STATE 18
// #define PROPCASE_AV 23
// #define PROPCASE_BV 40
// //      PROPCASE_DELTA_DIGITALGAIN 85
// #define PROPCASE_DELTA_SV 87
// //      PROPCASE_DELTA_ND 88
// #define PROPCASE_EV_CORRECTION_2 219
// #define PROPCASE_ORIENTATION_SENSOR 231
// #define PROPCASE_SV_MARKET 259
// //      PROPCASE_SVFIX 260
// #define PROPCASE_TV 276
propset 10 (m10):
Code: [Select]
// Known propcases
// //      PROPCASE_AFSTEP 13
// #define PROPCASE_FOCUS_STATE 18
// #define PROPCASE_AV 23
// #define PROPCASE_BV 40
// //      PROPCASE_DELTA_DIGITALGAIN 84
// #define PROPCASE_DELTA_SV 86
// //      PROPCASE_DELTA_ND 87
// #define PROPCASE_EV_CORRECTION_2 218
// #define PROPCASE_ORIENTATION_SENSOR 230
// #define PROPCASE_SV_MARKET 257
// //      PROPCASE_SVFIX 258
// #define PROPCASE_TV 274

edit:
... and here's what I had to do to add a new propset (10): r4754
« Last Edit: 10 / November / 2018, 15:49:03 by srsa_4c »


*

Offline blackhole

  • *****
  • 663
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #68 on: 12 / November / 2018, 04:44:21 »
@ntstatic
Are you ready for this?
This can only be done with the camera in hand, without this chdk cannot work properly.
The file that will be edited is attached.

Go to:
Miscellaneous Stuff -> Debug Parameters
set "Debug data display" to [Props] and "Propcase / Param data page" to [5]

Exit <ALT> mode and change the shooting modes.
The numbers on the left are propcases, on the right are possible settings.
Each time you change the shooting mode, you should see another number on the display (e.g. 32773 if your camera is in the P mode). It is necessary to find out which propcase is changing, I assume that this will be somewhere about 50.
For example, if is changed the propcase 58, you need to change #define PROPCASE_SHOOTING_MODE 55 to #define PROPCASE_SHOOTING_MODE 58
If none of these parameters change when you change the shooting modes, set the Propcase / Param data page to [4] or [6] and try again.

A similar procedure should be repeated for all items, but other parameters on the camera should be changed.

All the CUSTOM_XXX ones are things in the "my colors" menu
ISO_MODE is the ISO value you set in the func menu.
The USER_TV and USER_AV are the manual shutter speed and aperture values. They update immediately when you set them. The other TV and AV values update on half press.

SUBJECT_DIST2 / SUBJECT_DIST1
You should be able to check these in MF mode, they should have the same value, and it should change when you adjust the focus distance

DELTA_SV
Put the camera in AUTO ISO and half shoot. SV_MARKET will go to the base value (probably 576 = 200 ISO) and SV_MARKET + SV_DELTA converted to ISO should match the displayed auto ISO value.

DISPLAY_MODE
This should update when you press the disp button in shooting mode (maybe INFO on this cam)

FLASH_FIRE
Should be 1 after half press if the camera would use flash.

FLASH_EXP_COMP
Should show exp comp value in apex96 units

FOCUS_MODE
This should update when you change between Macro, standard AF and MF

OPTICAL_ZOOM_POSITION
should show the current zoom step, 0 at wide

EXPOSURE_LOCK
should go to one if you use the canon AE lock shortcut (half press, click +/- button)

IS_FLASH_READY
should go to one on half press when flash would be used, goes back to 0 on release.

ORIENTATION_SENSOR
Should be 0 in normal orientation, 90 or 270 in portrait orientation.

TIMER_DELAY
should update when you update the time in custom timer mode

WB_ADJ
should change when you change white balance mode

TIMER_SHOTS
should update when you adjust shot count in custom timer

*

Offline reyalp

  • ******
  • 11903
Re: SX430 - This will be my first porting Attempt
« Reply #69 on: 12 / November / 2018, 13:23:57 »
You may (or may not  ;)) find the chdkptp propcase tools useful for verifying the propcase values;

You can load them with
Code: [Select]
!require'extras/devutil'.init_cli()
after that, dpget reads propcases 0-1000. dpcmp gets the values again, compares the values with the last dpget, outputs the changed values.

With this, you can do a dpget, change a setting, and then do a dpcmp to see what changed.  Note that some unrelated values may change every half press (or for other reasons) so you should verify that changes are reproducible if it's not obvious: If you change shutter speed the value of the shutter speed prop should always be the same for a given shutter speed.

For props that need a half press to update, you can include lua code in the dpget command like
Code: [Select]
dpcmp -c='press "shoot_half" sleep(500)'

Changes between propsets tend be values being added and removed. E.g. if PROPCASE_TV is 123 in one propset, and 124 in another, then all the subsequent IDs will likely by +1 until the next change. If you guess a value that you can't verify please note it in the file.

Note that the meanings of values may also change, e.g. the PROPCASE_RESOLUTION value for M1 jpeg size might be 3 in one propset and 2 in another.

Most of the exposure props are in APEX*96 units, so it can be helpful to refer to APEX http://dougkerr.net/Pumpkin/#APEX to verify that you have the right value. E.g. if you are looking at a shutter speed value, 1/2 second should be 96.
Don't forget what the H stands for.

 

Related Topics