SX430 - This will be my first porting Attempt - page 10 - DryOS Development - CHDK Forum

SX430 - This will be my first porting Attempt

  • 166 Replies
  • 176402 Views
Re: SX430 - This will be my first porting Attempt
« Reply #90 on: 14 / November / 2018, 08:45:09 »
Advertisements
ok further to that i have tried using PTP

setting Exposure : ok
setting Aperture : ok
setting ISO : ok
setting Focus Lock : ok
setting focus manually ... .after Focus Lock : ok

all above verified by changes in captured Pictures


anything else need testing ?

Re: SX430 - This will be my first porting Attempt
« Reply #91 on: 14 / November / 2018, 09:09:28 »
Capturing RAW from the camera - not using CHDK PTP

The Raw file is corrupt

tried in Program mode


*

Offline blackhole

  • *****
  • 663
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #93 on: 14 / November / 2018, 12:00:02 »
thank you .... i tried compiling with propcase11.h and it compiled ok CHDK PTP however would not connect as it said propcase11 was unrecognized
so temporarily i renamed the propcase11 to propcase10 and compiled

everything seems ok ... though not thoroughly checked yet

CHDK PTP works ok (it will need to recognize propset11 though)
preview ok,
overlay ok,
zoom ok,
Shooting Mode ok,
Buttons work ok

shooting ok
DNG Remote Shoot ok

the dng file generated seems ok (corruption seems to be gone have not properly developed DCRaw gave a pinkish but non corrupted TIF)

JPG Remote Shoot still gives  ERROR: unsupported format
See here what you need to do when you add a new propset:
https://app.assembla.com/spaces/chdk/subversion/commits/4754
Do not forget the propset is defined in the platform / sx430is / platform_camera.h You have to change #define CAM_PROPSET 10 to #define CAM_PROPSET 11


Re: SX430 - This will be my first porting Attempt
« Reply #94 on: 14 / November / 2018, 13:16:05 »
thank you .... i tried compiling with propcase11.h and it compiled ok CHDK PTP however would not connect as it said propcase11 was unrecognized
so temporarily i renamed the propcase11 to propcase10 and compiled

everything seems ok ... though not thoroughly checked yet

CHDK PTP works ok (it will need to recognize propset11 though)
preview ok,
overlay ok,
zoom ok,
Shooting Mode ok,
Buttons work ok

shooting ok
DNG Remote Shoot ok

the dng file generated seems ok (corruption seems to be gone have not properly developed DCRaw gave a pinkish but non corrupted TIF)

JPG Remote Shoot still gives  ERROR: unsupported format
See here what you need to do when you add a new propset:
https://app.assembla.com/spaces/chdk/subversion/commits/4754
Do not forget the propset is defined in the platform / sx430is / platform_camera.h You have to change #define CAM_PROPSET 10 to #define CAM_PROPSET 11

i will check that link
but i had done the changes and put the definition and everything compiled ok .... the problem is that CHDK PTP does not recognise propset11 and gives an error and stops. so just to convince CHDK PTP that it was propset 10 .... i temporarily changes propset11h to propset10.h  :)

i will change everything back to regular and add
#if CAM_PROPSET == 11
    #include "propset11.h"   // SX430 -
in properties.h and post the last source here in a little while

Re: SX430 - This will be my first porting Attempt
« Reply #95 on: 14 / November / 2018, 14:13:03 »
ok made the changes for the inclusion of propcase11
here are the source and binaries

Edit: checked with CHDK PTP and works ok
will do a thorough check later (tomorrow :) )
« Last Edit: 14 / November / 2018, 14:14:35 by ntstatic »

*

Offline srsa_4c

  • ******
  • 3902
Re: SX430 - This will be my first porting Attempt
« Reply #96 on: 17 / November / 2018, 07:14:59 »
@ntstatic

Please check if the camera still boots with compatibility check enabled.
Uncomment
BL check_compat
in loader/sx430is/entry.S then recompile.

edit:
Based on the camera manuals, Canon has removed AE/AF/FE lock from SX4xx and SX6xx series cameras, starting with SX420 and SX610. So, one can't really upgrade from earlier equivalents anymore because the followup model is more crippled than the older...
« Last Edit: 17 / November / 2018, 07:25:45 by srsa_4c »

Re: SX430 - This will be my first porting Attempt
« Reply #97 on: 17 / November / 2018, 11:34:01 »
@ntstatic

Please check if the camera still boots with compatibility check enabled.
Uncomment
BL check_compat
in loader/sx430is/entry.S then recompile.

edit:
Based on the camera manuals, Canon has removed AE/AF/FE lock from SX4xx and SX6xx series cameras, starting with SX420 and SX610. So, one can't really upgrade from earlier equivalents anymore because the followup model is more crippled than the older...

will be able to check on monday


Re: SX430 - This will be my first porting Attempt
« Reply #98 on: 17 / November / 2018, 11:39:32 »
however just for the info ... i was able to achieve AF lock using CHDK PTP extension ... this was necessary for manual focus.... and in the brief test i was able to do, the manual focus worked perfectly

AE lock apparently worked in the Video mode.... i had not created a script and only gave command individually and so the AE lock is lost as soon as the camera receives the next command to Capture the video (however i was not able to test if this works or not ) i just observed that the preview was locked when AE lock was requested

i have never used a FE lock and hence cannot comment... however will try to look it up and check if possible

Re: SX430 - This will be my first porting Attempt
« Reply #99 on: 19 / November / 2018, 08:54:21 »
@ntstatic

Please check if the camera still boots with compatibility check enabled.
Uncomment
BL check_compat
in loader/sx430is/entry.S then recompile.

edit:
Based on the camera manuals, Canon has removed AE/AF/FE lock from SX4xx and SX6xx series cameras, starting with SX420 and SX610. So, one can't really upgrade from earlier equivalents anymore because the followup model is more crippled than the older...

I am on Windows and am using the CHDK Compiler GUI
so i unchecked the Disable_Compat_Check and everything seems to work as before

CHDK loads
PTP works
AF lock works
Manual Focus works
AE seems to work ok (on preview at least - not checked for video)

in all it behaves properly


 

Related Topics