SX430 - This will be my first porting Attempt - page 15 - DryOS Development - CHDK Forum

SX430 - This will be my first porting Attempt

  • 146 Replies
  • 174291 Views
*

Offline blackhole

  • *****
  • 652
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #140 on: 12 / March / 2019, 14:15:44 »
Advertisements

everything seems to be working with some bugs like...
Alt> menu keeps on disappearing while selecting options, enabling some options causing display to go black or red sometimes(don't know which option is causing this), MOST IMPO.  this cam don't have DISP. button, so the MANUAL FOCUS can't be turned on, pano mode isn't working ( display goes red or cam went hung when enabling edge overlay)
..
intrervalometer is working fi9,
Enable SD override in chdk menu and in ALT mode use zoom lever to adjusting focus.
Does the Zebra work well ?
Always use the camera in P mode, AUTO mode is very problematic.
« Last Edit: 12 / March / 2019, 14:18:48 by blackhole »

*

Offline srsa_4c

  • ******
  • 3815
Re: SX430 - This will be my first porting Attempt
« Reply #141 on: 12 / March / 2019, 16:48:30 »
@blackhole
Try enabling the compatibility check in the next test build, since we now know that CHDK works.
To rule out a possible cause of the edge overlay crash, I'd recommend doing this in lib.c:
Code: [Select]
void *vid_get_bitmap_active_buffer()
{
    return bitmap_buffer[active_bitmap_buffer&1];
}

enabling some options causing display to go black or red sometimes(don't know which option is causing this)
Zebra can do that when enabled. Question is, are the colored spots correct, or not.

*

Offline blackhole

  • *****
  • 652
  • A590IS 101b
    • Planetary astrophotography
Re: SX430 - This will be my first porting Attempt
« Reply #142 on: 12 / March / 2019, 18:07:15 »
Try enabling the compatibility check in the next test build, since we now know that CHDK works.
To rule out a possible cause of the edge overlay crash, I'd recommend doing this in lib.c:
Code: [Select]
void *vid_get_bitmap_active_buffer()
{
    return bitmap_buffer[active_bitmap_buffer&1];
}
Thanks !
Compatibility check is now enabled.

@shinchaπ
Can you please try the edge overlay and zebra with this test build.

Re: SX430 - This will be my first porting Attempt
« Reply #143 on: 17 / March / 2019, 05:10:56 »
Try enabling the compatibility check in the next test build, since we now know that CHDK works.
To rule out a possible cause of the edge overlay crash, I'd recommend doing this in lib.c:
Code: [Select]
void *vid_get_bitmap_active_buffer()
{
    return bitmap_buffer[active_bitmap_buffer&1];
}
Thanks !
Compatibility check is now enabled.

@shinchaπ
Can you please try the edge overlay and zebra with this test build.
i can do that✌️, but i m out of my town for a week, i will try it As soon i reach back.


Re: SX430 - This will be my first porting Attempt
« Reply #144 on: 18 / March / 2019, 05:36:53 »
Try enabling the compatibility check in the next test build, since we now know that CHDK works.
To rule out a possible cause of the edge overlay crash, I'd recommend doing this in lib.c:
Code: [Select]
void *vid_get_bitmap_active_buffer()
{
    return bitmap_buffer[active_bitmap_buffer&1];
}
Thanks !
Compatibility check is now enabled.

@shinchaπ
Can you please try the edge overlay and zebra with this test build.

zebra and edge overlay works ok thanks

however the camera does not execute the shutdown() or the reboot from LUA properly it feels like it crashes .. the lens does not retract the camera just stops responding power off and power on makes it just fine.

however i have one camera kept with power permanently pressed connected to a pc ...changes to white balance for eg become difficult (impossible other than physically turning it off) to save ... because the camera does not shut down

*

Offline srsa_4c

  • ******
  • 3815
Re: SX430 - This will be my first porting Attempt
« Reply #145 on: 19 / March / 2019, 12:27:02 »
however the camera does not execute the shutdown() or the reboot from LUA properly it feels like it crashes .. the lens does not retract the camera just stops responding power off and power on makes it just fine.
Do you have any CHDK supported cameras that behave differently when executing those commands?

Quote
however i have one camera kept with power permanently pressed connected to a pc ...changes to white balance for eg become difficult (impossible other than physically turning it off) to save ... because the camera does not shut down
Try
Code: [Select]
post_levent_to_ui("PressOffButton",0)

*

Offline reyalp

  • ******
  • 11746
Re: SX430 - This will be my first porting Attempt
« Reply #146 on: 19 / March / 2019, 13:18:44 »
however i have one camera kept with power permanently pressed connected to a pc ...changes to white balance for eg become difficult (impossible other than physically turning it off) to save ... because the camera does not shut down
FWIW, if you have the power button permanently pressed, using
Code: [Select]
post_levent_to_ui("UnpressPowerButton")
after startup can avoid some changes in firmware behavior related to having the button held: https://chdk.setepontos.com/index.php?topic=13214.0
Don't forget what the H stands for.

 

Related Topics