A problem of dumping firmwave A480. - page 4 - Firmware Dumping - CHDK Forum
supplierdeeply

A problem of dumping firmwave A480.

  • 34 Replies
  • 14238 Views
Re: A problem of dumping firmwave A480.
« Reply #30 on: 29 / December / 2009, 13:47:03 »
Advertisements
EDIT: Do you think it's a good idea to creat a topic at DryOs Development?

Yes, excellent idea, I just did. :P

Quote
So, this is my status for the day. I'm looking at a470 for reference, and I could almost finish boot.c.

Good job! We should somehow coordinate our work, I created a git repository at github so I could mirror everyone's changes there (I've also started looking at the firmware to locate some functions, but haven't committed anything yet).

Maybe you could drop by on IRC?

Quote
However, when I tried to compile a test, it misses some functions, and also, when putting nullsub to this missing functions, it gives lots of errors of linking, like  "undefined reference to `malloc`",  which had his name detected by sigfinder.

I am not yet familiarized with CHDK's build system, my guess is that some .a/.o is missing from the makefile / linker command, or you didn't put the stubs in the right file so the .a/.o doesn't get built in the first place (?), but it's really nothing but a guess.

@fe50: Thanks :)

Re: A problem of dumping firmwave A480.
« Reply #31 on: 29 / December / 2009, 14:11:33 »
I'll put my findings there, then :)

Re: A problem of dumping firmwave A480.
« Reply #32 on: 29 / December / 2009, 15:05:03 »
excellent job there pegahic!  :o  keep up the good work. :xmas

I look forward to running CHDK on my A480 when it is ready.
I am also willing to volunteer some time to this project.
msg me if you need help. but I am a newbie...
A450 -dead / a460 ok / a480 one day.

Re: A problem of dumping firmwave A480.
« Reply #33 on: 06 / January / 2010, 16:03:51 »
I have a 480 too :)
please keep us updated with the progress so we can try to help or otherwise learn something :)


Re: A problem of dumping firmwave A480.
« Reply #34 on: 05 / March / 2010, 12:44:47 »
I had almost no time to do anything - but I think I might get it started a bit.

I am currently setting up environment to try and compile the most simple piece of code and start from there...

I might need help though.

 

Related Topics