disabling PREflash? - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

disabling PREflash?

  • 15 Replies
  • 7376 Views
Re: disabling PREflash?
« Reply #10 on: 10 / August / 2008, 09:35:50 »
Advertisements
a630 and a650is - available in modes: P Tv Av
press shutter halfway and hold, press +/- button, fires preflash, * displays on screen
not available when flash adjust set to manual

that's the same thing (at least according to the manuals) as the fel on the a560 and sd700. unfortunately my 560 doesn't have the amount of control over the flash (out of the box) as your two do. on the plus side, tested again last night for a while, and once exposure is locked on mine, all the optical slaves work perfect

« Last Edit: 10 / August / 2008, 09:40:00 by trintek »

*

Offline dzsemx

  • ****
  • 302
  • [SX40HS][A650][A630]
Re: disabling PREflash?
« Reply #11 on: 10 / August / 2008, 17:43:56 »
yes, i can trigger preflash to lock FE, but slave flashes will fire when doing this :)

Re: disabling PREflash?
« Reply #12 on: 10 / August / 2008, 18:24:48 »
ah okies, yeah forgot about that bit :P unfortunately (so far) that is the only way to do it on mine. i really need to just start saving for some good kit, this cam is working great for just about everything though, so no rush ;)

*

Offline whoever

  • ****
  • 280
  • IXUS950
Re: disabling PREflash?
« Reply #13 on: 11 / August / 2008, 17:29:16 »
It actually turned out to be ridiculously easy, at least in my cam. Setting PropCase #121 to 1 achieves "manual" flash control. No pre-flash, that is. PropCase #141 then controls the flash power (0,1,2, from min to full).

The corresponding DigicII-style propcases, known since long, are 15 and 29.


Re: disabling PREflash?
« Reply #14 on: 11 / August / 2008, 19:05:59 »
i'll give this a try on the 560 and report back, just got in my next set of gels for the slaves, so.. :)

Re: disabling PREflash?
« Reply #15 on: 11 / August / 2008, 20:21:32 »
that worked perfect, thanks much :) here's the new script for anyone that needs it:

Code: [Select]
@title Manual Flash (no metering)
@param a Manual Flash (0=off/1=on)
@default a 0
@param b Brightness (0=min/2=max)
@default b 1
if a>1 then let a=1
if b>2 then let b=2
set_prop 121 a
set_prop 141 b
end

tested and working on a560 with 0 issues

 

Related Topics