Multi-camera setup project. - page 47 - Creative Uses of CHDK - CHDK Forum supplierdeeply

Multi-camera setup project.

  • 462 Replies
  • 100776 Views
*

Offline bismo

  • *
  • 10
Re: Multi-camera setup project.
« Reply #460 on: 07 / March / 2019, 12:13:54 »
Advertisements
How do you load the bcamHost.lua?
I don't understand how to run it on the PC, I've successfully run the bcamRem.lua on the camera by loading it via card reader to the card and run it with "Load Script from File..."
It's been a while since i was playing with lua scripts in chdkptp.So i dont quite remember :) But have a look at this link.Start cli mode of chdkptp and my bet is on this :
Code: [Select]
exec (!)     <lua code>  : - execute local lua
To integrate the script in GUI , its a bit more complicated if i remember well...


Sorry this reply took so long, I was caught up in something.
Anyway the script works, turns out I've downloaded the wrong chdkptp, what I had was an entirely different program, oops.

I've successfully connect the scripts to the camera but for some reason I cannot use the remote?

I've checked the "use remote sync?" option on the script setting but still cant, and everytime after I run the bcamRem, my remote parameters setting resetted (previously I've checked it and use the one shot)

but when I load the default.lua I can use the remote no problem

can you help point me in the right direction?

Thanks!

*

Offline mphx

  • ***
  • 210
Re: Multi-camera setup project.
« Reply #461 on: 07 / March / 2019, 12:19:55 »

Sorry this reply took so long, I was caught up in something.
Anyway the script works, turns out I've downloaded the wrong chdkptp, what I had was an entirely different program, oops.

I've successfully connect the scripts to the camera but for some reason I cannot use the remote?

I've checked the "use remote sync?" option on the script setting but still cant, and everytime after I run the bcamRem, my remote parameters setting resetted (previously I've checked it and use the one shot)

but when I load the default.lua I can use the remote no problem

can you help point me in the right direction?

Thanks!
As i said , its been a while since i was playing with these things.I use chdkptp (gui) for specific actions and i haven't update/change anything in chdptp for months if not years.So i don't remember much about stuff :) Reyalp or anyone else watching this thread might have better answers than me.
What are you trying to do and in what way?

Re: Multi-camera setup project.
« Reply #462 on: 07 / March / 2019, 12:34:35 »
I've successfully connect the scripts to the camera but for some reason I cannot use the remote?
Are you trying to use a USB remote like the one describe here?  If so, how do you have that wired to your USB connection to your PC?

Using both PTP and a wire remote is tricky.  That's why we added the usb_force_active( ) function.

Quote
I've checked the "use remote sync?" option on the script setting
That option is only needed when you are trying to get two or more cameras to shoot at almost exactly the same time.

Quote
and everytime after I run the bcamRem, my remote parameters setting resetted (previously I've checked it and use the one shot)
Is that the script I posted almost five years ago? If so, I'll have to drag it out of my svn archive and try to figure out what I was doing way back then.  IIRC, it sets up the remote parameter configuration - overriding the current settings and does not politely reset them when it is done.  Sorry.


Edit :  thread continues here : Re: Building a mult-camera rig
« Last Edit: 09 / March / 2019, 11:01:04 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics