SX40HS bricked - General Help and Assistance on using CHDK stable releases - CHDK Forum
supplierdeeply

SX40HS bricked

  • 6 Replies
  • 207 Views
*

Offline mb2

  • *
  • 4
SX40HS bricked
« on: 23 / June / 2019, 14:03:36 »
Advertisements
Hello!

I try install CHDK for my old SX40 camera.
I follow instructions on https://chdk.fandom.com/wiki/Prepare_your_SD_card
page, "Method 2 - Using CHDK itself to make the SD card bootable".
All operations ok to 11. points , but in 12. points after i switched SD card to
locked position, camera not powered on any more.

I checked accumulator, try power on with and without sd card locked state,
and with remowed SD card. Camera totally dead.

Please help me, possible recover this camera?

   Thanks:   mb2


*

Offline mb2

  • *
  • 4
Re: SX40HS bricked
« Reply #1 on: 23 / June / 2019, 14:25:51 »
Oh dont panic, problem solved!
I plugged camera to computer via usb cable, camera powered on, and started CHDK
without problem!

   mb2

*

Offline srsa_4c

  • ******
  • 3981
Re: SX40HS bricked
« Reply #2 on: 23 / June / 2019, 14:46:24 »
Glad to see the camera isn't dead.

There is a small switch somewhere around the battery door. If that switch fails to detect that the door is closed, the camera won't start. So, in case you ever find your camera seemingly dead, that switch would be the first suspect.

*

Online reyalp

  • ******
  • 12077
Re: SX40HS bricked
« Reply #3 on: 23 / June / 2019, 14:55:01 »
Oh dont panic, problem solved!
I plugged camera to computer via usb cable, camera powered on, and started CHDK
without problem!
Glad to hear you got this sorted, but it's pretty strange. Removing the card should really should eliminate any possible impact from CHDK. The camera should boot without a card as long as the door is closed.

This might indicate some kind of hardware issue. Since it happened after switching lock, it could maybe be something like the switch that detects the battery door not engaging as srsa_4c suggests, or maybe something in the battery contacts.

Some models like SX10 seem to have a pattern of the SD lock detect switch failing, but this generally just causes the camera to see all cards as unlocked.
Don't forget what the H stands for.


*

Offline mb2

  • *
  • 4
Re: SX40HS bricked
« Reply #4 on: 23 / June / 2019, 14:56:33 »
Glad to see the camera isn't dead.

There is a small switch somewhere around the battery door. If that switch fails to detect that the door is closed, the camera won't start. So, in case you ever find your camera seemingly dead, that switch would be the first suspect.

Thanks for reply!

Some time ago broken my camera battery door switch,
desoldered and disabled this function.

   mb2

Re: SX40HS bricked
« Reply #5 on: 23 / June / 2019, 15:28:04 »
Did you remove and re-install the battery during your debugging?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline mb2

  • *
  • 4
Re: SX40HS bricked
« Reply #6 on: 23 / June / 2019, 15:42:47 »
Did you remove and re-install the battery during your debugging?
Yes, i removed some time, charging, and no plug in to the camera while searching solution on internet.
And found this post in forum, and try plug camera to computer via usb cable, and camera powered on with on/off button!

   mb2
« Last Edit: 23 / June / 2019, 15:44:43 by mb2 »

 

Related Topics