Testing some - perhaps many - cams with CHDKPTP - page 12 - General Discussion and Assistance - CHDK Forum

Testing some - perhaps many - cams with CHDKPTP

  • 122 Replies
  • 6071 Views
*

Offline koshy

  • *****
  • 1003
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #110 on: 12 / November / 2019, 19:36:12 »
Advertisements
An image of the missing bowl:

Meanwhile, be careful not to fill up the 16M card the camera comes with :

 :D
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline reyalp

  • ******
  • 12218
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #111 on: 13 / November / 2019, 00:24:47 »
The only ones that did not pass 25/25 are A1100 and A2100.
Test builds attached.

Quote
A3400 also gives trouble in cont. In both test rounds it said "Lens Error" and the cam shut down.
Without cont A3400 was just fine.
That's weird. Can you check if there's a romlog?

Quote
This means 102 of 103 cams tested. The one that remains is Ixus iZoom which has this little charger bowl and a proprietary connector to interface with that. The usb out is on the bowl, that works, I recall testing remoteshoot with it years ago but if only I knew where that bowl went... So unless it crops up Ixus iZoom won't be tested ;-)
I think we can manage without that one  ;)
Seriously though, thanks for testing all these, it's nice to know that so many of the ports work reasonably well, and we fixed a number of bugs along the way too.
Don't forget what the H stands for.

*

Offline koshy

  • *****
  • 1003
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #112 on: 13 / November / 2019, 09:34:46 »
Quote
A3400 also gives trouble in cont. In both test rounds it said "Lens Error" and the cam shut down.
Without cont A3400 was just fine.
That's weird. Can you check if there's a romlog?
Yes
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline koshy

  • *****
  • 1003
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #113 on: 13 / November / 2019, 09:51:56 »
The only ones that did not pass 25/25 are A1100 and A2100.
Test builds attached.
That fixes those, now 25/25, ready for check in.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


*

Offline koshy

  • *****
  • 1003
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #114 on: 13 / November / 2019, 15:35:00 »
I thought it would be good to see where we are with this, a few cameras were left with failed tests. Upon reviewing my logs I thought I'd just re-test whatever failed anything other then the disconnect unable to re-connect issue that was proven to be due to my unorthodox USB setup earlier. So 14 cameras were re-tested on the XP test system out of which 8 are now fine. i65, i80, i85, i95, i110, i300, iw, tx1.

What remains:

- Ixus 30 and Powershot A410 - early VxWorks cams with won't fix issues (I'll always test the dinosaurs if anyone cares)
- Ixus 40 has a lot of trouble and maybe in the group of the above

- Powershot A550 and A560 have troubles reyalp said were known, fail 2/25

- Ixus 50 fails 2/25
- Ixus 75 fails 3/25 (new ROMLOG)
- Ixus 105 fails 1/25
- Ixus 220 crashed when CHDK is loaded and USB cable gets plugged in (new ROMLOG)
- Ixus 860 fails 1/25

That leaves 5 cams to look at and maybe improve due to these tests...
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline reyalp

  • ******
  • 12218
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #115 on: 13 / November / 2019, 23:46:05 »
That fixes those, now 25/25, ready for check in.
Done.
Quote
I thought it would be good to see where we are with this, a few cameras were left with failed tests
Very helpful.
ixus30, ixus40, a410 all fail on 52 byte transfers. I'd like to fix it, but currently lacking ideas. The following tests fail because the connection is hosed until reconnect. I should update the tests to try to reset the connection.
Ixus50, ixus75 - not sure. In lvdump, both fail with data < palette size, plus other different failures later.
ixus105 - probably remote hook problem, should be fixable
ixus220 - needs investigation. Did you check plugging in USB is OK when CHDK is not loaded?
ixus860 - missing viewport data in lvdump test, more of a test issue than a bug. Some cameras intermittently seem to have a null viewport address when there's no image in playback. This doesn't cause problems for live view, since no data is also shown as blank, but makes the test fail.
Don't forget what the H stands for.

*

Offline koshy

  • *****
  • 1003
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #116 on: 14 / November / 2019, 15:30:12 »
ixus220 - needs investigation. Did you check plugging in USB is OK when CHDK is not loaded?
Yes I meant to imply that by " crashed when CHDK is loaded and USB cable gets plugged in", I should have been more verbose. I tried without CHDK and it does not show any odd behaviour. I installed the LibUSB Driver without CHDK but as soon as I turn the camera on with a USB cable in place and a CHDK SD card inserted the cam crashes. Same with CHDK loaded and USB cable inserted with the cam already active. Same in Play and Rec modes.

ixus860 - missing viewport data in lvdump test, more of a test issue than a bug. Some cameras intermittently seem to have a null viewport address when there's no image in playback. This doesn't cause problems for live view, since no data is also shown as blank, but makes the test fail.
Good, one less to follow up on then.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline reyalp

  • ******
  • 12218
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #117 on: 14 / November / 2019, 22:33:56 »
Ixus220 issue turns out to be an old friend, continued in https://chdk.setepontos.com/index.php?topic=6341.msg141790#msg141790
Don't forget what the H stands for.


*

Offline koshy

  • *****
  • 1003
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #118 on: 23 / November / 2019, 18:03:31 »
Here are all but one missing Elph. The missing one is in the mail I guess.

I310 crashes - ROMLOG included
I230 also has something to look at.

3 others 25/25
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline koshy

  • *****
  • 1003
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #119 on: 28 / November / 2019, 08:48:43 »
The missing one is in the mail I guess.
It was and I140 is another 25/25.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

 

Related Topics