Testing some - perhaps many - cams with CHDKPTP - page 4 - General Discussion and Assistance - CHDK Forum supplierdeeply

Testing some - perhaps many - cams with CHDKPTP

  • 65 Replies
  • 1363 Views
*

Offline reyalp

  • ******
  • 12102
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #30 on: 17 / September / 2019, 22:58:14 »
Advertisements
the d10 is still from the last batch with 873
Glad that one passed, it was the original one I found the 0x23f4 bug on.

i100 failed in various ways...
Test build attached.

On any of the cameras that fail in only the reconnect test (like the D10 log), can you try connecting in the chdkptp CLI, and then using the reconnect command?
If it fails, connect again and try
Quote
reconnect -wait=5000
Don't forget what the H stands for.

*

Offline koshy

  • *****
  • 912
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #31 on: 18 / September / 2019, 18:36:55 »
i100 failed in various ways...
Test build attached.
Perfect. i100 fixed. i95 is next in line  ;)

*

Offline koshy

  • *****
  • 912
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #32 on: 18 / September / 2019, 18:51:39 »
On any of the cameras that fail in only the reconnect test (like the D10 log), can you try connecting in the chdkptp CLI, and then using the reconnect command?
If it fails, connect again and try
Quote
reconnect -wait=5000
Code: [Select]
> reconnect -wait=5000
ERROR: connection failed
In order to get anything again I need to close and restart both the cam and chdkptp

*

Offline koshy

  • *****
  • 912
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #33 on: 18 / September / 2019, 19:08:11 »
i85 and i80 have comparable issues


*

Offline koshy

  • *****
  • 912
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #34 on: 18 / September / 2019, 19:20:24 »
Since it crashed...

*

Offline koshy

  • *****
  • 912
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #35 on: 18 / September / 2019, 19:36:52 »
i70 only shows the reconnect issue, otherwise fine.
i65 shows two things.

*

Offline koshy

  • *****
  • 912
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #36 on: 18 / September / 2019, 19:53:10 »
i60 passes all
i55 fails two

*

Offline koshy

  • *****
  • 912
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #37 on: 18 / September / 2019, 20:06:34 »
i40 has a lot going on again,
i50 somewhat less...


*

Offline koshy

  • *****
  • 912
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #38 on: 18 / September / 2019, 20:19:49 »
Just as ancient i40 ancient i30 also wants help...
That is through to that end of the lot. One more a later addition to the flock i175.
This is enough for the day though.

*

Offline reyalp

  • ******
  • 12102
Re: Testing some - perhaps many - cams with CHDKPTP
« Reply #39 on: 18 / September / 2019, 23:07:12 »
For the cameras that show
Code: [Select]
filexfer:start
filexfer:failed Y:\chdkptp\trunk\874\lua\camtests.lua:196: camtest/TEST0511.dat: Permission denied
This appears to be a permission denied error for the local file on your PC, not the camera. It basically means fopen failed, which is weird. I'm not sure why this would happen, but if there's anything unusual about the filesystem where the test it running it would be good to know.

The tests use hard coded names relative the the current directory, so you shouldn't try to run more than one at once in the same directory, but I'd guess you aren't doing that.
Don't forget what the H stands for.

 

Related Topics