Issues with PowerShot SX530HS - General Help and Assistance on using CHDK stable releases - CHDK Forum  

Issues with PowerShot SX530HS

  • 1 Replies
  • 69 Views
Issues with PowerShot SX530HS
« on: 18 / September / 2019, 09:58:15 »
Advertisements
Hello all, I am new here

I recently purchased a Canon Powershot SX530HS. I have had a few issues with trying to use the SD Firmware Update method. The first issue I encountered was that when I try to find the firmware version by starting up the camera in playback mode and holding FUNC/SET then pressing DISP had no effect. I was never able to determine my firmware using this method. I am unsure why this is happening, when I created the VER.REQ file I used utf-8 encoding and ensured that the file was not saved as a txt.

Despite this initial issue I decided I could try to boot both the unstable 1.00A and 1.00C firmwares on my camera. Using the 1.00C I got an error that there was an issue with the firmware update, so I tried the 1.00A. When I did this I got the prompt "Update firmware Version"
"1.0.0.0 -> 1.1.0.0". When I select "OK", the green light next to the playback button begins flashing on and off, but all the buttons on the camera stop working and the camera does not recover from this state.

Does anyone know why neither firmware version is working on my camera? Are there other versions beside 1.00A and 1.00C? Assuming there are other versions how can I determine the version since the VER.REQ file does not seem to be working?

The SD card I am using is the Transcend Premium Class 10 8GB card Found below. If anyone could provide any ideas or suggestions to fix this problem I would be very grateful.

Thank You

https://www.amazon.com/Transcend-Speed-Flash-Memory-TS8GSDU1/dp/B00B1862ZC?psc=1&SubscriptionId=AKIAILSHYYTFIVPWUY6Q&tag=duckduckgo-ffab-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B00B1862ZC

*

Offline reyalp

  • ******
  • 12102
Re: Issues with PowerShot SX530HS
« Reply #1 on: 18 / September / 2019, 12:41:48 »
I was never able to determine my firmware using this method. I am unsure why this is happening, when I created the VER.REQ file I used utf-8 encoding and ensured that the file was not saved as a txt.
ver.req/vers.req doesn't work on many recent cameras.
Quote
Despite this initial issue I decided I could try to boot both the unstable 1.00A and 1.00C firmwares on my camera. Using the 1.00C I got an error that there was an issue with the firmware update, so I tried the 1.00A.
Assuming you mean an error in the Canon UI about the firmware file,  this sounds like you used a file for the wrong model (like SX520 instead of SX530)
Quote
When I did this I got the prompt "Update firmware Version"
"1.0.0.0 -> 1.1.0.0". When I select "OK", the green light next to the playback button begins flashing on and off, but all the buttons on the camera stop working and the camera does not recover from this state.
This sounds like you use the wrong firmware version.

I'd suggest using STICK or Chimp to prepare the card (https://chdk.fandom.com/wiki/Prepare_your_SD_card) to prepare the card or using ACID to identify the version http://www.zenoshrdlu.com/acid/acid.html
Don't forget what the H stands for.

 

Related Topics