EOS M100 porting - page 12 - DryOS Development - CHDK Forum supplierdeeply

EOS M100 porting

  • 135 Replies
  • 20652 Views
*

Offline srsa_4c

  • ******
  • 4426
Re: EOS M100 porting
« Reply #110 on: 08 / August / 2021, 14:16:58 »
Advertisements
I see it now.
Cam Settings: AV Mode, only RAW, AWB, ISO100,
+ continuous mode
Could still be a misplaced hook or an unhandled code path.

*

Offline Caefix

  • *****
  • 568
  • Sorry, busy deleting test shots...
Re: EOS M100 porting
« Reply #111 on: 11 / August / 2021, 12:56:08 »
 :)  Source #5616 seems compatible up to #5670.
Yesterday I found in a forgotten folder trunk-5671.zip.
So I thought it to be a straightforward step for Frogger ...< :o>..., compiled...
didn´t boot. (1x green LED) ...
Returned to homebuilt #5670 and got a PRIMARY.BIN...
https://ufile.io/ccyjgl3w (available for 30 :haha days.)
Cam seems to be everything alright, nevertheless, so no need to fix so far...  ::)

Edit: Related?  :blink: Romlog has: R14  : 0xE0028277, Warning/chunks=E002oooo
« Last Edit: 11 / August / 2021, 13:50:25 by Caefix »
All lifetime is a loan from eternity.

*

Offline reyalp

  • ******
  • 13363
Re: EOS M100 porting
« Reply #112 on: 11 / August / 2021, 15:44:22 »
:)  Source #5616 seems compatible up to #5670.
Yesterday I found in a forgotten folder trunk-5671.zip.
So I thought it to be a straightforward step for Frogger ...< :o>..., compiled...
didn´t boot. (1x green LED) ...
Returned to homebuilt #5670 and got a PRIMARY.BIN...
https://ufile.io/ccyjgl3w (available for 30 :haha days.)
Cam seems to be everything alright, nevertheless, so no need to fix so far...  ::)

Edit: Related?  :blink: Romlog has: R14  : 0xE0028277, Warning/chunks=E002oooo
I don't understand most of your post and I have no idea what source you were using.

That said, it looks like the first difference in the dump (at offset 0x204dc) corresponds to an address modified by MMU hacks in the m100 source I have (sub/100a/replaced.c BL_INSTR_T1(0xE00204DC, 0xE04470E2); )

So it seems the CRC check is not compatible with this port.
Don't forget what the H stands for.

*

Offline Caefix

  • *****
  • 568
  • Sorry, busy deleting test shots...
Re: EOS M100 porting
« Reply #113 on: 12 / August / 2021, 14:13:37 »
« Last Edit: 12 / August / 2021, 14:23:08 by Caefix »
All lifetime is a loan from eternity.


*

Offline srsa_4c

  • ******
  • 4426
Re: EOS M100 porting
« Reply #114 on: 28 / August / 2021, 17:38:11 »
I see it now.
Cam Settings: AV Mode, only RAW, AWB, ISO100,
+ continuous mode
FWIW, this has become a blocker - I still couldn't solve this crash. It can also be triggered by using hooktest.lua. Shooting CHDK raw in continuous mode with native raw is not a problem, so it's not about spending time in the raw hook. The M10 (as closest ILC port) has no similar issue.

*

Offline c_joerg

  • *****
  • 1129
Re: EOS M100 porting
« Reply #115 on: 29 / August / 2021, 03:42:52 »
But it was already possible in the older version. Pure random? That it also depended on the lens seems to be a timing problem right?
M100 100a, M3 101a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline srsa_4c

  • ******
  • 4426
Re: EOS M100 porting
« Reply #116 on: 29 / August / 2021, 10:37:05 »
But it was already possible in the older version.
Can you tell me which source and the CHDK revision it was applied to?
Quote
Pure random?
I'm always getting the same crash (a firmware variable at one particular RAM address is causing the trouble), despite my attempts to move CHDK around in memory (and downgrading to older source).

When I'm looking at the camera log, I get the feeling that the raw data of photos is first put in a "buffer" (as there are several raw buffers), and those buffers are compressed and written in parallel (independently from capt_seq).

*

Offline c_joerg

  • *****
  • 1129
Re: EOS M100 porting
« Reply #117 on: 29 / August / 2021, 12:50:56 »
Can you tell me which source and the CHDK revision it was applied to?
In the last version I mixed up sources. If it's important to you I could try to undo this

But I still found a completely older version „m100-100a-1.5.0-5575 Oct 12 2020 17:13:37“ including a rawopint log file. Maybe that will help.

M100 100a, M3 101a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd


*

Offline srsa_4c

  • ******
  • 4426
Re: EOS M100 porting
« Reply #118 on: 29 / August / 2021, 13:31:00 »
But I still found a completely older version „m100-100a-1.5.0-5575 Oct 12 2020 17:13:37“ including a rawopint log file. Maybe that will help.
Thanks. That build crashes as well. I get the feeling that this issue has always been there, but it only causes a crash under certain conditions. I could reproduce it with the "traditional" (= no MMU trickery) source too.

*

Offline reyalp

  • ******
  • 13363
Re: EOS M100 porting
« Reply #119 on: 29 / August / 2021, 17:51:07 »
Thanks. That build crashes as well. I get the feeling that this issue has always been there, but it only causes a crash under certain conditions. I could reproduce it with the "traditional" (= no MMU trickery) source too.
If you have a reliable test case, it would be interesting to know if g7x II has the same problem.

Also, do you have a link for your current source? I've kind of lost track.
Don't forget what the H stands for.

 

Related Topics