EOS M100 porting - page 19 - DryOS Development - CHDK Forum

EOS M100 porting

  • 194 Replies
  • 32927 Views
*

Offline srsa_4c

  • ******
  • 4450
Re: Re: eos M10 port
« Reply #180 on: 25 / June / 2022, 16:36:43 »
Advertisements
As I see fi2enc can pack only one data block - the updater. But we also need at least one more for firmware dump(excluding user data, calibration data etc.)
If you use a patched original updater, you don't need other data blocks. Card can be accessed, just read the data from there.
Quote
Did you manage to unpack M1000110.FI2 ?
You might be looking for  offset 0x19ec0 of the 100a dump.

*

Offline Ant

  • *****
  • 509
Re: Re: eos M10 port
« Reply #181 on: 25 / June / 2022, 16:57:56 »
If you use a patched original updater, you don't need other data blocks. Card can be accessed, just read the data from there
Do you think that patching the updater is easier than modifying the header of fi2 file?

Quote
You might be looking for  offset 0x19ec0 of the 100a dump.
No. I'm looking for the address of IV key.

*

Offline reyalp

  • ******
  • 13716
Re: EOS M100 porting
« Reply #182 on: 25 / June / 2022, 17:02:59 »
Everyone is welcome to do what they want of course, but FWIW, I would not personally recommend using a hacked upgrader to overwrite the Canon firmware in order to use a CHDK port the author does not consider stable enough for general use.

Porting the existing code to a new sub would be far safer and likely not significantly more effort.
Don't forget what the H stands for.

*

Offline srsa_4c

  • ******
  • 4450
Re: EOS M100 porting
« Reply #183 on: 25 / June / 2022, 17:07:50 »
I would not personally recommend using a hacked upgrader to overwrite the Canon firmware in order to use a CHDK port the author does not consider stable enough for general use.
I would not either, I was just answering Ant's post.
I'm looking for the address of IV key.
You can take the IV of any recent camera (it has not changed).


Re: EOS M100 porting
« Reply #184 on: 27 / June / 2022, 10:56:21 »
OK I've got my M100 today, but can't get the firmware version.

I have formated a 32Gb card in the camera.

I have both ver.req and vers.req text files on the card.

I press SET and at the same time press INFO

Nothing :-(

Any help gratefully received.
« Last Edit: 27 / June / 2022, 11:03:51 by pigeonhill »

*

Offline Caefix

  • *****
  • 856
  • Sorry, busy deleting test shots...
Re: EOS M100 porting
« Reply #185 on: 27 / June / 2022, 11:13:08 »
All lifetime is a loan from eternity.

Re: EOS M100 porting
« Reply #186 on: 27 / June / 2022, 11:29:51 »
OK, I got there using the Jeffrey Friedl LR EXIF viewer.

I got:

Canon Firmware Version = Firmware Version 1.00 and under Firmware Revision I have 1.00 rev 1.00.

I guess this means I have a 100a camera :-)

Cheers

Garry


Update: but can’t understand why I couldn’t get the PLAY plus press two buttons to work ?
« Last Edit: 27 / June / 2022, 11:59:12 by pigeonhill »

*

Offline srsa_4c

  • ******
  • 4450
Re: EOS M100 porting
« Reply #187 on: 27 / June / 2022, 16:14:27 »
a r6048 based build just crashed on me, and it fails to mask the "jogdial" in ALT mode for some unknown reason.
Turned out this (non-working masking) was caused by an unreleased change of mine that prevented the second ARM core from getting the modified MMU setup. It looked so benign that I missed it.
can’t understand why I couldn’t get the PLAY plus press two buttons to work ?
That method doesn't work on all models.


*

Offline Ant

  • *****
  • 509
Re: EOS M100 porting
« Reply #188 on: 27 / June / 2022, 18:05:35 »
I couldn’t get the PLAY plus press two buttons to work ?
Why two buttons? "Play" then "Set" works on EOS M3.

Re: EOS M100 porting
« Reply #189 on: 27 / June / 2022, 20:51:08 »
I couldn’t get the PLAY plus press two buttons to work ?
Why two buttons? "Play" then "Set" works on EOS M3.

press the func set+disp. buttons together (i.e. press set first, keep holding it down, then press disp.).

 

Related Topics