EOS M3 - Disable LCD Off doesn't work - General Help and Assistance on using CHDK stable releases - CHDK Forum

EOS M3 - Disable LCD Off doesn't work

  • 35 Replies
  • 1732 Views
EOS M3 - Disable LCD Off doesn't work
« on: 06 / February / 2020, 16:25:59 »
Advertisements
Hello. Recently found out about CHDK and was really surprised that there was a version for EOS M3. I immediately Prepared SD Card and downloaded the latest version for my camera.

Most of the functions and some scripts do work! But the main function I need is - Disable LCD Off. I tried to use all 3 modes: Always, Alt, Script, but none of them seem to work. Camera always shuts its screen after 3 minutes. Please can anyone suggest what might be wrong? Maybe there is an external script that I can load?

Thanks.

Mode: Video
Firmware: 1.2.0

*

Offline srsa_4c

  • ******
  • 4230
Re: EOS M3 - Disable LCD Off doesn't work
« Reply #1 on: 07 / February / 2020, 19:45:51 »
But the main function I need is - Disable LCD Off. I tried to use all 3 modes: Always, Alt, Script, but none of them seem to work. Camera always shuts its screen after 3 minutes.
That is basic functionality, I don't remember seeing it fail on any camera. If any other M3 user could comment whether it works, that would be great.

Re: EOS M3 - Disable LCD Off doesn't work
« Reply #2 on: 08 / February / 2020, 01:48:45 »
So I spent some time digging. Can confirm that if on load LCD off is ALWAYS, then it doesn't work.

But when I set LCD off to ALT on load, and after the camera is turned on change it to ALWAYS, then it does work.

Not a big deal for me, don't know why it happens though.

Re: EOS M3 - Disable LCD Off doesn't work
« Reply #3 on: 08 / February / 2020, 06:56:37 »
 
That is basic functionality, I don't remember seeing it fail on any camera. If any other M3 user could comment whether it works, that would be great.
I have an M3 101a.
On Canon Menue, I select 1min for Display off.
On CHDK Display LCD OFF => ALT, it never goes off in ALT Mode.
On CHDK Display LCD OFF => ALWAYS, it never goes off.
M100 100a, M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd


*

Offline srsa_4c

  • ******
  • 4230
Re: EOS M3 - Disable LCD Off doesn't work
« Reply #4 on: 08 / February / 2020, 07:16:27 »
So I spent some time digging. Can confirm that if on load LCD off is ALWAYS, then it doesn't work.

But when I set LCD off to ALT on load, and after the camera is turned on change it to ALWAYS, then it does work.
Thanks, that's useful observation.

I have an M3 101a.
On Canon Menue, I select 1min for Display off.
On CHDK Display LCD OFF => ALT, it never goes off in ALT Mode.
On CHDK Display LCD OFF => ALWAYS, it never goes off.
Thanks. Can you try the following?
Set CHDK Display LCD OFF => ALWAYS, exit CHDK menu (to save the setting), power off the camera, start it in rec  mode and don't touch it (don't enter ALT mode). Does it shut down the LCD after 1 minute?

Re: EOS M3 - Disable LCD Off doesn't work
« Reply #5 on: 08 / February / 2020, 08:36:43 »
 
Can you try the following?
Set CHDK Display LCD OFF => ALWAYS, exit CHDK menu (to save the setting), power off the camera, start it in rec  mode and don't touch it (don't enter ALT mode). Does it shut down the LCD after 1 minute?
No, I checked it for 6 Minutes. The display is still on.
 
 
M100 100a, M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline srsa_4c

  • ******
  • 4230
Re: EOS M3 - Disable LCD Off doesn't work
« Reply #6 on: 08 / February / 2020, 08:44:56 »
No, I checked it for 6 Minutes. The display is still on.
Thanks again.

@m3babyjesus
Can you repeat this experiment on your camera?

Set CHDK Display LCD OFF => ALWAYS, exit CHDK menu (to save the setting), power off the camera, start it in rec mode and don't touch it (don't enter ALT mode). Does it shut down the LCD after 3 minutes (or whatever delay you set in Canon menu)?

Re: EOS M3 - Disable LCD Off doesn't work
« Reply #7 on: 09 / February / 2020, 07:21:14 »
Yes, I recorded a video. The behaviour is the same.

While we are on the same page, does anyone know whether it is possible to:
1) Keep the LCD ON when HDMI is connected?
2) Transmit audio over HDMI?



*

Offline srsa_4c

  • ******
  • 4230
Re: EOS M3 - Disable LCD Off doesn't work
« Reply #8 on: 09 / February / 2020, 07:58:22 »
Yes, I recorded a video. The behaviour is the same.
I see.
I'll have a look at differences between the 101a and 120f ports, but I don't think I'll find any significant difference.
What I would suspect is that, when set to 'ALWAYS', CHDK attempts to disable power saving too early. Timing might depend on card, so if you have more cards, you could try and see whether you get the same issue while using a different card.
One additional thing you could try is to enter/exit ALT mode momentarily after the cam starts.

Quote
While we are on the same page, does anyone know whether it is possible to:
1) Keep the LCD ON when HDMI is connected?
The LCD and HDMI are independent output devices. Unless the firmware implements their simultaneous use (which is highly unlikely), this can't be done.
Quote
2) Transmit audio over HDMI?
This would also need firmware support, so the answer is also "no".

Side note:
The CHDK overlay behaves much better in playback mode, so whenever you need to spend time in CHDK menu, consider switching to playback.

Re: EOS M3 - Disable LCD Off doesn't work
« Reply #9 on: 09 / February / 2020, 09:55:38 »
Thanks for reply, thought just so.

Is it possible to autostart the recording when the camera is turned on OR autoload a script on launch that will trigger the recording? Is it possible?

That would partially solve my problem  :)

 

Related Topics