EOS M3 - Disable LCD Off doesn't work - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

EOS M3 - Disable LCD Off doesn't work

  • 31 Replies
  • 699 Views
Re: EOS M3 - Disable LCD Off doesn't work
« Reply #10 on: 10 / February / 2020, 09:59:53 »
Advertisements
Is it possible to autostart the recording when the camera is turned on OR autoload a script on launch that will trigger the recording?
You can set the currently selected script to autostart when the camera powers on.  A short script to start recording would then do what you want.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: EOS M3 - Disable LCD Off doesn't work
« Reply #11 on: 10 / February / 2020, 10:29:46 »
Yes, got it working.

Re: EOS M3 - Disable LCD Off doesn't work
« Reply #12 on: 10 / February / 2020, 13:49:08 »
Guys, we are almost there. One last problem is that when I have HDMI mini cable connected to Monitor on startup - the camera's screen turns on for a second, and then the whole thing shuts down.

I tried it without CHDK and it works as intended. Video feed is sent to HDMI output as soon as camera is started.

*

Offline srsa_4c

  • ******
  • 4105
Re: EOS M3 - Disable LCD Off doesn't work
« Reply #13 on: 10 / February / 2020, 15:08:00 »
One last problem is that when I have HDMI mini cable connected to Monitor on startup - the camera's screen turns on for a second, and then the whole thing shuts down.

I tried it without CHDK and it works as intended. Video feed is sent to HDMI output as soon as camera is started.
Please get a romlog. Miscellaneous stuff -> Debug parameters -> Save ROM crash log

BTW, there is a small difference between 101a and 120f: 101a has something debug-related enabled in boot.c (commented as "Enable TIO"). Probably not significant, but if it is, it only masks the real problem.


Re: EOS M3 - Disable LCD Off doesn't work
« Reply #14 on: 10 / February / 2020, 15:50:09 »
I guess this is it. At this point i am thinking maybe it's better to downgrade a firmware? Is it possible?

*

Offline reyalp

  • ******
  • 12366
Re: EOS M3 - Disable LCD Off doesn't work
« Reply #15 on: 10 / February / 2020, 15:52:19 »
Guys, we are almost there. One last problem is that when I have HDMI mini cable connected to Monitor on startup - the camera's screen turns on for a second, and then the whole thing shuts down.
Does this always happen when CHDK is running, or just with the startup script?

FWIW, it could be similar to some issues I saw with analog video https://chdk.setepontos.com/index.php?topic=13451.50

edit:
Looks like it is similar:
Code: [Select]
ASSERT!! MakeOsdVram.c Line 603
Occured Time  2020:02:10 23:47:08
Task ID: 16646180
Task name: SpyTask

@m3babyjesus there's no need to change firmware version. If the difference srsa_4c mentioned is significant, the CHDK port can be made like the other one. In any case, a workaround should be possible.
« Last Edit: 10 / February / 2020, 15:54:02 by reyalp »
Don't forget what the H stands for.

Re: EOS M3 - Disable LCD Off doesn't work
« Reply #16 on: 10 / February / 2020, 15:54:27 »
Guys, we are almost there. One last problem is that when I have HDMI mini cable connected to Monitor on startup - the camera's screen turns on for a second, and then the whole thing shuts down.
Does this always happen when CHDK is running, or just with the startup script?

FWIW, it could be similar to some issues I saw with analog video https://chdk.setepontos.com/index.php?topic=13451.50
I tried with autoscript and without, camera shuts down on both occasions.

*

Offline reyalp

  • ******
  • 12366
Re: EOS M3 - Disable LCD Off doesn't work
« Reply #17 on: 10 / February / 2020, 16:43:59 »
Here's a test build with the same workaround I used for the similar crash with analog video.

edit:
removed, HDMI_HPD_FLAG not defined
« Last Edit: 10 / February / 2020, 17:22:38 by reyalp »
Don't forget what the H stands for.


Re: EOS M3 - Disable LCD Off doesn't work
« Reply #18 on: 10 / February / 2020, 17:00:50 »
Unfortunately, this didn't work for me.

*

Offline reyalp

  • ******
  • 12366
Re: EOS M3 - Disable LCD Off doesn't work
« Reply #19 on: 10 / February / 2020, 17:21:39 »
Unfortunately, this didn't work for me.
Oops, the HDMI bit isn't defined in the M3 port. We need to find that before it can work. Attached is new build that will show a list of values at the bottom of the screen. I need to know which values change when you connect / disconnect HDMI.


Don't forget what the H stands for.

 

Related Topics