Live view (video out) in shot mode - page 2 - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum

Live view (video out) in shot mode

  • 12 Replies
  • 3805 Views
*

Offline reyalp

  • ******
  • 13457
Re: Live view (video out) in shot mode
« Reply #10 on: 09 / March / 2020, 15:28:13 »
Advertisements
- Camera has to be unmounted. This was the reason why I couldn't connect
Normally, if the camera is mounted by standard linux software, that will cause other problems too. See the section about udev in https://app.assembla.com/spaces/chdkptp/wiki/Install

Depending on configuration, you may encounter the permission issue mentioned at the bottom on raspberry pi.
Quote
- I confirm the reconnection issue https://chdk.setepontos.com/index.php?topic=13997.0 an the same solution works for me. The reconnection issue only happens when connected to usb 3. No issue with usb 2. No hubs used
Thanks, that's a useful datapoint.
Don't forget what the H stands for.

Re: Live view (video out) in shot mode
« Reply #11 on: 10 / March / 2020, 01:40:17 »
The reconnection issue only happens when connected to usb 3. No issue with usb 2

This was for the r921 without the usb reset command (set usb_reset_on_close=true)

I have to add: The reconnection issue only happens when connected to usb 3. No issue with usb 2 if in rec mode

So r921 without the usb reset commend only works if connected to usb 2 and in rec mode

Using r795 or r921 with usb reset there is no issue wheter in play or rec mode

One thing I've noticed is that rec command opens the lens if initially in play mode but play command puts the camera in play mode but it doesn't close the lens


Normally, if the camera is mounted by standard linux software, that will cause other problems too. See the section about udev in https://app.assembla.com/spaces/chdkptp/wiki/Install

I've added the udev rules to avoid automount for convenience though manual dismount also works for me... but damn... I've to read the docs, read the docs...    :-[
« Last Edit: 10 / March / 2020, 02:11:41 by DanielGeA »

*

Offline reyalp

  • ******
  • 13457
Re: Live view (video out) in shot mode
« Reply #12 on: 10 / March / 2020, 02:17:18 »
The reconnection issue only happens when connected to usb 3. No issue with usb 2

This was for the r921 without the usb reset command (set usb_reset_on_close=true)

I have to add: The reconnection issue only happens when connected to usb 3. No issue with usb 2 if in rec mode

So r921 without the usb reset commend only works if connected to usb 2 and in rec mode
I've now reproduced the issue on an 18.04.4 box on both USB3 and 2 ports  :blink:

I changed the code in svn to reset by default again for linux.

Quote
One thing I've noticed is that rec command opens the lens if initially in play mode but play command puts the camera in play mode but it doesn't close the lens
This is normal Canon behavior, should be similar if you press the play button. There should be a setting in the Canon menu for how long it waits after switching to play.

Quote
I've added the udev rules to avoid automount for convenience though manual dismount also works for me... but damn... I've to read the docs, read the docs...    :-[
The docs are not always the clearest  :-[
Don't forget what the H stands for.

 

Related Topics