Huge Ubasic bug - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

Huge Ubasic bug

  • 12 Replies
  • 4966 Views
*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Huge Ubasic bug
« Reply #10 on: 27 / May / 2008, 17:03:56 »
Advertisements
I couldn't run your debugger. I execute the BAT file and get this:

C:\Downloads\CHDK>java -cp UBDB.jar UBDebugUI
Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
        at java.lang.ClassLoader.defineClass1(Native Method)


I have the JVM. Is there something else I need?

I get this message if ubdb.jar file not present in current directory.

*

Offline wontolla

  • ****
  • 413
  • S3 & G9 & A720
Re: Huge Ubasic bug
« Reply #11 on: 27 / May / 2008, 17:29:25 »
Yep, I have the JAR file in the same directory, still I can't run it. Even if I double click it I get a window saying:
Failed to load Main-Class manifest attribute from C:\...UBD.jar

But if you guys can run it, then it's a problem with my computer. I'll check it out.


Edit: Now it works! Ignore me, I'm getting old. I had J2SE Runtime Environment, but donwloaded fresh JVM.
Download Java software for Windows from Sun Microsystems
« Last Edit: 27 / May / 2008, 17:39:27 by wontolla »

*

Offline zeno

  • *****
  • 889
Re: Huge Ubasic bug
« Reply #12 on: 27 / May / 2008, 17:49:28 »
Glad to see people are interested. It might be better if comments were added to the other thread - here Any interest in an interactive UBasic debugger for PC (or Mac?)

My apologies for the duplication.
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

 

Related Topics