How to set values for shoot automatically - Script Writing - CHDK Forum supplierdeeply

How to set values for shoot automatically

  • 4 Replies
  • 1105 Views
How to set values for shoot automatically
« on: 31 / March / 2021, 05:39:08 »
Advertisements
Hello everyone,

I tryed to set the values of ISO, obturation and disable flash by script for shooting. But I doesn't resolve this. In my code you can see I try to set the values but when the camera shoots this values are automatically choosed by the camera.

Code: [Select]
props=require'propcase'
require'hookutil'
logfile=io.open("A/dades.log","wb")
io.output(logfile)

function log(...)
  io.write(...)
  io.write("\n")
end

log("Nit")
set_sv96(iso_to_sv96(800))
set_tv96(usec_to_tv96(10000))
get_flash_mode(2)

press('shoot_half')
repeat sleep(10) until get_shooting() == true
press'shoot_full_only'

log("IMG_".. string.format("%04d",get_exp_count())..".JPG")
logfile:close()


Anybody how to make this? There are any mistake for my part? Thanks!
« Last Edit: 31 / March / 2021, 10:05:21 by ardedi7 »

*

Offline reyalp

  • ******
  • 13456
Re: How to set values for shoot automatically
« Reply #1 on: 31 / March / 2021, 12:39:53 »
Anybody how to make this? There are any mistake for my part? Thanks!
That mostly looks like it should work, what camera and what shooting mode (P, M, Tv...) are you using?

I think you want set_flash_mode not get_flash_mode as you have now.

Don't forget what the H stands for.

Re: How to set values for shoot automatically
« Reply #2 on: 21 / April / 2021, 05:19:22 »
My camera is Ixus 100 is and only have three modes (video, auto and program). I try to set a manual mode but I don't know how set it.

There are any solution?

*

Offline reyalp

  • ******
  • 13456
Re: How to set values for shoot automatically
« Reply #3 on: 21 / April / 2021, 12:38:19 »
My camera is Ixus 100 is and only have three modes (video, auto and program). I try to set a manual mode but I don't know how set it.
You are correct, there is no manual mode on your camera. CHDK overrides do not require a manual mode, but I would generally expect program to be less likely to have problems than Auto or special scene modes.

Your script looks like it should set the shutter and ISO.

How are you determining which settings the camera used? The exif can sometimes record the wrong values, but you should able to see if overrides are actually working by setting different values and seeing if the exposure changes.

Have you tried overrides from the "enhanced photo operations" menu?
Don't forget what the H stands for.


Re: How to set values for shoot automatically
« Reply #4 on: 21 / April / 2021, 13:10:23 »
No, but now I set the iso by set_prop and with this works.

Thanks

 

Related Topics