Installation on European IXUS 800IS model? - General Help and Assistance on using CHDK stable releases - CHDK Forum

Installation on European IXUS 800IS model?

  • 13 Replies
  • 7416 Views
Installation on European IXUS 800IS model?
« on: 11 / December / 2007, 16:14:40 »
Advertisements
Hi all

There is an SD700 firmware available at http://chdk.wikia.com/wiki/SD700_CHDK_Porting. Since the European IXUS 800IS is identical to the SD700, this firmware should fit that camera as well. But it doesn't install. Is there some trick to convince it that this is, in fact, the same camera?

I tried putting Canon's official SD 700 firmware on the camera to make CHDK happy, but the official firmware realizes it's a European-branded model and refuses to install as well.

*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: Installation on European IXUS 800IS model?
« Reply #1 on: 11 / December / 2007, 16:27:53 »
What version of the firmware do you have in your camera? (Hint)

Quote
I tried putting Canon's official SD 700 firmware on the camera to make CHDK happy, but the official firmware realizes it's a European-branded model and refuses to install as well.
Do you have the official update? Where did you get it? Or you tried to put the firmware dump back?
CHDK Developer.

Re: Installation on European IXUS 800IS model?
« Reply #2 on: 11 / December / 2007, 16:39:46 »
The official firmware is linked from the SD700 porting page. It should be located at http://www.zshare.net/download/4756192ec57bc6/, but this link seems to have since gone dead.

The firmware was a single file. I put it into the root directory of my camera and started in play mode. The firmware update link was there in the menu, but refused to actually update the firmware. Searching through Canon's site right now, I don't seem to be able to locate an SD700 firmware anywhere.

Re: Installation on European IXUS 800IS model?
« Reply #3 on: 11 / December / 2007, 16:44:03 »
I missed the question about my firmware version. It's 1.01B, same as the current SD700 firmware.


*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: Installation on European IXUS 800IS model?
« Reply #4 on: 11 / December / 2007, 16:53:37 »
The link you mentioned contains NOT a firmware update. It's just a dump of actual firmware from someone camera. It's not intended to put it back, that why your camera refuses it.
But there should be no differences between SD700 and IXUS800 in terms of firmware. At least, for pairs SD500(IXUS 700)  | SD400 (IXUS50) the official Canon's update is the same file for each couple.
CHDK Developer.

Re: Installation on European IXUS 800IS model?
« Reply #5 on: 11 / December / 2007, 16:58:13 »
The link you mentioned contains NOT a firmware update. It's just a dump of actual firmware from someone camera. It's not intended to put it back, that why your camera refuses it.

Fair enough. I guess it's good then that the camera was smart enough to refuse it. I have no desire to brick it :).

But there should be no differences between SD700 and IXUS800 in terms of firmware.

I agree and don't expect there to be any differences. Still, CHDK for the SD700 doesn't like an IXUS 800IS. When trying to load the CHDK firmware, the camera power-cycles and no new menu items appear. In the documentation, this is explained as the camera refusing a firmware that doesn't fit.

*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: Installation on European IXUS 800IS model?
« Reply #6 on: 11 / December / 2007, 17:00:31 »
It's 1.01B, same as the current SD700 firmware.
So far I do not see any obstacles why CHDK could not run.
CHDK Developer.

*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: Installation on European IXUS 800IS model?
« Reply #7 on: 11 / December / 2007, 17:04:41 »
When trying to load the CHDK firmware, the camera power-cycles and no new menu items appear. In the documentation, this is explained as the camera refusing a firmware that doesn't fit.
So, the camera did not halt or switch off. It's good.
Did the camera show a blue splash-screen and blink by blue LED? Are there any new OSD elements on the LCD? Have tried pressing the [direct print] button, and then [menu] button?
CHDK Developer.


Re: Installation on European IXUS 800IS model?
« Reply #8 on: 11 / December / 2007, 17:07:13 »
Did the camera show a blue splash-screen and blink by blue LED?

No

Are there any new OSD elements on the LCD?

No

Have tried pressing the [direct print] button, and then [menu] button?

Yes. [Direct print] does nothing, while [menu] opens up the menu with all the original items; nothing new in there.

*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: Installation on European IXUS 800IS model?
« Reply #9 on: 11 / December / 2007, 17:20:29 »
So, you did the following:
  • Put the files PS.fir and Diskboot.bin into the root folder of your SD card.
  • Put the SD card back into the camera.
  • Started the camera in Play mode.
  • Pressed the Menu button.
  • Went to the new menu entry "Firm Update".
  • Selected that function and confirmed that you want to update with "OK".

Camera reboots (as expected) but nothing happened. Strange...  :blink:

Did you try different versions from here.
CHDK Developer.

 

Related Topics