Lens error details for S110 - Hotwire! Hardware Mods, Accessories and Insights - CHDK Forum supplierdeeply

Lens error details for S110

  • 4 Replies
Lens error details for S110
« on: 01 / May / 2021, 18:41:12 »
My S110 camera issues lens error when I switch it on. I already once exchanged the objective with a new one, which I got from China. It worked for a few moths. But now, this one issues again a lens error. The camera extends the lens, but then it cannot retract it and the error appears. I disassembled the camera and also the objective, but I cannot see any damage. I also tried removing and replacing the flat ribbon cables into their sockets, like proposed in one of the posts in this forum, but that doesn't fix the problem.
The objective has several parts: Two servo motors (one for the objective movement, another for the lens focus), various sensors and the image stabilizer. I don't know, which one is defect. If I knew which one is defect, I might be able to repair the camera without ordering again a new objective.
The error just gives the information, that something is wrong, but no details.
Now CHDK might come into play:
Is there any possibility to get information about the details of the lens error? Is it possible to check the objective's components like the camera does during power up?
« Last Edit: 01 / May / 2021, 18:44:05 by waffenschmidt »


Offline reyalp

  • ******
  • 14082
Re: Lens error details for S110
« Reply #1 on: 01 / May / 2021, 18:59:37 »
If you can get the romlog (https://chdk.fandom.com/wiki/Debugging#Camera_crash_logs_.28romlog.29) that may provide some clues about the specific error.

Does the camera start if you start with the play button and don't switch to record mode? If so, you can use CHDK or the Canon basic romlog script. If not, we may be able to provide a special build that immediately dumps the romlog on boot.
Don't forget what the H stands for.

Re: Lens error details for S110
« Reply #2 on: 01 / May / 2021, 19:24:30 »
OK thank's, I'll check it.

Re: Lens error details for S110
« Reply #3 on: 02 / May / 2021, 01:34:45 »
This is a very common problem that I get with my S110 cameras, it is due to the ribbon cable inside the lens that goes to the aperture motor fatiguing as it is not a proper flex cable (the one going to the image stabilization module is a proper flex cable made from different material and I have never had problems with that). There is a photodiode in the aperture module soldered onto this cable that senses if the aperture is wide open, which is required for the lens to retract as one of the lens elements extends through the aperture when it retracts.

Unfortunately the replacement cables from ebay/aliexpress seem to be made out of the same material and also fatigue eventually, I have replaced them at least a few times on each of my S110 cameras over a few years, though I try to minimize lens retractions where possible. There does not seem to be any other option though for a permanent fix as far as I know.

The replacement cable looks like the one attached. If it doesn't come with a photodiode it will need to be desoldered from the old ribbon cable onto the new one which is easiest with a hot air rework station. For soldering the stepper motor I find it easiest to cut the old cable off with a razor blade next to the motor and solder the new one over the top as the pins on the motor are fragile.

Edit: Always a small possibility it could be something else but 99% chance it is the aperture cable. The old aperture cable may look fine at first but upon closer inspection you can see a small fatigue crack through the substrate and at least one of the traces.
« Last Edit: 02 / May / 2021, 01:52:40 by Recyclojunk64 »

Re: Lens error details for S110
« Reply #4 on: 05 / May / 2021, 08:57:47 »
Thank's for all your hints.
I just ordered a ribbon cable on ebay. It will come from China to Germany, so the estimated time of arrival is begin of June. I'll try again then with the new cable and then also try reading the ROM data.


Related Topics