- Override display off for liveview - General Discussion and Assistance - CHDK Forum  

- Override display off for liveview

  • 2 Replies
  • 146 Views
- Override display off for liveview
« on: 21 / May / 2021, 14:17:08 »
Advertisements
Hi!

I'm trying to use my G7X Mark II for streaming. I'm successfully sending the HDMI signal to my computer... but the camera shuts it down every 3 minutes. I loaded CHDK looking for and option to override it, but I found none. Is there a way to override it?

My next plan was to write a script to press a button every X seconds, but I think the camera will need to stay in <alt> mode, which will include an <alt> icon on the screen. Is there a way to hide the <alt> icon?

Alternatively, is there a way I can prevent the display from going off by running a script outside <alt> mode?

Cheers,

*

Offline reyalp

  • ******
  • 13230
Re: - Override display off for liveview
« Reply #1 on: 21 / May / 2021, 15:09:39 »
CHDK Settings->Disable LCD Off = Always should prevent the display from turning off. However, there have been some reports of this failing with HDMI out on some cams for reasons that aren't currently fully understood: https://chdk.setepontos.com/index.php?topic=13993.0

Quote
My next plan was to write a script to press a button every X seconds, but I think the camera will need to stay in <alt> mode, which will include an <alt> icon on the screen. Is there a way to hide the <alt> icon?
It is possible to exit alt mode with a script running, see here https://chdk.setepontos.com/index.php?topic=14341.0 for technical details.

The tl;dr is normal CHDK scripted key presses probably won't work if you exit alt, but you could use post_levent_to_ui. You'd need to find one that reset the power saving timer without doing anything that disrupts your streaming.
Don't forget what the H stands for.

Re: - Override display off for liveview
« Reply #2 on: 21 / May / 2021, 17:13:24 »
Quote
CHDK Settings->Disable LCD Off = Always should prevent the display from turning off. However, there have been some reports of this failing with HDMI out on some cams

Awesome!

FWIW, it does work for me (G7X Mark II, firmware 1.1.0.0b, CHDK g7x2-110b-1.5.1-5908-full_PREALPHA with Bootable SD Card). I set it up to `Always` just once, and still works after a restart without going to <Alt> mode.

 

Related Topics